You are not logged in.

#1 2013-04-10 09:46:30

klemmster
Member
Registered: 2011-11-13
Posts: 9

Pulseaudio stops when in TTY

Dear Arch Community,

I'm running gnome3, but since I've setup kmscon as tty replacement I find myself using vim in TTY rather than gvim in gnome3, as there are less (no) distractions.

However, whenever I switch to TTY (eg. Strg+Alt + F2) mplayer stops playing, "audio device got stuck".
Switching back to gnome, it continues playing.

I'm not quite sure where to look and how to prevent this problem.

It seems that 'someone' stops the pulseaudio-daemon when switching to TTY.
Any hints?

I can't just start another pulseaudio-session in tty as it can't connect to dbus, which relies on X11 apparently.

Against Arch linux philosophy of staying in control, I feel like i've lost it.

Any help would be appreciated.

Richy

Offline

#2 2013-04-10 10:57:09

mzneverdies
Member
Registered: 2012-02-04
Posts: 147

Re: Pulseaudio stops when in TTY

on a recent pulseaudio update, this output was posted

 Autospawn is now disabled by default. If you need to run PulseAudio outside of an X session, either:
      - Enable autospawn in client.conf, or
      - Start it manually by executing 'pulseaudio --start'

you can check pulseaudio.install here: https://projects.archlinux.org/svntogit … pulseaudio

Offline

#3 2013-05-04 06:43:32

klemmster
Member
Registered: 2011-11-13
Posts: 9

Re: Pulseaudio stops when in TTY

Thanks for you response.

However, neither Version works.

autospawn in client.conf seems to have no effect.

If I try to start pulseaudio manually it logs that "another instance is already running."

If i start audio - playback in gnome and switch to tty, audio still get's stuck and continues once I return to gnome..

*sigh*

Any other ideas?

Offline

#4 2013-05-25 13:05:08

artiom
Member
From: France
Registered: 2008-07-29
Posts: 108

Re: Pulseaudio stops when in TTY

I have the same issue after my last upgrade. I have two X sessions and when I switch between them sound stops in one and starts in other. I don't think it is a bug, but a feature wink.
It has another side effect - MPD is not playing in background. The system wide pulse is not a solution as it is strongly discouraged by upstream and has a lot of limitations.
I tried to search the web about it and found that this behaviour can be achieved (and changed) with polkit.
I found this command to enable inactive sessions to play sound:

sudo polkit-action --set-defaults-inactive org.freedesktop.hal.device-access.sound yes

Unfortunately I didn't find polkit-action in my current Arch installation. Seems like it is replaced by pkaction.
pkaction gives me a list with rules, but there is no org.freedesktop.hal.device-access.sound

Now I have no more ideas where to look forward. Please help

Offline

Board footer

Powered by FluxBB