You are not logged in.

#1 2013-04-09 08:38:51

RobvG
Member
Registered: 2013-04-09
Posts: 4

Smbnetfs not showing workgroup(s) anymore

Hi there,

After trying to fix this myself for the last weeks I'v decided to ask for help here wink

My problem is that smbnetfs is running (systemd), fuse is working, there are no errors (that I know of, doesn't say much though) and all the files have the proper rights set.

However: /mnt/smbnet is empty. No workgroups, nothing. I can actually cd to my NAS and browse the folders under /mnt/smbnet/NAS however this directory doesn't show up in smbnet. Nor shouldn't it. The proper url: /mnt/smbnet/WORKGROUP/NAS is inaccesible (i/o error).

I can browser the NAS with smbclient and it works like a charm. Manual mounting under fstab works, kinda. The NAS usually doesn't respond fast enough (even though we're talking gigabit here) and usually fails to mount one of two directories ('music' and 'home') on boot when using the fstab solution and I have to manually mount it when running (which defeats the point of it being a headless server).

smbnetfs used to work though after the latest update it's very much not working.

I thought it was a master browser problem and it turns out there where two master browsers on my network (new router, found it under "usb applications" of all places) though that did fix intermittent problems with a mediaplayer unit it hasn't fixed my arch setup(s).

Help?

Kind regards,

Rob

Offline

#2 2013-04-09 19:10:03

RobvG
Member
Registered: 2013-04-09
Posts: 4

Re: Smbnetfs not showing workgroup(s) anymore

Ah, there seems to be an error I missed:

smbnetfs.service - Mount Samba Shares
	  Loaded: loaded (/usr/lib/systemd/system/smbnetfs.service; enabled)
	  Active: active (running) since Tue 2013-04-09 20:59:51 CEST; 5min ago
	 Process: 437 ExecStop=/bin/fusermount -u $SMBNETFS_MOUNT_POINT (code=exited, status=0/SUCCESS)
	Main PID: 442 (smbnetfs)
	  CGroup: name=systemd:/system/smbnetfs.service
		  ├─442 /usr/bin/smbnetfs -f -o allow_other /mnt/smbnet
		  ├─452 /usr/bin/smbnetfs -f -o allow_other /mnt/smbnet
		  └─836 /usr/bin/smbnetfs -f -o allow_other /mnt/smbnet

Apr 09 20:59:51 musicroom systemd[1]: Starting Mount Samba Shares...
Apr 09 20:59:51 musicroom systemd[1]: Started Mount Samba Shares.
Apr 09 21:00:17 musicroom smbnetfs[442]: srv(456)->smb_conn_srv_opendir: err...d
Apr 09 21:00:20 musicroom smbnetfs[442]: srv(457)->smb_conn_srv_opendir: err...d
Apr 09 21:00:23 musicroom smbnetfs[442]: srv(458)->smb_conn_srv_opendir: err...d

Though google turned up nothing for me...

Offline

#3 2013-04-10 10:51:41

ccpaging
Member
Registered: 2012-01-24
Posts: 14

Re: Smbnetfs not showing workgroup(s) anymore

Yes. I have same problem exactly.

Offline

#4 2013-04-10 12:01:28

RobvG
Member
Registered: 2013-04-09
Posts: 4

Re: Smbnetfs not showing workgroup(s) anymore

ccpaging wrote:

Yes. I have same problem exactly.

Glad to hear I'm not alone in this! smile

Though the error I had with smbnetfs vanished on reboot I'm still no closer to a solution.

However, I've noticed that smbnetfs on startup looks for the workgroup "WORKGROUP" which no device on my network is part of. I'll see if this has anything to do with the problems I'm experiencing...

Offline

#5 2013-04-10 18:18:18

RobvG
Member
Registered: 2013-04-09
Posts: 4

Re: Smbnetfs not showing workgroup(s) anymore

As I suspected, if I add a computer to the workgroup "WORKGROUP" it get's detected.

Does anyone at all have any idea where I can set the workgroups it should detect?

Offline

#6 2013-04-11 02:47:41

ccpaging
Member
Registered: 2012-01-24
Posts: 14

Re: Smbnetfs not showing workgroup(s) anymore

It seems no error in systemctl status, but nothing in my windows group which displayed in /mnt/smbnet

systemctl status smbnetfs 
smbnetfs.service - Mount Samba Shares
	  Loaded: loaded (/usr/lib/systemd/system/smbnetfs.service; enabled)
	  Active: active (running) since 四 2013-04-11 10:39:10 CST; 1s ago
	 Process: 1390 ExecStop=/bin/fusermount -u $SMBNETFS_MOUNT_POINT (code=exited, status=0/SUCCESS)
	Main PID: 1396 (smbnetfs)
	  CGroup: name=systemd:/system/smbnetfs.service
		  ├─1396 /usr/bin/smbnetfs -f -o allow_other /mnt/smbnet
		  └─1402 /usr/bin/smbnetfs -f -o allow_other /mnt/smbnet

4月 11 10:39:10 myhost smbnetfs[1396]: size=1
4月 11 10:39:10 myhost smbnetfs[1396]: smb_com=0x0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_rcls=0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_reh=0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_err=0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_flg=0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_flg2=0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_tid=0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_pid=0
4月 11 10:39:10 myhost smbnetfs[1396]: smb_uid=0

May view /etc/systemd/system/multi-user.target.wants/smbnetfs.service and then:
1. umount /mnt/smbnetfs
2. Run ExecStart command in terminal windows directly

I saw many information but did not find any solution.

Last edited by ccpaging (2013-04-11 12:14:40)

Offline

#7 2013-04-16 07:44:39

ccpaging
Member
Registered: 2012-01-24
Posts: 14

Re: Smbnetfs not showing workgroup(s) anymore

Solved now.

First, the real problem is smbnetfs can not resolve netbios name.

Run command:
smbtree -d3 -N

lp_load_ex: refreshing parameters
Initialising global parameters
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf"
Processing section "[global]"
added interface eth0 ip=192.168.8.102 bcast=192.168.8.255 netmask=255.255.255.0
added interface eth0 ip=192.168.8.104 bcast=192.168.8.255 netmask=255.255.255.0
Connecting to 192.168.8.100 at port 445
Doing spnego session setup (blob length=0)
server didn't supply a full spnego negprot
Got challenge flags:
Got NTLMSSP neg_flags=0x628a8215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60088215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60088215
CIRCLE
Connecting to 192.168.8.100 at port 445
Doing spnego session setup (blob length=0)
server didn't supply a full spnego negprot
Got challenge flags:
Got NTLMSSP neg_flags=0x628a8215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60088215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60088215
	\\XP-VBOX        		
Connecting to 180.168.41.175 at port 445
Connecting to 180.168.41.175 at port 139
...

180.168.41.175 is resolve by DNS. According to:

http://www.zulius.com/how-to/resolve-wi … rom-linux/

Then edit /etc/nsswitch.conf and change this line:
hosts:      files dns

to this:

hosts:      files wins dns

Reboot machine. Everything is OK.

Offline

#8 2013-04-25 07:44:35

matleh
Member
Registered: 2013-04-25
Posts: 1

Re: Smbnetfs not showing workgroup(s) anymore

I had the same problem and the change to /etc/nsswitch.conf solved it for me. Thanks.

You do not need to reboot your system, it is sufficent to do "systemctl restart smbnetfs.service".

Offline

Board footer

Powered by FluxBB