You are not logged in.

#1 2013-04-14 15:04:14

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

Arch Linux porting the sh4 CPU OK, but telnetd strange

I've successful porting Arch Linux to sh4 CPU.
https://code.google.com/p/sh4twbox/

Here is the console screen demo http://ascii.io/a/2849

But, I use a workaround method to prevent upgrade kernel.
I use the sysvinit back instead of systemd.

Here I found a problem, when I telnet to the xinetd telnetd.
It hidden some chars. And disable the echo back.
It is OK for ssh login.

For example, see it eats my hostname prompt and 'P' of  'P'assword:

# hostname
sh4twbox
[root@sh4twbox ~]# telnet localhost
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
4twbox        
assword: 
0;root@sh4twbox:~?1034hoot@sh4twbox ~]# 
0;root@sh4twbox:~oot@sh4twbox ~]# 
0;root@sh4twbox:~oot@sh4twbox 
0;root@sh4twbox:~oot@sh4twbox ~]#      H       H       H       H       H
0;root@sh4twbox:~oot@sh4twbox ~]#ogout
Connection closed by foreign host.

Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

#2 2013-04-14 17:31:47

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,974

Re: Arch Linux porting the sh4 CPU OK, but telnetd strange

I think your escape sequences maybe goofed, but it maybe doing something else strange.
For security reasons, regular telnet was removed from Arch some time ago, for the sshd instead.
But if you are using telnet to access a web server or something like that and it still does that with the telnet client, then the telnet client is probably messed up, but this is probably your telnetd doing something funny.  So try to hit a web server with your telnet client and see what it does.

Last edited by nomorewindows (2013-04-14 17:33:59)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#3 2013-04-14 23:39:06

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

Re: Arch Linux porting the sh4 CPU OK, but telnetd strange

I'm sure my telnet client is workable on other.
I've sshd setup already, but, I want to save CPU on this slow machine.
But, the problem is caused by the telnetd or the path to telnetd.

/etc/inittab

id:3:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p
 
# -8 options fixes umlauts problem on login
c1:2345:respawn:/sbin/agetty -8 -s 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 -s 38400 tty2 linux

# Serial Virtual Console for KVM and others VMs
s0:2345:respawn:/sbin/agetty -8 -s 115200 ttyAS0 linux    

ls /dev

[root@sh4twbox ~]# ls -l /dev/tty?
crw-rw---- 1 root tty 4, 0 Jan  1  2000 /dev/tty0
crw-rw---- 1 root tty 4, 1 Apr 13 10:34 /dev/tty1
crw-rw---- 1 root tty 204, 40 Apr 13 10:34 /dev/ttyAS0

Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

Board footer

Powered by FluxBB