You are not logged in.

#1 2013-04-14 02:57:53

creatureofthedark
Member
Registered: 2013-04-14
Posts: 4

Unable to add new UEFI boot option on Asus Sabertooth 990fx [SOLVED]

Hey guys,

I am attempting to re-install my arch desktop but i am having problems with this horrific new UEFI bios stuff... I went with the grub method of booting as this is what worked the first time round i installed arch but for some reason this time it is not letting me add the boot option...

My output is shown below..

[root@archiso /]# pacman -S grub-efi-x86_64 efibootmgr
resolving dependencies...
looking for inter-conflicts...

Packages (6): dosfstools-3.0.16-1  freetype2-2.4.11-2  fuse-2.9.2-1  grub-common-2.00-1  efibootmgr-0.6.0-1
              grub-efi-x86_64-2.00-1

Total Download Size:    4.94 MiB
Total Installed Size:   20.19 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages ...
 grub-common-2.00-1-x86_64                           3.7 MiB  6.21M/s 00:01 [###########################################] 100%
 grub-efi-x86_64-2.00-1-any                        569.7 KiB  2.08M/s 00:00 [###########################################] 100%
 freetype2-2.4.11-2-x86_64                         462.5 KiB  8.36M/s 00:00 [###########################################] 100%
 fuse-2.9.2-1-x86_64                               137.2 KiB  8.37M/s 00:00 [###########################################] 100%
 dosfstools-3.0.16-1-x86_64                         60.7 KiB  9.89M/s 00:00 [###########################################] 100%
 efibootmgr-0.6.0-1-x86_64                          22.3 KiB  7.26M/s 00:00 [###########################################] 100%
(6/6) checking keys in keyring                                              [###########################################] 100%
(6/6) checking package integrity                                            [###########################################] 100%
(6/6) loading package files                                                 [###########################################] 100%
(6/6) checking for file conflicts                                           [###########################################] 100%
(6/6) checking available disk space                                         [###########################################] 100%
(1/6) installing freetype2                                                  [###########################################] 100%
(2/6) installing fuse                                                       [###########################################] 100%
(3/6) installing grub-common                                                [###########################################] 100%
Generating grub.cfg.example config file...
This may fail on some machines running a custom kernel.
done.
Optional dependencies for grub-common
    libisoburn: provides xorriso for generating grub rescue iso using grub-mkrescue
    os-prober: to detect other OSes when generating grub.cfg in BIOS systems
    mtools: for grub-mkrescue FAT FS support
(4/6) installing dosfstools                                                 [###########################################] 100%
(5/6) installing efibootmgr                                                 [###########################################] 100%
(6/6) installing grub-efi-x86_64                                            [###########################################] 100%
[root@archiso /]# grub-install --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck
Installation finished. No error reported.
[root@archiso /]# cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo
[root@archiso /]# grub-mkconfig -o /boot/grub/grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
done
[root@archiso /]# efibootmgr
BootCurrent: 0003
Timeout: 3 seconds
BootOrder: 0001,0000,0002,0003
Boot0000* CD/DVD Drive
Boot0001* Hard Drive
Boot0002* Removable Drive
Boot0003* UEFI: ATAPI   iHOS104
[root@archiso /]#

in the wiki it tells my that if grub dose not add the boot option i can do it via bcfg. the only problem with this is that bcfg requires UEFI shell v2.0 and i cannot get that shell to load up and just get a nice error...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT c:\dev\edk2tip\MdeModulePkg\Library\UefiHiiServIcesLib\UefiHiiServIcesLib.c(88): !EFI_ERROR (Status)

Dose anyone know another way of getting the boot option into the UEFI bios?

Thank you

Last edited by creatureofthedark (2013-04-15 23:42:55)

Offline

#2 2013-04-14 20:59:52

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 228

Re: Unable to add new UEFI boot option on Asus Sabertooth 990fx [SOLVED]

You say "re-install" so I'm assuming it worked once. What version of the Arch install media did you use when it installed the first time? What version are you using now?

I have a similar issue with the ASUS M5A99X EVO mobo, efibootmgr 0.6.0 and the 3.8.4 kernel where efibootmgr fails to add the boot entry and there's no error messages.

Same mobo with efibootmgr 0.5.4 and the 3.6.2 version of the kernel work perfectly.


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#3 2013-04-14 21:53:12

creatureofthedark
Member
Registered: 2013-04-14
Posts: 4

Re: Unable to add new UEFI boot option on Asus Sabertooth 990fx [SOLVED]

Hey Kairi,

That is correct this is my second install. The first install went well with no issues but being new to the OS i made a few mistakes with the install and after about 4-5 month of playing with the OS i had managed to mess up my pacman config file as well as a few other things tongue. I decided to just do a fresh install with everything how i wanted now i know what im doing (or so i thought).

I was using my Zalman VE-200 (Very nice toy) as a virtual USB CD drive for both attempts. This time after the first attempt with the Zalman i "borrowed" my gf windows laptop and burnt off a CD and tried that but with the same issue...

Is there an easy way to downgrade efibootmgr as well as choose the 3.6.2 kernal when installing? i don’t like the idea of installing an old kernal and then doing a full upgrade but if that is what works then i guess i have no choice...

Would it be a good idea to try and use another OS such as Ubuntu (im sure that will work) to install the correct boot options into the NVRAM on the BIOS?
If so... what would the config be as grub was supposed to handle that itself tongue

Thank you

Offline

#4 2013-04-14 22:05:53

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 228

Re: Unable to add new UEFI boot option on Asus Sabertooth 990fx [SOLVED]

I tried downgrading efibootmgr but I'd get the error below for every command I try:

efivars: set variable() failed: status=8000000000000009

So I just stick to the old Archboot media archlinux-2012.10-1-archboot-x86_64.iso for the install then update everything.

Last edited by KairiTech (2013-04-14 22:11:41)


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#5 2013-04-14 22:22:25

creatureofthedark
Member
Registered: 2013-04-14
Posts: 4

Re: Unable to add new UEFI boot option on Asus Sabertooth 990fx [SOLVED]

hmmm....

May be worth installing the OS with the latest CD with refind as the boot manager. After installing unmount and reboot as normal but use the old CD and from the live cd shell run:

efibootmgr -c -g -d /dev/sda -p 1 -w -L "rEFInd" -l '\EFI\refind\refind_x64.efi'

That way the bit that doesn’t work in the new kernal would be done by the old one... (Hopefully with no issues)
Wouldn’t be a nice grub boot loader but i guess i don’t actually need anything better then refind....

When i get back of shift i will give this a go and report back.

Thank you for your help Kairi.

Offline

#6 2013-04-15 23:42:40

creatureofthedark
Member
Registered: 2013-04-14
Posts: 4

Re: Unable to add new UEFI boot option on Asus Sabertooth 990fx [SOLVED]

Finally fixed it tongue

I could not find an arch iso with kernal version 3.6 so i ended up going with ubuntu 64bit 12.10 live cd. Out of laziness i did a quick Google and found the command i needed to add grub boot option into the UEFI bios was:

 sudo efibootmgr --create --gpt --disk /dev/sda --part 1 --write-signature --label "GRUB2" --loader '\EFI\arch_grub\grubx64.efi' 

I am now able to boot properly.

Thank you for your help KairiTech!!

Is this issue classified as an arch bug, an efibootmgr but or a kernal bug? I wonder if a mod/experienced user would be able to let me know where or if i should be reporting this with the workaround?

Thank you

Last edited by creatureofthedark (2013-04-15 23:43:38)

Offline

#7 2013-04-16 15:28:17

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 228

Re: Unable to add new UEFI boot option on Asus Sabertooth 990fx [SOLVED]

I've read some posts here and elsewhere that leads me to believe that there is something about the last few Arch install media releases that ASUS mobos doesn't like with respect to the kernel and efibootmgr. Hunting down a solution doesn't seem to be getting much traction so I'm beginning to suspect it's limited to ASUS mobos. Hopefully, in time, there's a BIOS, kernel or efiboomgr update that solves the silent fail. Till then I'll continue using the older install media and just update everything after booting into the new install.


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

Board footer

Powered by FluxBB