You are not logged in.

#1 2013-04-18 01:36:50

EvanPurkhiser
Member
From: Akron, Ohio
Registered: 2010-08-17
Posts: 225
Website

Error installing ruby-json from AUR

Hey guys,

I'm getting an error installing the ruby-json AUR package with yaourt. Here's the error https://gist.github.com/EvanPurkhiser/5409110

I checked the directory pkg directory and it has 000 permissions =/ Changing the permissions doesn't seem to fix it as it just resets them back to 000 next time i try to install it

Also, would this be a better to report this in the package comments instead of asking here?

Last edited by EvanPurkhiser (2013-04-18 01:47:22)

Offline

#2 2013-04-18 01:52:02

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,975

Re: Error installing ruby-json from AUR

Yes, it is better to notify the package maintainer. The problem is that $pkgdir is inaccessable from the build function.

Offline

#3 2013-04-18 05:40:10

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,727

Re: Error installing ruby-json from AUR

Scimmia wrote:

Yes, it is better to notify the package maintainer. The problem is that $pkgdir is inaccessable from the build function.

Technically that is not the problem, the problem is that the PKGBUILD was doing bad things in build(), which makepkg will now refuse  smile


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

Board footer

Powered by FluxBB