You are not logged in.

#1 2013-04-18 08:28:27

Dero
Member
Registered: 2013-04-18
Posts: 10

Audio and <Super>-Keys do not work (Acer Aspire TimelineX 4820TG)

Hi,

I recently installed Arch on my laptop. Most things work very well, but I can't use the "volume up", "volume down" and "mute volume" FN-keys. When I enter gnomes keyboard preferences, gnome recognizes the pressed keys and enters them correctly. But when I press them, nothing happens. The same problem appears with each mapping containing the <Super>-key.
I already searched for solutions to the <Super>-key problem, but couldn't find any so far.

For any helpful information I would be very grateful.

Greetings
Dero

Offline

#2 2013-04-18 08:49:23

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,383
Website

Re: Audio and <Super>-Keys do not work (Acer Aspire TimelineX 4820TG)

Welcome to the boards.


The first step is to identify if they are being registered by the kernel:
https://wiki.archlinux.org/index.php/Ex … board_Keys


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-04-18 09:23:37

Dero
Member
Registered: 2013-04-18
Posts: 10

Re: Audio and <Super>-Keys do not work (Acer Aspire TimelineX 4820TG)

jasonwryan wrote:

The first step is to identify if they are being registered by the kernel:
https://wiki.archlinux.org/index.php/Ex … board_Keys

I ran showkey and got a keycode for all keys I pressed (e.g.: 114 for volume down).

I also tried creating a xmodmap for those keycodes, but this didn't change anything about my problem.

What I just remembered is, that when I use <Super>+L (which is set to lock screen in gnome) while being in an editor, the "L" will be written. So I think gnome doesn't even catch the key combination.

Offline

#4 2013-04-18 14:27:25

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: Audio and <Super>-Keys do not work (Acer Aspire TimelineX 4820TG)

Did you assign the desired commands to those keys in the gnome control center?

Offline

#5 2013-04-18 18:39:31

Dero
Member
Registered: 2013-04-18
Posts: 10

Re: Audio and <Super>-Keys do not work (Acer Aspire TimelineX 4820TG)

cookies wrote:

Did you assign the desired commands to those keys in the gnome control center?

Dero wrote:

When I enter gnomes keyboard preferences, gnome recognizes the pressed keys and enters them correctly.

As I already mentioned I did this and gnome recognized the keys correctly.

Offline

#6 2013-05-08 13:19:19

Dero
Member
Registered: 2013-04-18
Posts: 10

Re: Audio and <Super>-Keys do not work (Acer Aspire TimelineX 4820TG)

I figured it out. In dconf editor enable /org/gnome/settings-daemon/plugins/media-keys/activate
This enabled custom keybindings as well als volume and media control keys

Offline

Board footer

Powered by FluxBB