You are not logged in.

#1 2013-04-21 02:41:53

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

[SOLVED] WINE - issues with wineboot and mount manager on 64-bit

I'm having a bit of a problem with running WINE and creating a new 64-bit wineprefix.
Running WINE 1.5.28 from [multilib], and a clean wineprefix with the 64-bit winearch. When I try to run winecfg (or any other wine-related tool), the terminal gives me the following error:

$ winecfg
err:process:start_wineboot failed to start wineboot, err 1359
err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.
err:winecfg:WinMain failed to restart 64-bit L"C:\\windows\\system32\\winecfg.exe", err 1359
err:winecfg:open_mountmgr failed to open mount manager err 2

Winecfg starts, and the last message posted here appears when I open the "Drives" tab. Also, the tab has no configuration available, just a message saying "Failed to connect to the mount manager, the drive configuration cannot be edited."

This happens only on a 64-bit wineprefix, and it doesn't occur when I try to run a WINE binary downloaded from e.g. PlayOnLinux. I tried reporting a bug to the WINE bugzilla, but they said there is a problem with my 64-bit binaries.

Is this a bug with the Arch package? If not, what am I doing wrong?


Thanks in advance! smile

Last edited by Wintershade (2013-04-22 22:10:31)


Only the best is good enough.

Offline

#2 2013-04-21 09:33:37

gilmoreja
Member
From: Florida
Registered: 2012-05-28
Posts: 71

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

I have the same issue when creating a new 64-bit wineprefix.

If I try to use my existing wineprefix winecfg won't even start, but crashes.

I'm not at my computer right now, so I can't post logs but will do that when I can.

I am using the package from multilib as well.

Edit: Forgot to add that running a pre-existing or new 32-bit wineprefix works perfectly fine.

Last edited by gilmoreja (2013-04-21 09:44:00)


Time you enjoy wasting isn't wasted time.

Offline

#3 2013-04-21 10:01:33

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

I have another friend who reported the same behaviour last night, also on 64-bit Arch Linux, WINE 1.5.28, 64-bit wineprefix.
Since I can get everything to work "normally" with a different WINE binary, is it safe to assume that this is a bug in the Arch package?

Also, the same thing happens when I try using wine-git from AUR.


Only the best is good enough.

Offline

#4 2013-04-21 10:37:32

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

http://forum.winehq.org/viewtopic.php?f=8&t=18631
http://bugs.winehq.org/show_bug.cgi?id=33351
http://bugs.winehq.org/show_bug.cgi?id=33307
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57003
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56881

Wine 1.5.28 in Multilib Arch repos was compiled with GCC 4.8. Possible workarounds:

  • Use a 32-bit WINEPREFIX

  • Downgrade Wine package to 1.5.27 (which was compiled with GCC 4.7)

  • Compile Wine yourself with -O0 / -O1 (or just -fno-builtin-memcpy)

Last edited by msthev (2013-04-21 12:33:48)

Offline

#5 2013-04-21 11:43:33

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Is this problem just WINE-specific or does GCC misbehave with other packages as well?

Also, downgrading to 1.5.27 didn't help - at least not for me. WINE behaved just the same as I described in the OP.

Last edited by Wintershade (2013-04-21 11:44:10)


Only the best is good enough.

Offline

#6 2013-04-21 11:51:54

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

It's probably a bug in Wine that appeared after GCC got more strict on C lib specification.

You did the downgrade using the Arch package, not by compilig Wine yourself, right?

Offline

#7 2013-04-21 12:14:39

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Umm... I compiled WINE myself :-/
OK, I see your point there. Where can I even find an older Arch package?

Last edited by Wintershade (2013-04-21 12:15:09)


Only the best is good enough.

Offline

#8 2013-04-21 12:33:06

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Offline

#9 2013-04-21 13:25:39

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

@Everybody

I was one of the people on WineHQ trying to track down the issue - i also emailed the Archlinux Wine Packager and notified him of the issue ~ I never even got a response from him, at all.

anyway, as msthev pointed out, compiling wine with gcc -O2 optimization level  + -fno-builtin-memcpy flag is enough to get wine64 working again.

It's a wine bug - NOT gcc bug. I know this since i am the one who filed a bug report against GCC bug tracker (and at wineHQ), regarding the wine64 problems, which led to finding that -fno-builtin-memcpy would solve the issue.

cheerz

Last edited by triplesquarednine (2013-04-21 13:26:17)

Offline

#10 2013-04-21 14:44:11

gilmoreja
Member
From: Florida
Registered: 2012-05-28
Posts: 71

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Hmm.. How can I get around the PGP error when downgrading to a cached version of a package with the new pacman? Pacman doesn't cache the signatures too?

Did a forum search but couldn't find anything useful on it.


Time you enjoy wasting isn't wasted time.

Offline

#11 2013-04-21 16:19:16

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

i also emailed the Archlinux Wine Packager and notified him of the issue ~ I never even got a response from him, at all.

Wow... not cool, man. Not cool at all. He could have at least said thanks, and modified his PKGBUILD accordingly.

anyway, as msthev pointed out, compiling wine with gcc -O2 optimization level  + -fno-builtin-memcpy flag is enough to get wine64 working again.

Hey, thanks! I just compiled it, and it worked. I hope the packager notices this before the next version is out...

Thank you very much, in any case smile


Only the best is good enough.

Offline

#12 2013-04-21 16:48:34

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Wintershade wrote:

i also emailed the Archlinux Wine Packager and notified him of the issue ~ I never even got a response from him, at all.

Wow... not cool, man. Not cool at all. He could have at least said thanks, and modified his PKGBUILD accordingly.

I wouldn't jump to any conclusions, there may be a variety of reasons/possibilities as to why i may not have heard back from him.

Wintershade wrote:

anyway, as msthev pointed out, compiling wine with gcc -O2 optimization level  + -fno-builtin-memcpy flag is enough to get wine64 working again.

Hey, thanks! I just compiled it, and it worked. I hope the packager notices this before the next version is out...

Thank you very much, in any case smile

great smile

Offline

#13 2013-04-22 09:23:58

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

The reason you haven't heard back from me is because I usually have a very busy inbox. Please use bug reports to everyone can see your findings and discuss possible solutions. Also, I can actually track bugs a lot better than emails. Just issue a bug report from now on and I will get back to that in time.

Offline

#14 2013-04-22 12:09:03

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Gotcha wink my bad. Good luck with resolving this.
You can set specific CFLAGS within the PKGBUILD, right? Something like CFLAGS="$CFLAGS -fno-builtin-memcpy"?


Only the best is good enough.

Offline

#15 2013-04-22 12:38:52

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

It's already rebuilt. Go ahead and test it and please report back results.

Offline

#16 2013-04-22 12:41:00

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

is it wine-1.5.28-2? I have to wait till my mirrors sync, so it might be 24 hours before I get it. I'll check out the abs if I find the time today.


Only the best is good enough.

Offline

#17 2013-04-22 12:41:07

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Svenstaro wrote:

The reason you haven't heard back from me is because I usually have a very busy inbox. Please use bug reports to everyone can see your findings and discuss possible solutions. Also, I can actually track bugs a lot better than emails. Just issue a bug report from now on and I will get back to that in time.

Myself, I generally file bug reports to upstream projects, and in this case - that is exactly what i did for both Wine and GCC. 

That being said, i do understand where you are coming from (i too have a busy inbox and it isn't uncommon for me to loose emails), so in the future - i will do as you recommend, since it's likely an email will be missed/passed by.

anyway, looking in my inbox this morning, it seems Dan Kegel has been busy bisecting wine sources / further isolating problematic code - hopefully this will all be sorted out by the bext wine-release smile

Offline

#18 2013-04-22 13:30:58

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

wine-1.5.28-2 fixes the issue for me. Thank you.

Offline

#19 2013-04-22 21:26:31

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Tried wine-1.5.28-2... Okay, so the "Devices" tab works, and the error pasted in the OP is no longer here. So it seems like everything works now.

Thanks, Svenstaro! smile


Only the best is good enough.

Offline

#20 2013-04-22 21:54:58

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Wintershade wrote:

Tried wine-1.5.28-2... Okay, so the "Devices" tab works, and the error pasted in the OP is no longer here. So it seems like everything works now.

Thanks, Svenstaro! smile

Could you please mark this thread [SOLVED] then?

Offline

#21 2013-04-22 22:10:40

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Marked.


Only the best is good enough.

Offline

#22 2013-04-26 20:12:13

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Just to let you guys know - Gcc has been fixed upstream, and thus whenever Archlinux updates GCC-4.8.0 - the wine64 problem should be fixed.

I am already using the patch that fixed wine64/gcc -O2 (but it did require patching gcc-multilib to fix / test the fix).

cheerz

Offline

#23 2013-04-27 18:10:25

Wintershade
Member
From: Croatia
Registered: 2008-02-18
Posts: 175
Website

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

That's good news! Thanks smile


Only the best is good enough.

Offline

#24 2013-04-27 19:03:36

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

Wintershade wrote:

That's good news! Thanks smile

indeed, it is good news. wink

basically, once we have a (gcc) snapshot past april 25th (or 26th?), we should be good to go smile

as a side-note: I may have found a bug in glibc to do with memcpy, that may be a bug similar to the one just solved (affecting wine64). However, i have to wait until Archlinux has updated, before i can investigate further. ~ i think i was hitting this bug before gcc-4.8.0 + wine bug - the gcc-4.8.0 update set me back a couple of weeks, but that (now solved) bug has directed me towards this potential glibc bug, that does not seem to affect ubuntu/eglibc.

but anyway, i digress. i'm glad gcc-4.8.0 bugs are being worked out and that wine64 is working again smile

Offline

#25 2015-06-10 11:16:30

CapSel
Member
Registered: 2011-08-26
Posts: 3

Re: [SOLVED] WINE - issues with wineboot and mount manager on 64-bit

I'm having same issue right now. WINE version is :
$ wine --version
wine-1.7.44

After removing ~/.wine I can't start successfully winecfg. During initialization there is a problem with "(Unknown)" application and a hint that I should check up in application database. After clicking "show details" there is a window ... without any content, re-sizeable.

After I close it winecfg window opens and I can't configure drives.

Offline

Board footer

Powered by FluxBB