You are not logged in.

#1 2013-04-23 09:27:26

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

[solved] cannot start x

Trying to set up X and awesome. X doesn't start. I turned off KMS, following the uvesafb instructions on archwiki. Could that be related?

Here's my xorg.0.log
http://codepad.org/PbCRHJQ4

Last edited by atomicpookavirus (2013-04-24 08:35:24)

Offline

#2 2013-04-23 11:08:53

rix
Member
Registered: 2012-07-25
Posts: 221

Re: [solved] cannot start x

atomicpookavirus wrote:

[...]
(EE) Failed to load module "modesetting" (module does not exist, 0)
[...]
[   494.500] (EE) Failed to load module "fbdev" (module does not exist, 0)
[...]

Offline

#3 2013-04-23 11:35:54

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: [solved] cannot start x

@rix: Those errors are completely normal. Those are fallback drivers, there's nothing wrong if they aren't there.

@atomicpookavirus: More info about your machine would be nice. I'm guessing it's a CedarView machine. Search the forums ot find out what that means.

PS. Turning off KMS is *never* a solution. Never. I really don't like that documentation still suggests doing that.

Offline

#4 2013-04-23 11:40:46

rix
Member
Registered: 2012-07-25
Posts: 221

Re: [solved] cannot start x

@ Gusar: sometimes it did resolves for me.
Why it's not good turning off KMS?
Thanks.

Offline

#5 2013-04-23 11:55:08

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: [solved] cannot start x

rix wrote:

@ Gusar: sometimes it did resolves for me.

No it didn't. They're *fallback* drivers. So you didn't resolve anything if they got used. Fallbacks are temporary workarounds, but they don't fix the actual issue.

rix wrote:

Why it's not good turning off KMS?

Because that's how drivers nowadays work. Disabling KMS effectively means disabling the whole driver.

Offline

#6 2013-04-23 12:02:28

rix
Member
Registered: 2012-07-25
Posts: 221

Re: [solved] cannot start x

Got it. Thank you.

Offline

#7 2013-04-23 12:37:52

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

Re: [solved] cannot start x

http://codepad.org/GME1YFPI

Last edited by atomicpookavirus (2013-04-23 13:19:09)

Offline

#8 2013-04-23 12:41:44

youngunix
Member
Registered: 2013-01-16
Posts: 41
Website

Re: [solved] cannot start x

Have you tried:

$ su  <----if you are not logged in as root
# Xorg -configure <----this will generate xorg.conf file if you don't have one

Then try starting X, you might need to reboot.


"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity." --Dennis Ritchie-- RIP

Offline

#9 2013-04-23 13:02:13

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: [solved] cannot start x

Just like disabling KMS, Xorg -configure is also *never* a solution. It's a relic of the past, it'll create an outdated config that won't do anything different than the auto-detection stuff already does anyway.

@atomicpookavirus: That link doesn't work. You don't need pastebins, you can post stuff directly here, just make sure to use code tags.

Last edited by Gusar (2013-04-23 13:02:23)

Offline

#10 2013-04-23 13:03:52

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

Re: [solved] cannot start x

"Number of created screens does not match number of detected devices.
Configuration failed."

Last edited by atomicpookavirus (2013-04-23 13:04:26)

Offline

#11 2013-04-23 13:17:36

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

Re: [solved] cannot start x

Right, so I'll delete the config file /etc/X11/xorg.conf.d, disable uvesafb tweaks (turn on KMS) and retry startx. Odd that uvesafb and KMS are so incompatible.

I'm not sure how to paste code into the web forum in text mode. I just use curlpaste. No doubt there must be some way to pipe the output of lspci -v | trepidation graphics into elinks. I am writing on an android tablet that has annoying auto correct, making grep-into trepidation and otherwise thwarts writing code.

Offline

#12 2013-04-23 15:23:43

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

Re: [solved] cannot start x

Turning off KMS lets x start. Removing /etc/X11/xorg.conf.d was probably a bad idea. Now I can't use the keyboard or touchpad under x.

Fbterm still works fine with KMS enabled. Qingy is still broken. It flickers when input is entered then goes black. Same behavior with v86d uvesa loaded.

Offline

#13 2013-04-23 16:01:07

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: [solved] cannot start x

/etc/X11/xorg.conf.d isn't a file, it's a directory, and why would you remove that?? There's stuff for input devices in there.

I don't see how turning KMS off would let X start, unless you have one of the fallback drivers installed, and your first log says that you don't. BTW, that link still doesn't work, so we still have no idea what kind of hardware you have. And now we have X mysteriously starting, so you must have changed something since you last posted an X log, but we don't know what. You need to be a lot more detailed in providing info. We don't have crystal balls, we can't know what's going on unless you tell us. In great details.

Offline

#14 2013-04-23 16:13:15

youngunix
Member
Registered: 2013-01-16
Posts: 41
Website

Re: [solved] cannot start x

Gusar wrote:

Just like disabling KMS, Xorg -configure is also *never* a solution. It's a relic of the past, it'll create an outdated config that won't do anything different than the auto-detection stuff already does anyway.

Just used it 4 days ago on a brand new install that wouldn't run "startx", which was me rushing to get things done.


"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity." --Dennis Ritchie-- RIP

Offline

#15 2013-04-23 16:13:41

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

Re: [solved] cannot start x

No, I don't know why I wrote that. Too weird for a typo. Anyways, I meant turning KMS /on/ lets X start.

It's intel mobile 915GM/GMS/910GML Express Graphics Controller

Offline

#16 2013-04-23 16:25:59

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: [solved] cannot start x

youngunix wrote:

Just used it 4 days ago on a brand new install that wouldn't run "startx", which was me rushing to get things done.

I'd like to know the details of that. There's no way Xorg -configure would know more than X's auto-detection.

@atomicpookavirus: Well, that just confirms what I said, turning off KMS is never a solution. Now all you need to do is reinstall xorg-server and xf86-input-synaptics, so you'll get back the config files you deleted from /etc/X11/xorg.conf.d

Offline

#17 2013-04-24 08:14:41

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

Re: [solved] cannot start x

Re-installing those packages did the trick, thanks.

https://wiki.archlinux.org/index.php/Uvesafb#GRUB2

I added a warning to the uvesafb archwiki page, noting that disabling KMS may break xorg.

It's worth noting that I do get the black screen bug as described there and that disabling KMS does in fact fix it but at the cost of breaking xorg - it is not worth it to use uvesafb.

Last edited by atomicpookavirus (2013-04-24 08:21:12)

Offline

#18 2013-04-24 09:41:12

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: [solved] cannot start x

Why did you even go for uvesafb in the first place? It hasn't been the norm to use it for a looooong time now. It's only use is with the proprietary nvidia driver, and even there nvidia doesn't officially support such configuration.

Offline

#19 2013-04-24 16:28:39

atomicpookavirus
Member
Registered: 2009-06-28
Posts: 43

Re: [solved] cannot start x

https://wiki.archlinux.org/index.php/Qingy

How to get qingy?

First you need a working DirectFB. I'm recommending Uvesafb but if you have some graphical issues with it use vesafb. Qingy may not work with KMS.

Offline

Board footer

Powered by FluxBB