You are not logged in.

#1 2013-04-04 11:32:38

preginald
Member
Registered: 2013-04-04
Posts: 6

mount.nfs: rpc.statd is not running but is required for remote locking

Hey folks,

I have installed the archlinux 64bit earlier today and I am having problems with mounting my nfs shares.

I have already installed nfs-utils and have the following entry in my fstab:
192.168.0.250:/mnt/Pool-1/media /mnt/media/ nfs auto
My nfs server is a freebsd machine and I am able to successfully mount nfs on my ubuntu machines using the line above.

However when I run 'mount -a' from my new archlinux installation I get the following output.
mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: an incorrect mount option was specified

I also followed the nfs troubleshooting guide for the "mount.nfs: rpc.statd is not running but is required for remote locking." error found here https://wiki.archlinux.org/index.php/NF … leshooting and changed the "NEED_STATD" value in /etc/conf.d/nfs-common.conf to "YES" and restarted the machine but I'm still unable to successfully 'mount -a' and get my nfs shares working.

I have also tried the following settings as instructed in the arch wiki here https://wiki.archlinux.org/index.php/Nfs and get this output, "mount.nfs4: Protocol not supported"
192.168.0.250:/mnt/Pool-1/media   /mnt/media   nfs4   rsize=8192,wsize=8192,timeo=14,intr,_netdev    0 0

Is there a package I haven't installed or is there something wrong with my settings?

Cheers, Pete

Offline

#2 2013-04-23 18:55:48

adc123
Member
Registered: 2013-04-23
Posts: 4

Re: mount.nfs: rpc.statd is not running but is required for remote locking

I also receive protocol not supported when trying to mount a share from my FreeNAS box

sudo mount -t nfs4 192.168.1.3:/mnt/vol0/Media /mnt/freenas
mount.nfs4: Protocol not supported

So bump i guess...

Offline

#3 2013-04-23 19:54:16

adc123
Member
Registered: 2013-04-23
Posts: 4

Re: mount.nfs: rpc.statd is not running but is required for remote locking

Sorted my problem... looks like FreeNAS doesn't support nfs4 (which i still think it does, i probably haven't setup it up).

sudo systemctl start rpcbind
sudo mount -t nfs4 192.168.1.3:/mnt/vol0/Media /mnt/freenas/

smile

Offline

Board footer

Powered by FluxBB