You are not logged in.

#1 2011-11-30 14:56:10

scenox
Member
Registered: 2010-07-19
Posts: 63

[solved] Gnome 3 extended Desktop makes Arch extremely slow

Hi,

I've a netbook running Arch. When I plugin an external monitor (1920x1080) and uncheck 'Mirror screen' in Gnome Settings, extended Desktop is activated and Arch gets really slow, reaction time > 30 sec
Any idea why this is so?

Last edited by scenox (2011-12-01 19:32:25)

Offline

#2 2011-12-01 14:26:51

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,033

Re: [solved] Gnome 3 extended Desktop makes Arch extremely slow

Probably this:
https://bbs.archlinux.org/viewtopic.php … 78#p983378

well, im using a 945gm myself with 2 screens..

how are you setting your dual desktop? cloned? stacked? next to each other? what resolution are both screens?

this hardware does not support texture sizes over 2048x2048, so you should consider this when setting your desktop configuration (gnome3 or compiz use textures to draw your desktop, so you need your desktop size to fit within that limit).

and of course, if you paste some logs....

...but of course, specific to whatever the limitations of your particular video card are.

Last edited by jakobcreutzfeldt (2011-12-01 14:27:12)

Offline

#3 2011-12-01 19:00:34

scenox
Member
Registered: 2010-07-19
Posts: 63

Re: [solved] Gnome 3 extended Desktop makes Arch extremely slow

it seems to be the same video card.. the monitor alone works in full hd resolution without problems (when I've switched off the netbook display).

[scenox@q10 ~]$ lspci
 00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
 00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
[scenox@q10 ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 2720 x 1080, maximum 4096 x 4096
LVDS1 connected 800x600+0+480 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x600       60.0 +
   800x600        60.3*    56.2  
   640x480        59.9  
VGA1 connected 1920x1080+800+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0  
   720x400        70.1 

So if i understand correctly, i can only use a total x axis resolution of 2048 px, therefore it doesn't work (1920+800>2048). It works when I put the netbook screen under the monitor screen with gnome tool, but I think I will just use the full hd monitor.

Last edited by scenox (2011-12-01 19:26:19)

Offline

#4 2013-04-23 22:13:19

oconnor663
Member
Registered: 2012-12-16
Posts: 45

Re: [solved] Gnome 3 extended Desktop makes Arch extremely slow

I seem to be having the same problem, but when I plug in the external monitor, Gnome becomes so unresponsive that I can't adjust any settings after that. How might I preemptively tell Gnome to use only the external monitor, before the external monitor is actually plugged in? Thanks for this thread.

Offline

#5 2013-04-23 22:58:55

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,012
Website

Re: [solved] Gnome 3 extended Desktop makes Arch extremely slow

Please don't necrobump, particularly solved threads.
https://wiki.archlinux.org/index.php/Fo … Bumping.27

Gnome has moved on...

Closing


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#6 2013-04-23 23:00:24

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,110

Re: [solved] Gnome 3 extended Desktop makes Arch extremely slow

I am going to close this.  The thread is coming up on a year and a half old.  Gnome 3 has changed alot since then.  Please start a new thread and, if you feel this thread is relevant, link back to it,

Thanks.
our policy

Edit:  I am slowing down .... More than a minute late sad

Last edited by ewaller (2013-04-23 23:01:05)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB