You are not logged in.

#1 2013-04-22 05:55:07

iipe
Member
From: Finland
Registered: 2011-09-13
Posts: 8

[SOLVED] EPS files won't render in Evince and Zathura

Whenever I try to open an EPS file, Evince gives errors:
undefined -21
undefined -21
(evince:15067): EvinceDocument-CRITICAL **: ev_document_misc_pixbuf_from_surface: assertion `surface' failed

Zathura gives similar errors:
undefined -21
error: Rendering failed (page 0)

Both viewers open a window that does not crash, but the file is not rendered. Ghostscript is able to show and convert the EPS files.

My other Arch Linux x86-64 installation works fine with EPS files.

Any ideas how to find out the source of the problem?

Last edited by iipe (2013-09-07 10:01:41)

Offline

#2 2013-04-23 19:42:58

iipe
Member
From: Finland
Registered: 2011-09-13
Posts: 8

Re: [SOLVED] EPS files won't render in Evince and Zathura

It seems to be an issue with Ghostscript. I downgraded from 9.07 to 9.06 and now EPS files can be viewed. However, still with errors. The viewers Evince and Zathura give multiple lines of:
GPL Ghostscript 9.06: Error: Font Renderer Plugin ( FreeType ) return code = -1

Offline

#3 2013-04-23 20:37:49

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,185

Re: [SOLVED] EPS files won't render in Evince and Zathura

Offline

#4 2013-04-24 06:10:28

iipe
Member
From: Finland
Registered: 2011-09-13
Posts: 8

Re: [SOLVED] EPS files won't render in Evince and Zathura

Thanks for the link. Hopefully the bug gets fixed sometime soon.

My other Arch installation works fine because I'm using English as the locale instead of Finnish that has "," as the decimal separator.

Last edited by iipe (2013-04-24 06:10:37)

Offline

#5 2013-09-07 10:01:23

iipe
Member
From: Finland
Registered: 2011-09-13
Posts: 8

Re: [SOLVED] EPS files won't render in Evince and Zathura

Ghostscript 9.10 fixed this issue.

Offline

Board footer

Powered by FluxBB