You are not logged in.

#1 2013-04-15 22:39:37

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

[SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

Did an -Syu yesterday, and noticed that systemd got updated (among other things).  Following the upgrade, my lircd.service failed to load:

$ systemctl status lircd
lircd.service - LIRC Daemon
   Loaded: loaded (/usr/lib/systemd/system/lircd.service; enabled)
   Active: failed (Result: exit-code) since Mon 2013-04-15 15:33:45 PDT; 1min 4s ago
  Process: 592 ExecStart=/usr/sbin/lircd -d $LIRC_DEVICE -P /run/lirc/lircd.pid -H $LIRC_DRIVER $LIRC_CONFIGFILE (code=exited, status=1/FAILURE)
  Process: 589 ExecStartPre=/bin/ln -s /run/lirc/lircd /dev/lircd (code=exited, status=0/SUCCESS)
  Process: 586 ExecStartPre=/bin/rm -f /run/lirc/lircd (code=exited, status=0/SUCCESS)
  Process: 583 ExecStartPre=/bin/rm -f /dev/lircd (code=exited, status=0/SUCCESS)
  Process: 579 ExecStartPre=/bin/mkdir -p /run/lirc (code=exited, status=0/SUCCESS)

I restored everything from a mid-week backup, ran the -Syu again, but held systemd.   lircd.service started without problems.

I just reran the upgrade to snag systemd 201-1, and lircd.service is failing again.

Any thoughts?

[edit] Just downgraded systemd & systemd-sysvcompat back to 198-2, and lircd started properly.

Last edited by wilberfan (2013-04-22 22:59:49)


Hey, be nice...I'm new at this!

Offline

#2 2013-04-17 09:56:21

Jestern
Member
From: Spain
Registered: 2013-02-28
Posts: 3

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

I have the same issue more or less.
For me, Lirc starts correctly with systemd-201 but "irw" shows nothing. I have tried "mode2 -r -d $device" to see that the remote is reorganized. After downgrading to systemd-198-2 it works again.
These are my scripts, the default that comes with the lirc package have never worked on my system:

/etc/conf.d/lircd.conf

#
# Parameters for lirc daemon
#

LIRC_DEVICE="/dev/lirc0"
LIRC_DRIVER=""
LIRC_EXTRAOPTS=""
LIRC_CONFIGFILE=""

/etc/systemd/system/lircd.service

[Unit]
Description=LIRC Daemon
After=network.target

[Service]
Type=forking
EnvironmentFile=/etc/conf.d/lircd.conf
PIDFile=/run/lirc/lircd.pid
ExecStartPre=/bin/mkdir -p /run/lirc
ExecStartPre=/bin/rm -f /dev/lircd
ExecStartPre=/bin/rm -f /run/lirc/lircd
ExecStartPre=/bin/ln -s /run/lirc/lircd /dev/lircd

ExecStart=/usr/sbin/lircd -d $LIRC_DEVICE -P /run/lirc/lircd.pid $LIRC_CONFIGFILE
ExecStopPost=/bin/rm -f /dev/lircd
ExecStopPost=/bin/rm -fR /run/lirc

[Install]
WantedBy=multi-user.target

Offline

#3 2013-04-17 14:20:12

shyn
Member
Registered: 2009-09-23
Posts: 15

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

systemd 201-2 is already available, maybe it will solve the issue.

Offline

#4 2013-04-17 14:33:46

Jestern
Member
From: Spain
Registered: 2013-02-28
Posts: 3

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

shyn wrote:

systemd 201-2 is already available, maybe it will solve the issue.

Thank you for the info. It solved the problem for me big_smile
Now i can comment the ignorePkg from my pacman.conf again.

Offline

#5 2013-04-22 23:00:18

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

systemd 201-2 solved the issue for me as well.  :-)


Hey, be nice...I'm new at this!

Offline

#6 2013-04-23 18:28:58

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

Well, there's another new version of systemd (202-2), and after upgrading, lircd failed again for me.   Haven't had time to experiment with it yet to see if downgrading will fix it.  And, of course, it's possible something else broke it this time...

Last edited by wilberfan (2013-04-23 18:40:43)


Hey, be nice...I'm new at this!

Offline

#7 2013-04-24 07:48:59

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

Yeah, upgraded as well and now lirc does not work. systemctl shows it running but doesn't actually work hmm

Offline

#8 2013-04-25 00:33:09

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

I just ran an update with systemd and systemd-sysvcompat on hold--but lircd failed, so systemd would not seem to be the culprit this time.  A LOT of packages updated, so I'm not sure what's causing the failure at this point....


Hey, be nice...I'm new at this!

Offline

#9 2013-04-25 07:44:58

rocktale
Member
From: Munich, Germany
Registered: 2009-03-18
Posts: 24

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

Same problem here. XBMC stopped working and irw isn't showing anything as well.

However, I won't have time to take a closer look until the end of next week.

Offline

#10 2013-05-03 12:10:29

rocktale
Member
From: Munich, Germany
Registered: 2009-03-18
Posts: 24

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

Just to let you know. I solved the problem here. Apparently the paths of the lirc remote configurations changed from /usr/share/lirc/remotes/ to /usr/share/lirc/ and since I had an include to one of those in my custom config, it couldn't be loaded anymore. Fixing the path also fixed my issues. Just in case anyone has a similar problem.

Offline

#11 2013-05-04 01:21:08

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: [SOLVED] Upgrade to systemd 201-1 causes lircd to fail on boot

rocktale wrote:

Just to let you know. I solved the problem here. Apparently the paths of the lirc remote configurations changed from /usr/share/lirc/remotes/ to /usr/share/lirc/ and since I had an include to one of those in my custom config, it couldn't be loaded anymore. Fixing the path also fixed my issues. Just in case anyone has a similar problem.

I'll be honest: I don't understand your fix.  I'm not aware that I have anything that's pointing to /usr/share/lirc/remotes/   (That's not to say I don't, however.)

I just tried upgrading lirc and lirc-utils, from -41 to -43, and lircd failed to start.   When I downgraded from -43 BACK to -41, lircd still failed to start.

What is -43 changing in my system that downgrading back to a working lirc no longer starts?

$ systemctl status lircd.service
lircd.service - LIRC Daemon
   Loaded: loaded (/usr/lib/systemd/system/lircd.service; enabled)
   Active: failed (Result: exit-code) since Fri 2013-05-03 18:14:35 PDT; 41s ago
  Process: 572 ExecStart=/usr/sbin/lircd -d $LIRC_DEVICE -P /run/lirc/lircd.pid -H $LIRC_DRIVER $LIRC_CONFIGFILE (code=exited, status=1/FAILURE)
  Process: 569 ExecStartPre=/bin/ln -s /run/lirc/lircd /dev/lircd (code=exited, status=0/SUCCESS)
  Process: 566 ExecStartPre=/bin/rm -f /run/lirc/lircd (code=exited, status=0/SUCCESS)
  Process: 563 ExecStartPre=/bin/rm -f /dev/lircd (code=exited, status=0/SUCCESS)
  Process: 559 ExecStartPre=/bin/mkdir -p /run/lirc (code=exited, status=0/SUCCESS)

[edit]  Okay, I put lirc and lirc-utils on hold, and updated the other 88 packages that wanted to update.   Lircd started fine following the upgrade.    It would seem that (at least in my case) there's something about lirc & -utils v -43 that won't play nice with my system (or vice-versa).

Last edited by wilberfan (2013-05-04 01:51:20)


Hey, be nice...I'm new at this!

Offline

Board footer

Powered by FluxBB