You are not logged in.

#1 2013-04-25 08:10:26

jesusjimenez
Member
Registered: 2007-09-26
Posts: 20

Gnome 3.8 Empathy

Hi,

after upgrading to 3.8 (and to 3.8.1) I am not able to access my ICQ account in Empathy 3.8.1 anymore. It does not even offer to add ICQ/AIM account in 'Adding new account'. It shows only Jabber, Facebook, Google Talk, People nearby, IRC and SIP. I tried it under newly created system account - the same situation. What's wrong with it? Gnome developers decided that no one shall use ICQ anymore?

Pidgin works flawlessly, but I'd rather use Empathy.

Anyone has the same?

Offline

#2 2013-04-25 08:28:47

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: Gnome 3.8 Empathy

You propably experienced the same problem than me : https://bbs.archlinux.org/viewtopic.php?id=162039.
But you are lucky, I only have jabber, google talk and facebook chat…
It seems that Empathy 3.8 doesn't see telepathy-haze (which allow to use libpurple for adding accounts) anymore.
What's more, telepathy-haze is flaged as outdate (version 0.6, the last one is 0.7). Maybe an update will solve the problem…


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#3 2013-04-25 21:24:03

jesusjimenez
Member
Registered: 2007-09-26
Posts: 20

Re: Gnome 3.8 Empathy

My problem is gone after last update - telepathy-glib 0.20.2-1, telepathy-haze 0.7.0-1, telepathy-idle 0.1.15-1

Offline

#4 2013-04-26 12:35:36

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: Gnome 3.8 Empathy

Not for me. I tried to supress empathy and telepathy, then reinstall telepathy-glib, then telepathy and empathy, doesn't change anything. Everything else work fine : I've acces to jabber, google, irc, sip, facebook, but not to the protocols offer by telepathy-haze hmm
I can't find a config file for telepathy-haze which could be messed up or anything like it.


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#5 2013-04-26 13:04:33

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: Gnome 3.8 Empathy

Debbuging telepathy-haze by doing

HAZE_DEBUG=all /usr/lib/telepathy/telepathy-haze

give me this :

(haze:3492): purple/plugins-CRITICAL **: /usr/lib/purple-2/tcl.so is not loadable: libtk8.6.so: cannot open shared object file: No such file or directory
purple/prpl-loubserp-mxit-Message: Loading MXit libPurple plugin...

(haze:3492): purple/plugins-CRITICAL **: /usr/lib/purple-2/libjabber.so is not usable because the 'purple_init_plugin' symbol could not be found.  Does the plugin call the PURPLE_INIT_PLUGIN() macro?

(haze:3492): purple/plugins-CRITICAL **: /usr/lib/purple-2/libymsg.so is not usable because the 'purple_init_plugin' symbol could not be found.  Does the plugin call the PURPLE_INIT_PLUGIN() macro?

(haze:3492): purple/plugins-CRITICAL **: /usr/lib/purple-2/liboscar.so is not usable because the 'purple_init_plugin' symbol could not be found.  Does the plugin call the PURPLE_INIT_PLUGIN() macro?
purple/util-Message: Reading file xmpp-caps.xml from directory /tmp/haze-RvuBAD
purple/util-Message: File /tmp/haze-RvuBAD/xmpp-caps.xml does not exist (this is not necessarily an error)
purple/jabber-Message: creating hash tables for data objects
purple/util-Message: Reading file accounts.xml from directory /tmp/haze-RvuBAD
purple/util-Message: File /tmp/haze-RvuBAD/accounts.xml does not exist (this is not necessarily an error)
purple/util-Message: Reading file status.xml from directory /tmp/haze-RvuBAD
purple/util-Message: File /tmp/haze-RvuBAD/status.xml does not exist (this is not necessarily an error)

(haze:3492): purple/certificate-WARNING **: CertificateVerifier x509, singleuse requested but not found.
purple/certificate-Message: CertificateVerifier singleuse registered

(haze:3492): purple/certificate-WARNING **: CertificatePool x509, ca requested but not found.

(haze:3492): purple/certificate-WARNING **: CertificateScheme x509 requested but not found.

(haze:3492): purple/certificate/x509/ca-WARNING **: Lazy init failed because an X.509 Scheme is not yet registered. Maybe it will be better later.
purple/certificate/x509/ca-Message: Init failed, probably because a dependency is not yet registered. It has been deferred to later.
purple/certificate-Message: CertificatePool ca registered

(haze:3492): purple/certificate-WARNING **: CertificatePool x509, tls_peers requested but not found.
purple/certificate-Message: CertificatePool tls_peers registered

(haze:3492): purple/certificate-WARNING **: CertificateVerifier x509, tls_cached requested but not found.
purple/certificate-Message: CertificateVerifier tls_cached registered

(haze:3492): purple/certificate-WARNING **: CertificateScheme x509 requested but not found.
purple/certificate-Message: CertificateScheme x509 registered
purple/util-Message: Reading file smileys.xml from directory /tmp/haze-RvuBAD
purple/util-Message: File /tmp/haze-RvuBAD/smileys.xml does not exist (this is not necessarily an error)
purple/stun-Message: using server
purple/util-Message: Reading file blist.xml from directory /tmp/haze-RvuBAD
purple/util-Message: File /tmp/haze-RvuBAD/blist.xml does not exist (this is not necessarily an error)
purple/prefs-Message: Reading /tmp/haze-RvuBAD/prefs.xml
purple/prefs-Message: Reading /etc/purple/prefs.xml

(haze:3492): purple/prefs-CRITICAL **: Error reading prefs: Failed to open file '/etc/purple/prefs.xml': No such file or directory

(haze:3492): tp-glib/params-WARNING **: tp_base_connection_manager_register: Couldn't claim bus name. If you are trying to debug this connection manager, disable all accounts and kill any running copies of this CM, then try again. Name 'org.freedesktop.Telepathy.ConnectionManager.haze' already in use by another process
purple/certificate-Message: CertificateVerifier tls_cached unregistered
purple/certificate-Message: CertificateVerifier singleuse unregistered
purple/certificate-Message: CertificatePool tls_peers unregistered
purple/certificate-Message: CertificatePool ca unregistered
purple/main-Message: Unloading normal plugins
purple/plugins-Message: Unloading plugin NSS
purple/certificate-Message: CertificateScheme x509 unregistered
purple/plugins-Message: Unloading plugin SSL
purple/blist-Message: Destroying
purple/util-Message: Writing file status.xml to directory /tmp/haze-RvuBAD
purple/util-Message: Writing file /tmp/haze-RvuBAD/status.xml
purple/main-Message: Unloading all plugins
purple/plugins-Message: Unloading plugin MXit
purple/plugins-Message: Unloading plugin Zephyr
purple/plugins-Message: Unloading plugin Yahoo JAPAN
purple/plugins-Message: Unloading plugin SIMPLE
purple/plugins-Message: Unloading plugin IRC
purple/plugins-Message: Unloading plugin MSN
purple/plugins-Message: Unloading plugin Yahoo
purple/plugins-Message: Unloading plugin Bonjour
purple/plugins-Message: Unloading plugin Gadu-Gadu
purple/plugins-Message: Unloading plugin GroupWise
purple/plugins-Message: Unloading plugin MySpaceIM
purple/plugins-Message: Unloading plugin XMPP
purple/jabber-Message: destroying hash tables for data objects
purple/plugins-Message: Unloading plugin AIM
purple/plugins-Message: Unloading plugin Perl Plugin Loader
purple/plugins-Message: Unloading plugin ICQ
purple/util-Message: Writing file prefs.xml to directory /tmp/haze-RvuBAD
purple/util-Message: Writing file /tmp/haze-RvuBAD/prefs.xml

« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#6 2013-04-26 15:29:12

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: Gnome 3.8 Empathy

The problem comes from glib2, not telepathy. Updating glib2 to the testing version solves the problem.


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#7 2013-04-26 16:08:13

jesusjimenez
Member
Registered: 2007-09-26
Posts: 20

Re: Gnome 3.8 Empathy

Cthulhu82 wrote:

The problem comes from glib2, not telepathy. Updating glib2 to the testing version solves the problem.

I'm running always from testing, so I've had that glib2 already.

Offline

#8 2013-04-26 16:35:22

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: Gnome 3.8 Empathy

Then it should come from both glib2 and telepathy.
I am on the stable repo (I didn't realize your post was in the testing category, my mistake), so I had the same version as yours exept for glib2.


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

Board footer

Powered by FluxBB