You are not logged in.

#1 2013-04-24 18:08:09

wwn
Member
Registered: 2013-03-25
Posts: 68

[solved] After Gnome 3.8/Kernel update bumblebee is broken

After some troubles with Gnome 3.8 and GDM and getting back to work bumblebee is broken. I guess the troubles came with the new kernel.

$ optirun -vv glxgears
[  184.945324] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  184.946196] [DEBUG]optirun version 3.1 starting...
[  184.946228] [DEBUG]Active configuration:
[  184.946239] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  184.946250] [DEBUG] X display: :8
[  184.946260] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia
[  184.946271] [DEBUG] Socket path: /var/run/bumblebee.socket
[  184.946281] [DEBUG] Accel/display bridge: auto
[  184.946291] [DEBUG] VGL Compression: proxy
[  184.946332] [DEBUG]Using auto-detected bridge virtualgl
[  184.974394] [INFO]Response: No - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[  184.974451] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[  184.974471] [DEBUG]Socket closed.
[  184.974531] [ERROR]Aborting because fallback start is disabled.
[  184.974536] [DEBUG]Killing all remaining processes.

$ systemctl status bumblebeed
bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
   Active: active (running) since Mi 2013-04-24 20:00:21 CEST; 4min 40s ago
 Main PID: 264 (bumblebeed)
   CGroup: name=systemd:/system/bumblebeed.service
           └─264 /usr/sbin/bumblebeed

$ cat /proc/acpi/bbswitch
0000:01:00.0 ON

I made a fresh reinstallation of bumblebee but it does not help. All packages inkl. bbswitch are up to date (whole system is up to date). Thx for any hints.

Last edited by wwn (2013-04-24 18:20:33)

Offline

#2 2013-04-24 18:11:16

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [solved] After Gnome 3.8/Kernel update bumblebee is broken

if you are using SNA accel remove it and move to default uxa.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#3 2013-04-24 18:15:24

wwn
Member
Registered: 2013-03-25
Posts: 68

Re: [solved] After Gnome 3.8/Kernel update bumblebee is broken

aaarrrrgh: that was the thing to get gdm and gnome 3.8 get back to work again.!

devil and the deep blue see sad

Offline

#4 2013-04-24 18:17:29

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [solved] After Gnome 3.8/Kernel update bumblebee is broken

Actually my system currently handles both accel methods in gnome 3.8 fie. But with SNA bumblebee is crashing!


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#5 2013-04-24 18:20:06

wwn
Member
Registered: 2013-03-25
Posts: 68

Re: [solved] After Gnome 3.8/Kernel update bumblebee is broken

OK, I did not know that. I have to find another solution for Gnome 3.8.
Thx.

Offline

#6 2013-04-25 13:05:20

Jodell
Member
Registered: 2009-10-09
Posts: 285

Re: [solved] After Gnome 3.8/Kernel update bumblebee is broken

If you want to use SNA and Bumblebee together recompile the intel driver with disabled UXA support.

Offline

#7 2013-04-26 16:52:55

wwn
Member
Registered: 2013-03-25
Posts: 68

Re: [solved] After Gnome 3.8/Kernel update bumblebee is broken

finally the current snapshot updates fixed all smile
thx for your effort

Offline

Board footer

Powered by FluxBB