You are not logged in.

#1 2013-04-23 07:45:56

japgolly
Member
Registered: 2013-04-23
Posts: 10

Today's update breaking cairo-dock, google-chrome, compiz

Hi all,

Like other users are reporting today's update broke a bunch of stuff for me.  Which is cool.  It happens.  Bug reports have been filed and life goes on.

My problem is I'm trying to revert packages and am having trouble identifying which I need to rollback.
I've downgraded glib2 from 2.36.1 to 2.34.3 but that didn't work.
Any advice?

The problems I'm having are:
  * cairo-dock seg fault (https://bugs.archlinux.org/task/34904)
  * compiz/fusion-icon seg fault (https://bugs.archlinux.org/task/34892)
  * google-chrome appears to work but all tabs freeze, none load

Thanks!

David

Offline

#2 2013-04-23 09:35:47

crazyg4merz
Member
Registered: 2013-04-14
Posts: 40

Re: Today's update breaking cairo-dock, google-chrome, compiz

are u on i686 or x64 architecture? if u are on x64 u should also downgrade lib32-glib2 if u have it installed. That's all I know :-)

Offline

#3 2013-04-23 09:49:16

japgolly
Member
Registered: 2013-04-23
Posts: 10

Re: Today's update breaking cairo-dock, google-chrome, compiz

Hey. I'm on x64 and yeah I downgraded both, thanks, but still no luck.
I've also downgraded gtk3 and libsoup but things are still going wrong.

It's odd, after downgrading glib2, gnome-terminal wouldn't start (under xfce4). I had to downgrade gnome-terminal as well to get it working again.

Offline

#4 2013-04-23 09:56:20

japgolly
Member
Registered: 2013-04-23
Posts: 10

Re: Today's update breaking cairo-dock, google-chrome, compiz

If anyone else is having a similar problem downgrading to the following seems to be working. Had one random crash but can't reproduce it. Old packages available here: http://arm.konnichi.com/2013/04

cairo-dock-3.2.0-2-x86_64.pkg.tar.xz
glib2-2.34.3-1-x86_64.pkg.tar.xz
gnome-terminal-3.6.1-1-x86_64.pkg.tar.xz
gtk3-3.6.4-2-x86_64.pkg.tar.xz
lib32-glib2-2.34.3-1-x86_64.pkg.tar.xz
librsvg-2.36.4-1-x86_64.pkg.tar.xz
libsoup-2.40.3-1-x86_64.pkg.tar.xz
libsoup-gnome-2.40.3-1-x86_64.pkg.tar.xz
rest-0.7.90-1-x86_64.pkg.tar.xz

Offline

#5 2013-04-23 11:23:11

rmetzger
Member
Registered: 2012-10-04
Posts: 13

Re: Today's update breaking cairo-dock, google-chrome, compiz

I'm also affected by this bug. xfce4-session seems to crash regularity when using the new glib2, so I downgraded it .. but then eclipse, NetworkManager and others started to make trouble. Is there a simple way to unroll a whole update?

Offline

#6 2013-04-25 13:20:10

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,603
Website

Re: Today's update breaking cairo-dock, google-chrome, compiz

rmetzger wrote:

I'm also affected by this bug. xfce4-session seems to crash regularity when using the new glib2, so I downgraded it .. but then eclipse, NetworkManager and others started to make trouble. Is there a simple way to unroll a whole update?

Use https://aur.archlinux.org/packages/pacsnap/.


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#7 2013-04-25 20:26:32

japgolly
Member
Registered: 2013-04-23
Posts: 10

Re: Today's update breaking cairo-dock, google-chrome, compiz

Good looking tool, thanks!

Offline

#8 2013-04-25 20:48:12

japgolly
Member
Registered: 2013-04-23
Posts: 10

Re: Today's update breaking cairo-dock, google-chrome, compiz

I gave pacsnap a try. Unfortunately it doesn't seem to be able to detect changes made after upgrading pacman from 4.0 to 4.1
It's a shame because it looks like a great tool.

Offline

#9 2013-04-26 20:08:37

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Today's update breaking cairo-dock, google-chrome, compiz

I found that you can use the compton compositor with XFCE instead of Compiz to get rid of video tearing.  Tried it, and it works.  I installed compton-git from AUR.

See following for more info:
http://www.neowin.net/forum/topic/11484 … g-in-xfce/

Offline

Board footer

Powered by FluxBB