You are not logged in.

#1 2013-04-26 10:58:52

Revolt
Member
From: Portugal
Registered: 2009-06-11
Posts: 71
Website

[SOLVED] Konsole, shells and zombies, oh my!

Hello fellow archers!

Decided to try the new KDE yesterday and after some tinkering, I've managed to put it just how I like it. One thing troubles me though: whenever I open Konsole, do something in the shell and then Ctrl+D or type exit, the actual konsole tab is not closed and the shell is left as a zombie process (see next 2 screens). Tried with zsh, bash, new konsole profile, clean kde4 config (removed ~/.kde4) and nothing changes.

http://i41.tinypic.com/4rvxax.jpg

http://i44.tinypic.com/2hyi2r8.jpg

Maybe this is expected behaviour in Konsole, forcing you to use Ctrl+Shit+W to close the tab but that feels very awkward coming from urxvt.

Any feedback?

Last edited by Revolt (2013-04-26 18:35:39)

Offline

#2 2013-04-26 11:23:36

mzneverdies
Member
Registered: 2012-02-04
Posts: 147

Re: [SOLVED] Konsole, shells and zombies, oh my!

Have you tried changing the "close tab" shortcut?

h8xmC01.png

Offline

#3 2013-04-26 12:47:24

Revolt
Member
From: Portugal
Registered: 2009-06-11
Posts: 71
Website

Re: [SOLVED] Konsole, shells and zombies, oh my!

It's not the shortcut that bugs me. It's the zombifying on Ctrl+D or exit.

In addition, just noticed that if I try to close only the tab, Konsole says that it cannot kill /bin/zsh or /bin/bash (tested with both) and asks if I want to force close them but even selecting 'Yes' has no effect. However, closing the entire window (not just the tab) does end up terminating all sessions eventually.

Offline

#4 2013-04-26 14:45:57

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,080

Re: [SOLVED] Konsole, shells and zombies, oh my!

I use konsole with bash, and I don't see what you describe: tab closes and there is no zombie left.

$ echo $TERM                                                                                                         
xterm

Offline

#5 2013-04-26 15:05:58

Revolt
Member
From: Portugal
Registered: 2009-06-11
Posts: 71
Website

Re: [SOLVED] Konsole, shells and zombies, oh my!

Also, in case this wasn't clear, xterm and urxvt still work correctly. Was feeling pretty confident in it being a konsole packaging misconfiguration or something but since berbae is not experiencing it, I'm not so sure anymore. Are you using the latest version of konsole (4.10.2-1) berbae?

Offline

#6 2013-04-26 15:43:03

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,080

Re: [SOLVED] Konsole, shells and zombies, oh my!

Yes I use the latest konsole package.
When you are at the konsole prompt, what is the value of TERM ?
Do you have something special in the .bashrc file or some other configuration file?

Offline

#7 2013-04-26 16:02:01

Revolt
Member
From: Portugal
Registered: 2009-06-11
Posts: 71
Website

Re: [SOLVED] Konsole, shells and zombies, oh my!

I do not have anything special in any rc file to the best of my knowledge since this happens with bash, zsh and even simple sh.

My term is currently set to konsole-256color but I've tried many others including konsole, xterm, rxvt to no avail sad

Offline

#8 2013-04-26 16:07:45

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,080

Re: [SOLVED] Konsole, shells and zombies, oh my!

Post the content of '~/.kde4/share/config/konsolerc' and of your profiles in '~.kde4/share/apps/konsole'.

Offline

#9 2013-04-26 16:12:12

Revolt
Member
From: Portugal
Registered: 2009-06-11
Posts: 71
Website

Re: [SOLVED] Konsole, shells and zombies, oh my!

konsolerc:

[$Version]
update_info=konsole.upd:2.9.0-global-options

[Colors]
CurrentPalette=Forty Colors

[Desktop Entry]
DefaultProfile=Shell.profile

[Favorite Profiles]
Favorites=Shell.profile

[MainWindow]
Height 900=490
State=AAAA/wAAAAD9AAAAAAAAAu4AAAHqAAAABAAAAAQAAAAIAAAACPwAAAAA
ToolBarsMovable=Disabled
Width 1600=750

Shell.profile:

[Appearance]
AntiAliasFonts=true
BoldIntense=false
ColorScheme=My Color Scheme
Font=Monospace,9,-1,5,50,0,0,0,0,0

[Cursor Options]
UseCustomCursorColor=false

[General]
Command=/bin/zsh
Environment=TERM=konsole-256color
Name=Shell
Parent=FALLBACK/
SaveGeometryOnExit=true

[Interaction Options]
AutoCopySelectedText=false
OpenLinksByDirectClickEnabled=true
TrimTrailingSpacesInSelectedText=false

[Keyboard]
KeyBindings=default

[Scrolling]
ScrollBarPosition=2

[Terminal Features]
BidiRenderingEnabled=true
FlowControlEnabled=true

I've also noticed the following on ~/.xsession-errors:

konsole(15724) Konsole::Session::closeInNormalWay: Process  16002  did not die with SIGHUP 
konsole(15724) Konsole::Session::closeInForceWay: Process  16002  did not die with SIGKILL 
konsole(15724) Konsole::Session::closeInNormalWay: Process  16036  did not die with SIGHUP 
konsole(15724) Konsole::Session::closeInForceWay: Process  16036  did not die with SIGKILL

Offline

#10 2013-04-26 18:35:21

Revolt
Member
From: Portugal
Registered: 2009-06-11
Posts: 71
Website

Re: [SOLVED] Konsole, shells and zombies, oh my!

Ok so after lots of manual recompilation of kde packages, I finally noticed that konsole --nofork didn't have this problem which led me to examine the process list to see if there were by any chance any misbehaving konsole processes to which the newest ones could be linking somehow. Indeed I found 2 zombie konsole processes so I killed their kinit parent and now all launched konsoles worked correctly.

The interesting thing is that after the reboot everything seems to be fixed. Since I don't save sessions, I can only assume one of my recompilations/installations/cache cleaning fixed the problem. In particular, I had this ~/.config/Trolltech.conf file which now shows completely different timestamps in the library listing.

This also fixed other problems I had with amarok and ark.

Offline

#11 2013-04-26 18:43:50

Strider
Member
From: Belgium
Registered: 2009-08-04
Posts: 82

Re: [SOLVED] Konsole, shells and zombies, oh my!

Interesting ...
I experienced Konsole hanging also when typing 'exit' the last few days (same issue as you desribed). I deleted ~/.config/Trolltech.conf after reading your last post and ... problem solved !


Win XP -> Ubuntu -> Fedora -> Arch -> Arch -> Arch -> Ar...

Offline

Board footer

Powered by FluxBB