You are not logged in.

#26 2012-10-31 04:29:14

hisland
Member
Registered: 2012-10-29
Posts: 5

Re: [Solved] invalid or corrupted database (PGP signature)

jhello wrote:
rm -R /var/lib/pacman/sync
pacman -Syuf

works!

hey man, i don't think your way works on any others(at least for me), it depends!

i tried may situation, and got some result:

1. if you run

pacman -Syy 

see the message with a .sig with an error

==> Downloading http://mirror.rit.edu/archlinux/core/os/i686/core.db
######################################################################## 100.0%
==> Downloading http://mirror.rit.edu/archlinux/core/os/i686/core.db.sig <<.sig here
######################################################################## 100.0%
error: GPGME error: No data <<error here

that means this mirror site provide a .sig but (maybe) not valid,

so you just change a mirrorlist file that do not provide .sig, like

#Server = http://mirrors.kernel.org/archlinux/$repo/os/$arch

put this  at the first line in your

/etc/pacman.d/mirrorlist

and then run

pacman -Syy 

if you don't see the .sig it may update correctly.

2. don't change the SigLevel in you new  /etc/pacman.conf that contains 'SigLevel = PackageRequired'
i think it may harm for you in some situation

i did the step 1 and update correctly.

and i haven't find a mirror with .sig is correct, does some one find?

i run

rm -R /var/lib/pacman/sync

like @jhello said, it will remove the .sig file in your local. if the step 1 does not work, run it and then do step 1 again.

Offline

#27 2013-04-30 06:35:25

jimmuzz
Member
Registered: 2013-04-30
Posts: 1

Re: [Solved] invalid or corrupted database (PGP signature)

Thanks everyone for your help. For me, the problem turned out to be the public internet server I was using at the time, rather than a specific mirror. It was filtering and redirecting pacman requests to it's own html redirection page. By using a different internet connection, removing the html .db.sig files and refreshing the database, it worked again. After trying it all again, I found removing the .db.sig files wasn't necessary though.

Thanks again

Offline

#28 2013-05-05 21:26:21

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 663

Re: [Solved] invalid or corrupted database (PGP signature)

I have a similar problem, just way more specific.
Only package I can't update is dropbox, which gives me this error message:

error: dropbox: missing required signature
:: File /var/cache/pacman/pkg/dropbox-2.0.8-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you wish to remove it? [Y/n]

This might not be the best place for this, but I must say I do like that pacman go localised, in my case to Slovene, but I might have translated ":: File /var/cache/pacman/pkg/dropbox-2.0.8-1-x86_64.pkg.tar.xz is corrupted"
wrong.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#29 2013-05-05 21:35:12

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: [Solved] invalid or corrupted database (PGP signature)

dropbox is not in the official repos. It's in archlinuxgr and archlinuxcn.

I don't understand the part about localization, but I'm pretty sure this i s not the right place for this discussion :-)

Offline

#30 2013-05-06 21:33:20

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 663

Re: [Solved] invalid or corrupted database (PGP signature)

Strange... only now, I've noticed, that yeah dropbox isn't in the main repo.
Thanks!


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#31 2013-05-06 21:38:44

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,699
Website

Re: [Solved] invalid or corrupted database (PGP signature)

I think this thread has run its course.

Offline

Board footer

Powered by FluxBB