You are not logged in.

#1 2013-04-30 04:00:40

rzrscm
Member
Registered: 2012-11-17
Posts: 86

[SOLVED] Problem automounting USB storage devices with Thunar...

I installed thunar, thunar-volman, gvfs, and polkit-gnome...I created the 10-drives.rules file specified on the GVFS page in the wiki...I added myself to all of the storage-related groups...I enabled "mount removable drives when hotplugged" and "mount removable drives when inserted" in the volume management settings...

Yet, nothing will mount when inserted.  What am I missing?  I've never had this problem in the past.

Last edited by rzrscm (2013-04-30 23:25:33)

Offline

#2 2013-04-30 20:53:54

torors
Member
Registered: 2012-09-28
Posts: 86

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

Have you tried udiskie?

Offline

#3 2013-04-30 21:14:56

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

usbmount from the AUR.

I have tried to follow the wiki for mounting a usb stick (it works), but I was looking for a simple plugin & play option when using i3wm.

usbmount does exactly that. Very nice indeed.


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#4 2013-04-30 21:55:38

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

I haven't tried anything else, but I did want to point out that none of my devices aside from my HDD even show up in Thunar's sidepane...I don't know how relevant that is.

Offline

#5 2013-04-30 22:06:17

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

...try usbmount


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#6 2013-04-30 22:11:50

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

Okay, after doing some research, it seems to work if I launch Thunar with "dbus-launch thunar" except my CD-ROM still doesn't show up, and I don't want to have to launch Thunar this way every time.

Last edited by rzrscm (2013-04-30 22:17:21)

Offline

#7 2013-04-30 22:14:02

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

Am I fucking invisible ??????

try usbmount !!!!


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#8 2013-04-30 22:14:06

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

flipper T wrote:

...try usbmount

Well, I've determines that mounting isn't my issue at this point...It's the way Thunar's handling (or not) my devices.

Offline

#9 2013-04-30 23:18:58

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,570
Website

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

flipper T wrote:

Am I fucking invisible ??????

try usbmount !!!!

No, you're not invisible. You are annoying. Also, you are ignoring rzrscm's question.

Both rzrscm and I want to use automounting in Thunar. This is functionality that has worked in the past in Arch Linux and also works in every other Linux distribution that uses Thunar. You know, all those distros that don't use your very special usbmount application.

Last edited by drcouzelis (2013-04-30 23:21:58)

Offline

#10 2013-04-30 23:24:20

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

drcouzelis wrote:
flipper T wrote:

Am I fucking invisible ??????

try usbmount !!!!

No, you're not invisible. You are annoying. Also, you are ignoring rzrscm's question.

Both rzrscm and I want to use automounting in Thunar. This is functionality that has worked in the past in Arch Linux and also works in every other Linux distribution that uses Thunar.

Well, solved the problem through some trial and error and reading through an old thread dealing with this same issue except with some outdated information.

In my xinit, I had to change "exec awesome" to "exec dbus-launch awesome" [awesome being the name of my WM, obviously], and now everything works perfectly [my CD-ROM still doesn't show up, but I'm sure that's another issue entirely].

Last edited by rzrscm (2013-04-30 23:28:18)

Offline

#11 2013-04-30 23:45:23

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,570
Website

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

Thank you for pushing me to look further into my problem. I think I might have a "better" solution for you. wink

Arch Linux provides a skeleton ".xinitrc" file here: "/etc/skel/.xinitrc"

It shows you how to load all of the scripts that are in the "/etc/X11/xinit/xinitrc.d" directory. One of those scripts will check for and start D-Bus for you. If you make your ".xinitrc" file similar to the skeleton, then you won't need to use "dbus-launch" yourself.

As for my problem, I was already starting D-Bus. My problem was that I didn't have the correct checkboxes selected in "thunar-volman-settings". tongue

Offline

#12 2013-05-01 05:26:15

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

Apologies all around for my bad language in earlier post.

I was drunk (shame-face) & had had a bad day & was venting here.

Again, apology offered. (wine was very very nice though. Second bottle was even nicer !)

sad


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#13 2013-05-01 05:54:36

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,570
Website

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

I forgive you.

The important thing is that it's now a little easier for each of us to access photos from a memory card in order to upload more cat pictures to the Internet.

Offline

#14 2013-05-01 06:03:59

dag
Member
From: US
Registered: 2013-01-20
Posts: 216

Re: [SOLVED] Problem automounting USB storage devices with Thunar...

there is also devmon via udevil which works flawlessly for me


--------------------------------------
alcoves wonder creates the wonder unto the ages; never lose that.

Offline

Board footer

Powered by FluxBB