You are not logged in.

#1 2013-05-02 10:21:22

fib
Member
Registered: 2012-06-13
Posts: 13

GDM freezes

Hello,

I went through a problem yesterday starting gdm after a fresh new archlinux installation.
Whenever I try to launch gdm the process stop after a couple of minutes in a black screen where I can only move the mouse cursor.
I'm still able to switch into another console and pkill X.

The desktop environment (Gnome Shell 3.8) runs perfectly out-of-the-box by starting it manually with startx (.xinitrc file contains only "exec gnome-session").

The video driver installed is nvidia propetary driver (via pacman).... I also tried to install noveau and see if the problem can be solved in such way but the result was exactly the same.

If you need any kind of log, plaese let me know which one you need.

Offline

#2 2013-05-02 10:52:07

KCE
Member
From: SoCal
Registered: 2007-06-26
Posts: 41

Re: GDM freezes

https://bbs.archlinux.org/viewtopic.php … 8#p1264138

I use nvidia on on my desktop and intel/nvidia on my ultrabook; both had issues with the upgrade, but the following worked for me.

See jrussell's post on page 4:

jrussell wrote:

Perhaps give this a try, read the whole post before trying.
Be carefull with the -c option in

pacman -Rnsc gnome gnome-extra

look here: https://wiki.archlinux.org/index.php/Pa … g_packages

systemctl disable gdm.service
systemctl disable graphical.target
systemctl enable multi-user.target
--reboot--
pacman -Rnsc gnome gnome-extra
rm -R /var/lib/gdm .gnome2 .cache .config/gnome-session .config/autostart .config/dconf .config/gconf .config/gtk-3.0 .config/gtk-2.0 .config/nautilus .config/user-dirs.dirs .config/tracker .local/share/gnome-shell .local/share/gnome-settings-daemon
--reboot--
pacman -S gnome
systemctl enable gdm.service
systemctl disable multi-user.target
systemctl enable graphical.target
--reboot--

I did see

 error: command failed

when removing gdm

and

 directory permissions differ on /var/log/gdm
 filesystem: 771 package: 1770.

when insatlling gdm

I myself actually deleted the entire contents of .config and .local/share just to reset all my settings.
The above my have excessive reboots/commands but I have had no problems other than this:
https://bbs.archlinux.org/viewtopic.php?id=161961

I have found this 3.8 release much buggier than previous gnome updates, I have many small issues/bugs with gnome, there are a large amount of errors in my journal relating to gnome and gdm, journal is nice and clean with lxdm and xfce4.


elkoraco wrote:

Removing gnome-screensaver fixes the issue. Somebody should probably put this up for everybody to see, as it is by far the most likely solution to the problem.

pacman -Rnsc gnome gnome-extra

sorted that out for me.

Offline

#3 2013-05-02 23:42:37

mandog
Member
From: Peru
Registered: 2008-09-17
Posts: 204

Re: GDM freezes

Or you could install LXDM then     systemctl disable gdm.service  then        systemctl enable  lxdm.service      reboot  and all should be OK. I don't ever recall any problems with LXDM. I always found GDM slow.
I also don't have problems with Nvidia.


I'm dyslexic Please do not complain about puntuation or spelling and remember most dyslexic people have above average iq.

Offline

Board footer

Powered by FluxBB