You are not logged in.

#1 2013-05-02 16:52:10

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,301

Gnome: Capslock for switching input sources (kbd layouts)

Hi,

In Settings->Keyboard-Typing I can't change Super+Space to Capslock: it gets ignored, unlike most of the keys. Setting Capslock in Tweak Tool won't work either. What else can I try?

Offline

#2 2013-05-03 01:30:15

UnsolvedCypher
Member
Registered: 2012-04-28
Posts: 198

Re: Gnome: Capslock for switching input sources (kbd layouts)

I've submitted a bug: https://bugzilla.gnome.org/show_bug.cgi?id=699541
Other than that, it seems like there isn't much you can do. You can try remapping the caps lock key to something the shortcut editor will accept, but that is hacky.

Offline

#3 2013-05-03 06:00:37

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,301

Re: Gnome: Capslock for switching input sources (kbd layouts)

Thanks, UnsolvedCypher!

Offline

#4 2013-05-03 10:40:13

UnsolvedCypher
Member
Registered: 2012-04-28
Posts: 198

Re: Gnome: Capslock for switching input sources (kbd layouts)

And it looks like there is a solution! In order to switch to something like Caps Lock or Alt Shift, you need to set the shortcut for "Modifiers-only switch to next source" rather than "Switch to next input source". To set it, you need to press and hold the disable button, mouse over the one you want (Caps Lock), and release the mouse. If this solves your problem, don't forget to mark the thread [SOLVED]. big_smile

Last edited by UnsolvedCypher (2013-05-03 10:41:15)

Offline

Board footer

Powered by FluxBB