You are not logged in.

#1 2013-04-25 07:51:59

step-2
Member
Registered: 2012-05-08
Posts: 60

no sound under gdm

Hi there ,

i did a fresh install yesterday , and everything seems to be working fine

except sound on gdm login screen is muted , when i click on the sound menu to unmute it, it has a weird two control one for sound and another for microphone ,
and the slider don't produce any sound .

tried alsamixer & pavucontrol and everything is working & unmuted .

i haven't troubleshooted pulseaudio problems before , so any ideas are welcome

Offline

#2 2013-04-25 07:57:07

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: no sound under gdm

Do you have alsa-utils installed?


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#3 2013-04-25 08:31:11

step-2
Member
Registered: 2012-05-08
Posts: 60

Re: no sound under gdm

yes

Offline

#4 2013-04-30 23:08:36

StR@ng3r
Member
Registered: 2011-11-12
Posts: 61

Re: no sound under gdm

I have the same issue.

Offline

#5 2013-05-02 00:25:49

ub1quit33
Member
Registered: 2013-04-30
Posts: 58

Re: no sound under gdm

What is the device name and port being shown in pavucontrol?

Offline

#6 2013-05-02 16:53:48

LyCC
Member
Registered: 2012-09-05
Posts: 88

Re: no sound under gdm

A little experiment: try in the pulse audio volume control, the Output tab, "Headphone" instead of "Analog" (if you have this, even if its "Headphone Unplugged", select that), and at the "Profile" tab select "Analog Stereo output" - if you have these options.

Last edited by LyCC (2013-05-02 16:55:38)

Offline

#7 2013-05-02 22:41:02

step-21
Member
Registered: 2013-05-02
Posts: 3

Re: no sound under gdm

ub1quit33 wrote:

What is the device name and port being shown in pavucontrol?

port: Analog output

Offline

#8 2013-05-02 22:45:49

step-21
Member
Registered: 2013-05-02
Posts: 3

Re: no sound under gdm

LyCC wrote:

A little experiment: try in the pulse audio volume control, the Output tab, "Headphone" instead of "Analog" (if you have this, even if its "Headphone Unplugged", select that), and at the "Profile" tab select "Analog Stereo output" - if you have these options.

in the output tab the option selected is : Analog output
and there is no other option in the drop down menu

tried changing profile to : Analog stereo output , with no luck

Offline

#9 2013-05-03 01:46:25

ub1quit33
Member
Registered: 2013-04-30
Posts: 58

Re: no sound under gdm

If you plug in analog headphones, do you get sound on those? Also, paste output from pulseaudio -vvvvv

Offline

#10 2013-05-03 14:20:08

step-21
Member
Registered: 2013-05-02
Posts: 3

Re: no sound under gdm

ub1quit33 wrote:

If you plug in analog headphones, do you get sound on those? Also, paste output from pulseaudio -vvvvv

in the desktop yes , the problem only under gdm

pulseaudio -vvvvv :


I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 3.0
D: [pulseaudio] main.c: Compilation host: x86_64-unknown-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wall -W -Wextra -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux x86_64 3.8.10-1-ck #1 SMP PREEMPT Fri Apr 26 22:29:14 EDT 2013
D: [pulseaudio] main.c: Found 2 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is b3dcf7e4818d4a05993ad80aad7e398a.
I: [pulseaudio] main.c: Session ID is 2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/step-2/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-3.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Offline

#11 2013-05-07 00:14:37

ub1quit33
Member
Registered: 2013-04-30
Posts: 58

Re: no sound under gdm

step-21 wrote:
ub1quit33 wrote:

If you plug in analog headphones, do you get sound on those? Also, paste output from pulseaudio -vvvvv

in the desktop yes , the problem only under gdm

pulseaudio -vvvvv :


I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 3.0
D: [pulseaudio] main.c: Compilation host: x86_64-unknown-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wall -W -Wextra -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux x86_64 3.8.10-1-ck #1 SMP PREEMPT Fri Apr 26 22:29:14 EDT 2013
D: [pulseaudio] main.c: Found 2 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is b3dcf7e4818d4a05993ad80aad7e398a.
I: [pulseaudio] main.c: Session ID is 2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/step-2/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-3.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

I'm not sure I understand what you mean here. So are you saying after you log in you have sound? Also, I probably should have mentioned, you should have run

pulseaudio --kill

before running the command I mentioned, and then after you get your output, you can ^C and start pulseaudio back up using

pulseaudio --start

Offline

Board footer

Powered by FluxBB