You are not logged in.

#26 2013-04-25 12:34:34

oceans11
Member
Registered: 2010-06-24
Posts: 11

Re: mplayer2 and fontconfig-2.10.92-4

Javafant wrote:
oceans11 wrote:
Rasi wrote:

then

mv osd_font.pfb ~/.mplayer/subfont.ttf

worked for me too.
Thank you, guys!

Are you talking about subtitles or the osd? I don't have subtitels to test, but the osd is still broken. This is what the output looks like:

[ass] FcFreeTypeQueryFace failed

osd. i don't have subtitles too.

Offline

#27 2013-04-26 20:57:41

maletor
Member
Registered: 2013-03-28
Posts: 10

Re: mplayer2 and fontconfig-2.10.92-4

oceans11 wrote:
Javafant wrote:
oceans11 wrote:

then

mv osd_font.pfb ~/.mplayer/subfont.ttf

worked for me too.
Thank you, guys!

Are you talking about subtitles or the osd? I don't have subtitels to test, but the osd is still broken. This is what the output looks like:

[ass] FcFreeTypeQueryFace failed

osd. i don't have subtitles too.

Copying the file like that doesn't seem to work for me. Specifically the OSD play icon is still broken and the [ass] error still comes up from the mplayer output.

Offline

#28 2013-04-26 21:02:13

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,471
Website

Re: mplayer2 and fontconfig-2.10.92-4

maletor wrote:

Copying the file like that doesn't seem to work for me. Specifically the OSD play icon is still broken and the [ass] error still comes up from the mplayer output.

You mean, where you used to see the "play" icon your now see the three dots (contrast?) icon? That's what I see. This "copy file" fix certainly helps, but doesn't appear to be perfect...

Offline

#29 2013-04-26 21:17:58

maletor
Member
Registered: 2013-03-28
Posts: 10

Re: mplayer2 and fontconfig-2.10.92-4

What I see is a square box (like a National Geographic logo). Not three dots.

MPV Player is tracking it here: https://github.com/mpv-player/mpv/issue … t-17100091

Offline

#30 2013-04-26 22:07:31

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: mplayer2 and fontconfig-2.10.92-4

Did you save the font as /usr/share/fonts/<dir>/osd_font.pfb, just like I suggested above? If you did, then you should see something like in the screenshot from my mplayer2 running. All other symbols (~13 altogether) are displayed correctly, too…


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#31 2013-04-27 00:52:01

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,471
Website

Re: mplayer2 and fontconfig-2.10.92-4

bohoomil wrote:

Did you save the font as /usr/share/fonts/<dir>/osd_font.pfb, just like I suggested above? If you did, then you should see something like in the screenshot from my mplayer2 running. All other symbols (~13 altogether) are displayed correctly, too…

Yes, your fix works 100% correctly. To clarify:

rkreis's suggestion is mostly a fix. (what I was using)

bohoomil's suggestion is a complete fix. (what I'm now using)

Last edited by drcouzelis (2013-04-27 00:52:17)

Offline

#32 2013-04-27 08:36:36

Javafant
Member
Registered: 2012-04-02
Posts: 19

Re: mplayer2 and fontconfig-2.10.92-4

bohoomil's suggestion worked for me aswell.

Offline

#33 2013-04-27 17:14:12

shomyo
Member
From: /dev/sda1
Registered: 2009-11-06
Posts: 40
Website

Re: mplayer2 and fontconfig-2.10.92-4

bohoomil

Thanks bro.


No signature currently stored in profile.

Offline

#34 2013-04-30 00:09:03

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: mplayer2 and fontconfig-2.10.92-4

mpv player fix the issue with commit https://github.com/mpv-player/mpv/commi … 030da57572

i make the same changes in my mplayer2-build-git pkgbuild in AUR

(save font in otf format with fontforge and change path in makefile)

Last edited by sl1pkn07 (2013-04-30 00:11:15)

Offline

#35 2013-05-03 19:43:49

ianux
Member
From: France
Registered: 2008-12-02
Posts: 14
Website

Re: mplayer2 and fontconfig-2.10.92-4

While the trick with the PFB font didn't work for me, using the OTF font actually did it. I didn't even have to rebuild mplayer2 (just mkfontdir/mkfontscale/fc-cache).
Here it is, from sl1pkn07 PKGBUILD : https://dl.dropboxusercontent.com/u/659 … d_font.otf


listen to radio ianux!

Offline

#36 2013-05-03 21:10:06

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: mplayer2 and fontconfig-2.10.92-4

It might have not worked if your font policy rejects T1 fonts.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#37 2013-05-04 02:11:35

djpohly
Member
Registered: 2007-08-14
Posts: 23

Re: mplayer2 and fontconfig-2.10.92-4

You can probably avoid touching system directories this way:

mkdir -p ~/.fonts/OSD
wget -O ~/.fonts/OSD/osd_font.pfb 'http://git.mplayer2.org/mplayer2/plain/sub/osd_font.pfb?id=9d6b188'
fc-cache -f -v ~/.fonts

That worked for me at least. smile

Offline

#38 2013-05-04 03:15:18

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: mplayer2 and fontconfig-2.10.92-4

djpohly wrote:

You can probably avoid touching system directories this way:

mkdir -p ~/.fonts/OSD
wget -O ~/.fonts/OSD/osd_font.pfb 'http://git.mplayer2.org/mplayer2/plain/sub/osd_font.pfb?id=9d6b188'
fc-cache -f -v ~/.fonts

That worked for me at least. smile

Of course it did -- this location is still available. Just in case, don't forget about the $XDG_DATA_HOME/fonts || $HOME/.local/share/fonts which will eventually replace it.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#39 2013-05-06 22:15:36

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: mplayer2 and fontconfig-2.10.92-4

Offline

#40 2013-05-06 23:01:54

opt1mus
Member
From: UK
Registered: 2011-12-31
Posts: 197
Website

Re: mplayer2 and fontconfig-2.10.92-4

This of course goes for mpv too;
wm4's commit to mpv
Built from git via PKGBUILD from the AUR a few moments ago, the OSD shows glyphs correctly - that were previously missing. No intervention/hackery on my part of any kind, re: fixes in this thread.

local/fontconfig 2.10.92-4
local/libass 0.10.1-1

Offline

#41 2013-05-06 23:14:26

Gusar
Member
Registered: 2009-08-25
Posts: 3,447

Re: mplayer2 and fontconfig-2.10.92-4

Well, there is still a bug in fontconfig. So saying "fixed" is not fully correct. Any other situation where PostScript fonts from memory are being used are still broken.

On the other hand, this thread is about mplayer2, and here the issue is indeed "fixed" by changing the format of the font into one that does not trigger the fontconfig bug.

Offline

#42 2013-05-19 15:26:58

Blaubos
Member
Registered: 2013-05-19
Posts: 1

Re: mplayer2 and fontconfig-2.10.92-4

They converted the font to OTF. Here's a copy&paste to fix this issue:

cd /usr/share/fonts/OTF
sudo wget -O mplayer2_osd_font.otf http://git.mplayer2.org/mplayer2/plain/sub/osd_font.otf
sudo fc-cache -f -v

You can delete /usr/share/fonts/OTF/mplayer2_osd_font.otf once the fix comes to Arch repos.

Last edited by Blaubos (2013-05-19 17:17:19)

Offline

#43 2013-05-21 16:34:12

SneakySnake
Member
Registered: 2012-03-30
Posts: 9

Re: mplayer2 and fontconfig-2.10.92-4

Issue fixed with fontconfig 2.10.93-1.

Offline

Board footer

Powered by FluxBB