You are not logged in.

#1 2013-05-06 22:19:38

flipper T
Member
Registered: 2012-09-14
Posts: 419

libpng15.so.15 crash

Following todays updates to : firefox-20.0.1-5  gdk-pixbuf2-2.28.1-2  libpng-1.6.2-3

When I try to start  X I get a crash followed by a message

"libpng15.so.15: cannot open shared object file"

I think it is the same problem discussed here :https://bbs.archlinux.org/viewtopic.php?id=162661

but I could not really follow that thread & I am not using the testing repos.

What I could gather from that thread was that downgrading the packages mentioned above should (and does) solve the problem.

I can now log into X fine, but am seeking reassureance here that I have done the right thing.

Any help appreciated.

Last edited by flipper T (2013-05-07 01:08:00)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#2 2013-05-06 22:22:13

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: libpng15.so.15 crash

I guess we'll be seeing a lot of these. People really should understand better the responsibilities of using AUR packages that replace important packages from the repos. In this case, cairo.

Last edited by Gusar (2013-05-06 22:28:57)

Online

#3 2013-05-06 22:26:28

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: libpng15.so.15 crash

Now that you have had a good old sigh, any chance of a constructive pointer ?


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#4 2013-05-06 22:29:24

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: libpng15.so.15 crash

I did give you one, I told you directly which package is responsible.

Online

#5 2013-05-06 22:39:47

bisam
Member
From: Vienna
Registered: 2012-10-31
Posts: 16

Re: libpng15.so.15 crash

Gusar wrote:

I did give you one, I told you directly which package is responsible.

So removing cairo with, for example pacman -Rs cairo, should work?

I have encountered the same error while I updated, but I did not restart till now, so X is still functioning...

( 20/117) upgrading firefox       [##################################################################] 100%
gtk-update-icon-cache: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory
error: command failed to execute correctly

Offline

#6 2013-05-06 22:41:51

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: libpng15.so.15 crash

Offline

#7 2013-05-06 22:42:24

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: libpng15.so.15 crash

Gusar wrote:

I did give you one, I told you directly which package is responsible.


Hi again. Are you referring to lib32-cairo ? And if so, do I just need to downgrade to 1.12.14-3 to resolve.

I really am trying my best, but am in the dark. So help is appreciated.


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#8 2013-05-06 22:45:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: libpng15.so.15 crash

@flipper T
lib32-cairo is in the official repos and shoudl work just fine. If you want to find the culprit, search among the AUR packages: 'pacman -Qqm'.

Offline

#9 2013-05-06 22:51:15

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: libpng15.so.15 crash

I'm referring to using cairo-ubuntu or similar package from AUR. I think the infinality font stuff installs it's own cairo too. The official cairo package got updated by the Arch devs, any unofficial ones need to be updated by you. Or, much better, stop using such packages. Unless you're fully aware of the consequences. This thread shows some of you are not.

Last edited by Gusar (2013-05-06 22:52:58)

Online

#10 2013-05-06 22:59:00

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: libpng15.so.15 crash

If the finger is pointing at me, so yes, I have done my job already…


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#11 2013-05-06 23:12:39

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: libpng15.so.15 crash

I am not trying to be a "help vampire" here. Just utterly lost.

I have now removed bohoomil (beautiful) infinality bundle, run the update & everything is ok (if rather ugly).

bohoomill, any help ? You have been extremely helpful to me in the past.


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#12 2013-05-06 23:17:56

progandy
Member
Registered: 2012-05-17
Posts: 2,143

Re: libpng15.so.15 crash

Just try to reinstall infinality.

Offline

#13 2013-05-06 23:19:32

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: libpng15.so.15 crash

As I said, cairo has been rebuilt for all architectures. I even installed everything from the remote repo to double-check the package. Did pacman fetch the update? It should read

cairo-infinality-ultimate 1.12.14-5 (infinality-bundle)

:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#14 2013-05-06 23:21:05

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: libpng15.so.15 crash

Run 'pacman -Syu'. I'm using the infinality bundle and I'm fine.

Offline

#15 2013-05-06 23:32:31

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: libpng15.so.15 crash

bohoomil wrote:

As I said, cairo has been rebuilt for all architectures. I even installed everything from the remote repo to double-check the package. Did pacman fetch the update? It should read

cairo-infinality-ultimate 1.12.14-5 (infinality-bundle)

bohoomil, have just checked my pacman.conf to find that, for whatever stupid reason on my part, your custom repos were commented out. I have corrected this, reinstalled your (wonderful) package & everything seems to be hunky-dory.

So, thanks to those who helped & those who sighed.

I will mark as solved. I hope that this thread might prove useful to someone else.

grrr.


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#16 2013-05-06 23:37:10

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: libpng15.so.15 crash

Never mind, I'm glad it's working again. However, you could have stated it clearly at the beginning that you are using the bundle… wink


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#17 2013-05-06 23:40:27

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: libpng15.so.15 crash

bohoomil wrote:

Never mind, I'm glad it's working again. However, you could have stated it clearly at the beginning that you are using the bundle… wink

I had no idea that this was the issue, or I would have.

Thanks again.


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#18 2013-05-07 01:04:47

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: libpng15.so.15 crash

I'm confused. I got errors on updating:

[2013-05-06 22:23] [PACMAN] upgraded libpng (1.5.15-1 -> 1.6.2-3)
[2013-05-06 22:24] [ALPM-SCRIPTLET] gtk-update-icon-cache: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-06 22:24] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-06 22:24] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-06 22:25] [PACMAN] upgraded lib32-libpng (1.5.15-1 -> 1.6.2-1)

I am using infinality but I checked and everything I have with "cairo" in is from the official repos. I also checked the directory where I keep built packages prior to install and there is nothing there with the string cairo in the name.

I reinstalled gdk-pixbuf2 as the thread in the testing repo suggested but now I'm not sure if there is something further I need to do or not. That is, I mean about infinality - I realise if there are AUR packages I'm using which use libpng, I will need to identify and rebuild those. I just can't see any dependency affecting freetype2-infinality or fontconfig-infinality when I look at their PKGBUILDs.

What am I missing?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#19 2013-05-07 01:07:36

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: libpng15.so.15 crash

cfr, I wish I could help, but while my problem as been resolved, I am still none the wiser.

What I can do, however, is mark the topic not - "solved".

Good luck.


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#20 2013-05-07 01:43:07

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: libpng15.so.15 crash

@cfr: Which cairo version are you using? cairo 1.12.14-4? If you have already updated to this one, then re-install librsvg, libpng and gdk-pixbuf2. cairo is the biggest pain there, but once you have it, others should follow.

Last edited by bohoomil (2013-05-07 01:43:33)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#21 2013-05-07 03:09:12

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: libpng15.so.15 crash

bohoomil wrote:

@cfr: Which cairo version are you using? cairo 1.12.14-4? If you have already updated to this one, then re-install librsvg, libpng and gdk-pixbuf2. cairo is the biggest pain there, but once you have it, others should follow.

Yes. That's the version. I already reinstalled gdk-pixbuf2 so I've now also reinstalled libpng and librsvg. Thanks for the help.

But my version of cairo is from the official repo even though I'm using infinality which is what I'm somewhat confused about.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#22 2013-05-07 05:27:58

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: libpng15.so.15 crash

I had the same problem.

I just had to re-install cairo-ubuntu from the AUR, so it will build with libpng16

All is good now smile

Last edited by hunterthomson (2013-05-07 05:28:52)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#23 2013-05-07 08:11:06

89c51
Member
Registered: 2012-06-05
Posts: 642

Re: libpng15.so.15 crash

I am not using anything from aur and this is what i got during an update today.

[2013-05-07 11:03] [ALPM-SCRIPTLET] gtk-update-icon-cache: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-07 11:03] [PACMAN] upgraded firefox (20.0.1-2 -> 20.0.1-5)
[2013-05-07 11:03] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory 

Firefox seems to be working OK though. hmm

Offline

#24 2013-05-07 08:33:14

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,700

Re: libpng15.so.15 crash

It's simply because firefox is being updated after libpng but before gdk-pixbuf2, so it's not able to update the icon cache. Shouldn't matter, the icon cache doesn't need updating with this update of firefox, so it wouldn't really do anything even if it ran fine.

Online

#25 2013-05-07 13:54:50

kelloco2
Member
Registered: 2012-02-13
Posts: 121

Re: libpng15.so.15 crash

[2013-05-07 13:50] [PACMAN] upgraded gd (2.0.36RC1-5 -> 2.0.36RC1-6)
[2013-05-07 13:50] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-07 13:50] [PACMAN] upgraded gdk-pixbuf2 (2.28.1-1 -> 2.28.1-2)
[2013-05-07 13:50] [PACMAN] upgraded gegl (0.2.0-7 -> 0.2.0-8)
[2013-05-07 13:50] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-07 13:50] [PACMAN] upgraded libwmf (0.2.8.4-9 -> 0.2.8.4-10)

gtk-update-icon-cache /usr/share/icons/Faenza works, but Can I ignore it? "/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory"


sorry for my english. {Arch Linux, Debian} User

Offline

Board footer

Powered by FluxBB