You are not logged in.

#1 2012-08-27 20:00:55

Teyras
Member
Registered: 2010-07-14
Posts: 36

systemd boot messages in the login prompt

Hi,
I just switched to systemd and there is one thing left bothering me - after the login prompt appears, systemd keeps spamming messages about some services starting (mysql, ntp...). I've googled a little and found that this should have been fixed some time ago by adding the Type=idle parameter, which is already set in my getty service file (/usr/lib/systemd/system/getty@.service) without any results.
Thanks

Offline

#2 2012-08-27 20:10:41

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,537

Re: systemd boot messages in the login prompt

If you use the "quiet" parameter on the kernel command line, you won't get output from systemd in your console at all. Maybe that's good enough for you, and maybe it's not.

Offline

#3 2012-08-27 20:23:36

Teyras
Member
Registered: 2010-07-14
Posts: 36

Re: systemd boot messages in the login prompt

Well, I want to see what's happening to my system, but I don't want to see it all over my login prompt...

Offline

#4 2012-08-27 21:37:42

patroclo7
Member
From: Bassano del Grappa, ITALY
Registered: 2006-01-11
Posts: 913

Re: systemd boot messages in the login prompt

+1
This is for me atm the only annoyance of systemd. Let me know if you are going to report a bug, otherwise I shall report it myself.

Last edited by patroclo7 (2012-08-27 21:38:13)


Mortuus in anima, curam gero cutis

Offline

#5 2012-08-28 07:56:58

Teyras
Member
Registered: 2010-07-14
Posts: 36

Re: systemd boot messages in the login prompt

Since I'm not sure where should I report this, I guess it would be nice of you if you did it...
EDIT: Okay, this is the bug report... https://bugs.freedesktop.org/show_bug.cgi?id=54247

Last edited by Teyras (2012-08-30 07:05:54)

Offline

#6 2012-08-30 23:11:24

BrainWorker
Member
Registered: 2011-02-23
Posts: 26

Re: systemd boot messages in the login prompt

I have the same situation !!!

I dont know maybe is not proper to write about it in "Applications & Desktop Environments" but rather in "Arch Discussion" (systemd is part of Arch now) or in "Pacman & Package Upgrade Issues" (this issue appers right after upgrade).

Nevertheless, I have the same situation.

I updated the system. During update some packages were replaced with 'systemd'. Then suggestion appeared - to append 'init=/bin/systemd' to kernel command line options in your bootloader. I have syslinux as bootloader.
I did it. After reboot a lot of messages appeared.
[ OK ] ..........
[ OK ] ..........
[ OK ] ..........

But after login prompt appears the same continued

[ OK ] ..........
[ OK ] ..........
[ OK ] ..........

Offline

#7 2012-08-31 00:25:14

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,408
Website

Re: systemd boot messages in the login prompt

Same!  I just used "quiet"...

Offline

#8 2012-08-31 00:39:38

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: systemd boot messages in the login prompt

Yeah, it certainly seems like a bug.  But I think with "quiet" and a decent log level, journalctl gives me plenty of info in the event I do want to see what is going on.

Offline

#9 2012-11-18 11:41:52

honestleaf
Member
Registered: 2011-07-03
Posts: 5

Re: systemd boot messages in the login prompt

Well, i don't think it is really a bug. It is a matter of service booting order. For me, i just move the getty service to graphical target so that it will spwan at the end of the booting. Then, there is  no more overlapped message.

Offline

#10 2012-11-18 11:56:23

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,810
Website

Re: systemd boot messages in the login prompt

What is the "Type" line of your getty service file?

If it is anything other than "Type=idle" (or perhaps also "Type=simple") than what you describe is the expected behavior.  Change it to "Type=idle" to avoid this.

Last edited by Trilby (2012-11-18 11:56:56)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#11 2013-01-08 01:12:25

hawaiicharles
Member
Registered: 2012-12-21
Posts: 71

Re: systemd boot messages in the login prompt

The following has happened to me on multiple (fresh) installations:

After following the directions here: https://wiki.archlinux.org/index.php/Ne … _Operation to set up a static wired connection, I'm seeing curious behavior when the system boots.  Specifically, the login prompt appears before the boot process is complete.  So I end up with a screen looking like this:

Arch Linux 3.6.11-1-ARCH (tty1)
Myhostname login: [ OK ] Started Netcfg networking service for profile blahblah
[ OK ] Reached target Multi-User.
[ OK ] Reached target Graphical Interface

There's a blinking cursor on the next line after that.  It's not really a big deal, since I can just press enter and get a fresh login prompt.  However, it violates my sense of having things clean and orderly.  I did a fair amount of searching, but didn't find any reference to this occurance.  Though, like I said, I've seen it multiple times.  Has anyone else seen this and is there a fix?

Offline

#12 2013-01-08 01:25:50

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,801
Website

Re: systemd boot messages in the login prompt

Known bug: reported upstream.

https://bbs.archlinux.org/viewtopic.php?id=147808

and a couple of other threads...


Merging


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#13 2013-05-09 09:00:33

gilmoreja
Member
From: Florida
Registered: 2012-05-28
Posts: 71

Re: systemd boot messages in the login prompt

I don't mean to necro an old thread, but it doesn't look like this was resolved for OP and it's a problem that irritated me for a long time as well (because just setting systemd to quiet mode was a poor solution).

After some research I found a good solution on the Mageia bug tracker that I've been using for a few months..

Just add the following line to the top of the [Service] section in /usr/lib/systemd/system/getty@.service :

ExecStartPre=-/bin/kill -55 1

Source

Note that you'll probably have to re-add this line sometimes when systemd updates; I had to do so after the most recent systemd update.

Hope it helps!

Last edited by gilmoreja (2013-05-09 09:01:31)


Time you enjoy wasting isn't wasted time.

Offline

#14 2013-05-09 09:25:59

Raynman
Member
Registered: 2011-10-22
Posts: 1,094

Re: systemd boot messages in the login prompt

gilmoreja wrote:

Note that you'll probably have to re-add this line sometimes when systemd updates; I had to do so after the most recent systemd update.

That is to be expected if you edit service files under /usr/lib/. Put local configuration in /etc/systemd and use something like https://wiki.archlinux.org/index.php/Ac … 40.service (that example is for all gettys, I think you can limit this to getty@tty1)

Offline

#15 2013-05-13 15:32:06

gilmoreja
Member
From: Florida
Registered: 2012-05-28
Posts: 71

Re: systemd boot messages in the login prompt

Raynman wrote:
gilmoreja wrote:

Note that you'll probably have to re-add this line sometimes when systemd updates; I had to do so after the most recent systemd update.

That is to be expected if you edit service files under /usr/lib/. Put local configuration in /etc/systemd and use something like https://wiki.archlinux.org/index.php/Ac … 40.service (that example is for all gettys, I think you can limit this to getty@tty1)

Thanks for the pointer!

Copying /usr/lib/systemd/system/getty@.service to /etc/systemd/system/getty@tty1.service and then putting the extra line into that file works great.


Time you enjoy wasting isn't wasted time.

Offline

#16 2013-05-13 16:19:28

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: systemd boot messages in the login prompt

Better yet, do this:

% cat /etc/systemd/system/getty@.service
.include /usr/lib/systemd/system/getty@.servce

[Service]
ExecStartPre=-/bin/kill -55 1

That way you get the updates.  I chose to use the .include function rather than the foo.service.d type because I am not sure how well the latter works on "@" services.

Now I am going to be really late for work!

Offline

#17 2013-05-13 19:45:18

gilmoreja
Member
From: Florida
Registered: 2012-05-28
Posts: 71

Re: systemd boot messages in the login prompt

WonderWoofy wrote:

Better yet, do this:

% cat /etc/systemd/system/getty@.service
.include /usr/lib/systemd/system/getty@.servce

[Service]
ExecStartPre=-/bin/kill -55 1

That way you get the updates.  I chose to use the .include function rather than the foo.service.d type because I am not sure how well the latter works on "@" services.

Now I am going to be really late for work!

I'm not sure if I understand the implementation properly.. Do you have all of that in a /etc/systemd/system/getty@.service file?


Time you enjoy wasting isn't wasted time.

Offline

#18 2013-05-13 20:49:02

Raynman
Member
Registered: 2011-10-22
Posts: 1,094

Re: systemd boot messages in the login prompt

gilmoreja wrote:
WonderWoofy wrote:

Better yet, do this:
[snip]
That way you get the updates.  I chose to use the .include function rather than the foo.service.d type because I am not sure how well the latter works on "@" services.

Now I am going to be really late for work!

I'm not sure if I understand the implementation properly.. Do you have all of that in a /etc/systemd/system/getty@.service file?

Yes, you include the original file and add some extra options to it. With recent systemd versions you can add multiple of these 'extensions' in the form of .conf files in a directory named after the service as in the wiki page I linked to (so .include line is no longer needed). Works fine for getty@.service, but I haven't tried it with template instances yet (as in getty@tty1.service).

Last edited by Raynman (2013-05-13 20:50:13)

Offline

#19 2013-05-24 00:30:50

brandon88tube
Member
Registered: 2009-11-06
Posts: 84

Re: systemd boot messages in the login prompt

Hate to be "that" guy, but is this going to get a real fix or will I have to make this change myself?

Offline

#20 2013-05-24 10:22:32

Raynman
Member
Registered: 2011-10-22
Posts: 1,094

Re: systemd boot messages in the login prompt

It doesn't look like the upstream bug report (see above) is getting any developer attention and posting here is not going to change that. I use quiet anyway, so I don't care, but how much trouble is it to drop a 2-line .conf file under /etc if it really bothers you?

Offline

#21 2013-05-25 17:18:16

brandon88tube
Member
Registered: 2009-11-06
Posts: 84

Re: systemd boot messages in the login prompt

Excuse my ignorance, but I thought it was a .service file and that you were only adding "ExecStartPre=-/bin/kill -55 1" under [Service]. I most likely misunderstood something because I still have the issue.

Offline

#22 2013-05-25 21:31:03

Raynman
Member
Registered: 2011-10-22
Posts: 1,094

Re: systemd boot messages in the login prompt

You can also use a 3-line .service file (with .include) or (preferably not) copy the original in its entirety and add that line (this has all been explained in this thread). But if you go with a .service file, you also have to reenable getty@tty1 so the symlink  in multi-user.target.wants points to your new file under /etc instead of the original under /usr.

Offline

#23 2013-05-25 23:47:41

brandon88tube
Member
Registered: 2009-11-06
Posts: 84

Re: systemd boot messages in the login prompt

OK, I just created /etc/systemd/system/getty@.service.d, but what do I call the .conf file or does it not matter?

Offline

#24 2013-05-26 08:30:19

PReP
Member
From: Sweden/Sala
Registered: 2010-06-13
Posts: 347
Website

Re: systemd boot messages in the login prompt

I have this aswell, but i think i remember it happen before systemd at some point aswell.
The thing is also, that since some time ago one could write over/delete the characters of the actual prompt (i think that is still the case)

But yeah, this issue is annoying, it only happens sometimes (due to however fast the "services" start) but it is very confusing.
I am a bit worried that many people expect/use a login to X/graphic manager, thus this bug gets too little attention.

Last edited by PReP (2013-05-26 08:30:29)


#1 Main: Intel Core i5 2500k (Sandy) @ 3.9 Ghz, 8 GB DDR2-XMP RAM @ 1600 Mhz, Geforce GTX 570 (Gainward Phantom) - Arch Linux 64-Bit
#2 Server: Intel C2D E8400 @ 3.6 Ghz, 3 GB DDR2-RAM @ 802mhz, XFX GF GTX260 XT -ArchLinux 64-bit.

<- Server Homepage: http://prep.mine.nu ->

Offline

#25 2013-05-26 14:56:58

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: systemd boot messages in the login prompt

PReP wrote:

I have this aswell, but i think i remember it happen before systemd at some point aswell.
The thing is also, that since some time ago one could write over/delete the characters of the actual prompt (i think that is still the case)

But yeah, this issue is annoying, it only happens sometimes (due to however fast the "services" start) but it is very confusing.
I am a bit worried that many people expect/use a login to X/graphic manager, thus this bug gets too little attention.

I too have a vague recollection of this occuring before systemd as well.  But I am not 100% about that...

Honestly, with your concerns about people's exectations, if a non-*nix user is looking at a Linux machine, I don't think they really know what to expect.  In fact, a text based login prompt is likely just as confusing to them as a login prompt that is polluted with boot messages as well.

These issues went away for me when I started using a SSD, so it is indeed an issue with parallel starting of services.  The thing is, we all enjoy the benefits of systemd's parallel startup, it provides a much faster boot.  So most of us remove the scrolling messages because it is typically scrolling too fast to make sense of anyway.  But for those of you who still want those messages, you can't have the expectation that it is going to tell you about all your messages and not mess up your login prompt, knowing that parallel forces are afoot.  If it were to simply throw out the last boot messages in favor or having a clean login prompt, I think then you would likely have people thinking that some of their services weren't starting or, worse, people who knew what was happening but now complained of inconsistent boot message output.

What I am trying to say is that systemd is actually doing exactly what you are asking of it.  If you don't use the 'quiet' boot parameter, it is going to tell you about the crap that is is doing.  If you don't intentionally use ordering or some other functionality to make sure that getty@tty1 is started after everything else, it is going to do what the system is asking of it.

Offline

Board footer

Powered by FluxBB