You are not logged in.

#1 2013-05-10 09:24:06

ubunchu
Member
Registered: 2012-05-01
Posts: 176

[SOLVED] Pacman, Can't ignore group KDE

Solution, ignoring groups/packages need to be space separated, not by comma.


Hello,
I'm trying to upgrade, skipping some groups (packages), but it doesn't seem to work.
In pacman.conf I have:

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
IgnoreGroup =kde,kdebase,kdeutils,libreoffice,qt,kdeplasma

NoUpgrade   =kde,libreoffice,qt,kdeplasma
#NoExtract   =
[ubunchu@quickie etc]$ sudo pacman -Syyu

Paquetes (168): alsa-lib-1.0.27-2  dirmngr-1.1.1-1  gnome-icon-theme-symbolic-3.8.0.1-2  gpgme-1.4.1-1  iproute2-3.9.0-1  kactivities-4.10.3-1  kde-base-artwork-4.10.3-1
                kde-l10n-es-4.10.3-2  kde-wallpapers-4.10.3-1  kdeaccessibility-kaccessible-4.10.3-1  kdeaccessibility-kmag-4.10.3-1  kdeaccessibility-kmousetool-4.10.3-1
                kdeadmin-kcron-4.10.3-1  kdeadmin-kuser-4.10.3-1  kdeartwork-colorschemes-4.10.3-1  kdeartwork-desktopthemes-4.10.3-1  kdeartwork-emoticons-4.10.3-1
                kdeartwork-iconthemes-4.10.3-1  kdeartwork-kscreensaver-4.10.3-1  kdeartwork-sounds-4.10.3-1  kdeartwork-styles-4.10.3-1  kdeartwork-wallpapers-4.10.3-1
                kdeartwork-weatherwallpapers-4.10.3-1  kdebase-dolphin-4.10.3-1  kdebase-katepart-4.10.3-1  kdebase-kdepasswd-4.10.3-1  kdebase-kdialog-4.10.3-1
                kdebase-keditbookmarks-4.10.3-1  kdebase-kfind-4.10.3-1  kdebase-konqueror-4.10.3-1  kdebase-konsole-4.10.3-1  kdebase-kwrite-4.10.3-1  kdebase-lib-4.10.3-1
                kdebase-plasma-4.10.3-1  kdebase-runtime-4.10.3-1  kdebase-workspace-4.10.3-1  kdegames-kollision-4.10.3-1  kdegraphics-gwenview-4.10.3-1
                kdegraphics-kamera-4.10.3-1  kdegraphics-kcolorchooser-4.10.3-1  kdegraphics-kgamma-4.10.3-1  kdegraphics-kruler-4.10.3-1  kdegraphics-ksnapshot-4.10.3-1
                kdegraphics-mobipocket-4.10.3-1  kdegraphics-okular-4.10.3-1  kdelibs-4.10.3-2  kdemultimedia-audiocd-kio-4.10.3-1  kdemultimedia-ffmpegthumbs-4.10.3-1
                kdemultimedia-juk-4.10.3-1  kdemultimedia-kmix-4.10.3-1  kdenetwork-filesharing-4.10.3-1  kdenetwork-kdnssd-4.10.3-1  kdenetwork-kget-4.10.3-1
                kdepim-console-4.10.3-1  kdepim-kaddressbook-4.10.3-1  kdepim-kalarm-4.10.3-1  kdepim-kontact-4.10.3-1  kdepim-korganizer-4.10.3-1  kdepim-kresources-4.10.3-1
                kdepim-libkdepim-4.10.3-1  kdepim-runtime-4.10.3-1  kdepimlibs-4.10.3-1  kdeplasma-addons-applets-binary-clock-4.10.3-1
                kdeplasma-addons-applets-blackboard-4.10.3-1  kdeplasma-addons-applets-bookmarks-4.10.3-1  kdeplasma-addons-applets-bubblemon-4.10.3-1
                kdeplasma-addons-applets-calculator-4.10.3-1  kdeplasma-addons-applets-charselect-4.10.3-1  kdeplasma-addons-applets-comic-4.10.3-1
                kdeplasma-addons-applets-community-4.10.3-1  kdeplasma-addons-applets-dict-4.10.3-1  kdeplasma-addons-applets-eyes-4.10.3-1
                kdeplasma-addons-applets-fifteenpuzzle-4.10.3-1  kdeplasma-addons-applets-filewatcher-4.10.3-1  kdeplasma-addons-applets-frame-4.10.3-1
                kdeplasma-addons-applets-fuzzy-clock-4.10.3-1  kdeplasma-addons-applets-icontasks-4.10.3-1  kdeplasma-addons-applets-incomingmsg-4.10.3-1
                kdeplasma-addons-applets-kdeobservatory-4.10.3-1  kdeplasma-addons-applets-kimpanel-4.10.3-1  kdeplasma-addons-applets-knowledgebase-4.10.3-1
                kdeplasma-addons-applets-kolourpicker-4.10.3-1  kdeplasma-addons-applets-konqprofiles-4.10.3-1  kdeplasma-addons-applets-konsoleprofiles-4.10.3-1
                kdeplasma-addons-applets-lancelot-4.10.3-1  kdeplasma-addons-applets-leavenote-4.10.3-1  kdeplasma-addons-applets-life-4.10.3-1
                kdeplasma-addons-applets-luna-4.10.3-1  kdeplasma-addons-applets-magnifique-4.10.3-1  kdeplasma-addons-applets-mediaplayer-4.10.3-1
                kdeplasma-addons-applets-microblog-4.10.3-1  kdeplasma-addons-applets-news-4.10.3-1  kdeplasma-addons-applets-notes-4.10.3-1
                kdeplasma-addons-applets-nowplaying-4.10.3-1  kdeplasma-addons-applets-paste-4.10.3-1  kdeplasma-addons-applets-pastebin-4.10.3-1
                kdeplasma-addons-applets-plasmaboard-4.10.3-1  kdeplasma-addons-applets-previewer-4.10.3-1  kdeplasma-addons-applets-qalculate-4.10.3-1
                kdeplasma-addons-applets-rememberthemilk-4.10.3-1  kdeplasma-addons-applets-rssnow-4.10.3-1  kdeplasma-addons-applets-showdashboard-4.10.3-1
                kdeplasma-addons-applets-showdesktop-4.10.3-1  kdeplasma-addons-applets-social-news-4.10.3-1  kdeplasma-addons-applets-spellcheck-4.10.3-1
                kdeplasma-addons-applets-systemloadviewer-4.10.3-1  kdeplasma-addons-applets-timer-4.10.3-1  kdeplasma-addons-applets-unitconverter-4.10.3-1
                kdeplasma-addons-applets-weather-4.10.3-1  kdeplasma-addons-applets-weatherstation-4.10.3-1  kdeplasma-addons-containments-4.10.3-1
                kdeplasma-addons-libs-4.10.3-1  kdeplasma-addons-runners-audioplayercontrol-4.10.3-1  kdeplasma-addons-runners-browserhistory-4.10.3-1
                kdeplasma-addons-runners-characters-4.10.3-1  kdeplasma-addons-runners-contacts-4.10.3-1  kdeplasma-addons-runners-converter-4.10.3-1
                kdeplasma-addons-runners-datetime-4.10.3-1  kdeplasma-addons-runners-dictionary-4.10.3-1  kdeplasma-addons-runners-events-4.10.3-1
                kdeplasma-addons-runners-katesessions-4.10.3-1  kdeplasma-addons-runners-konsolesessions-4.10.3-1  kdeplasma-addons-runners-mediawiki-4.10.3-1
                kdeplasma-addons-runners-spellchecker-4.10.3-1  kdeplasma-addons-runners-youtube-4.10.3-1  kdeplasma-addons-wallpapers-mandelbrot-4.10.3-1
                kdeplasma-addons-wallpapers-pattern-4.10.3-1  kdeplasma-addons-wallpapers-potd-4.10.3-1  kdeplasma-addons-wallpapers-virus-4.10.3-1
                kdeplasma-addons-wallpapers-weather-4.10.3-1  kdesdk-dolphin-plugins-4.10.3-1  kdesdk-kate-4.10.3-1  kdesdk-kompare-4.10.3-1  kdeutils-filelight-4.10.3-1
                kdeutils-kcalc-4.10.3-1  kdeutils-kcharselect-4.10.3-1  kdeutils-ktimer-4.10.3-1  kdeutils-kwallet-4.10.3-1  kdeutils-print-manager-4.10.3-1
                kdeutils-superkaramba-4.10.3-1  kdewebdev-kfilereplace-4.10.3-1  kdewebdev-kimagemapeditor-4.10.3-1  kdewebdev-kommander-4.10.3-1  libkcddb-4.10.3-1
                libkcompactdisc-4.10.3-1  libkdegames-4.10.3-1  libkexiv2-4.10.3-1  libkipi-4.10.3-1  libpipeline-1.2.3-1  libreoffice-calc-4.0.3-1
                libreoffice-common-4.0.3-1  libreoffice-es-4.0.3-1  libreoffice-extension-presentation-minimizer-4.0.3-1  libreoffice-impress-4.0.3-1
                libreoffice-writer-4.0.3-1  libxslt-1.1.28-1  mkinitcpio-0.14.0-1  mono-2.10.9-1  nepomuk-core-4.10.3-1  nepomuk-widgets-4.10.3-1  openjpeg-1.5.1-1
                oxygen-icons-4.10.3-1  pacman-4.1.1-1  pinentry-0.8.3-1  systemd-203-2  systemd-sysvcompat-203-2  xerces-c-3.1.1-4  xfce4-notifyd-0.2.4-1

What am I doing wrong? (i'm not using metapackages)
Thanks in advance.
Cheers!

Note: I know that not upgrading these might cause problems, but since I don't use them that much atm, it does not matter.

Last edited by ubunchu (2013-05-10 10:25:58)


Don't forget to mark as [SOLVED].

Offline

#2 2013-05-10 09:48:37

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [SOLVED] Pacman, Can't ignore group KDE

See the example section of man pacman.conf for how it should be formatted. Or look at HoldPkg in pacman.conf.

Last edited by lucke (2013-05-10 09:52:07)

Offline

#3 2013-05-10 10:01:40

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,107
Website

Re: [SOLVED] Pacman, Can't ignore group KDE

ubunchu wrote:

What am I doing wrong?

https://wiki.archlinux.org/index.php/Pa … nsupported


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#4 2013-05-10 10:16:57

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,541
Website

Re: [SOLVED] Pacman, Can't ignore group KDE

ubunchu wrote:

Hello,
I'm trying to upgrade, skipping some groups (packages), but it doesn't seem to work.
In pacman.conf I have:

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
IgnoreGroup =kde,kdebase,kdeutils,libreoffice,qt,kdeplasma

NoUpgrade   =kde,libreoffice,qt,kdeplasma
#NoExtract   =

The packages need to be space separated, not comma separated. Also, I think there should be a space next to the "=" too.

And, NoUpgrade is used to prevent files from being overwritten, not preventing package upgrades.

Offline

#5 2013-05-10 10:25:23

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: [SOLVED] Pacman, Can't ignore group KDE

x33a wrote:

The packages need to be space separated, not comma separated. Also, I think there should be a space next to the "=" too.

And, NoUpgrade is used to prevent files from being overwritten, not preventing package upgrades.

Thanks! That did the trick.
Solved.


Don't forget to mark as [SOLVED].

Offline

Board footer

Powered by FluxBB