You are not logged in.

#5251 2013-05-02 12:22:39

abbradar
Member
Registered: 2010-06-10
Posts: 34

Re: The AMD/ATI Bar & Grill

Catalyst 13.4 crashes for me (segfault, xorg 1.13.4) with this log:
http://codepad.org/oxKCUdyA
Trying catalyst 13.3 now, will also check with xorg 1.13.3.

Update: xorg 1.13.3 does not fix this, but catalyst 13.3 does. *sigh* I love ATI. Try 13.3 if this problem affects you.

Last edited by abbradar (2013-05-02 13:35:52)


Sorry for my poor English.

Offline

#5252 2013-05-02 14:20:15

ccpaging
Member
Registered: 2012-01-24
Posts: 16

Re: The AMD/ATI Bar & Grill

Anon11 wrote:
MadNoob wrote:
Anon11 wrote:

I disabled varibright. The problem is that brightness changes that i do manually don't take effect and it is always quite bright when i start.



On my laptop (HP dv6z) , i can sort of use function keys that change brightness.
At first they do nothing but if i keep doing increase/decrease randomly i eventually get to a lower brightness ( after abt 5-10 seconds of continuous inc/dec )

Weirdly, this does not seem to work if i use kde brightness widget.

tray with acpi_backlight=vendor in grub... it should work "randomly" with fn keys

Does not work on my laptop. Function keys for brightness stops working.
The backlight issue should be a catalyst bug as it was working in 12.8

Me too. catalyst-stable-13.1 is OK.

Offline

#5253 2013-05-03 09:10:01

mityukov
Member
Registered: 2010-10-10
Posts: 66

Re: The AMD/ATI Bar & Grill

The only discrete card actually works. If I switch to the Integral one (aticonfig --px-igpu), the X windows would not start at all on the next book. Here's the log:
https://gist.github.com/5508034

Discrete GPU works Ok.

SOLVED by re-installing catalyst-* packages and by running `# aticonfig --adapter=all --initial`

Last edited by mityukov (2013-05-03 09:25:53)

Offline

#5254 2013-05-04 01:09:12

NiteiaTt
Member
Registered: 2012-04-15
Posts: 29

Re: The AMD/ATI Bar & Grill

I could use some help here, if anyone was so kind
A problem has been bugging me and it's been keeping me from upgrading from 13.1
When I install any version greater than 13.1-1, and run catalyst_build_module
there's a warning when compiling
it kind of says:
"in KCL_EFI_IS_ENABLED
warning: return makes integer from pointer without a cast
return efi_enabled"
but it proceeds "successfully"
when I reboot, X won't start

# cat /var/log/Xorg.0.log | grep -E "WW|EE"
[    21.516] (WW) Falling back to old probe method for fglrx
[    22.315] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:1) found
[    24.534] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[    24.822] (EE) fglrx(0): DAL initialization failed!
[    24.822] (EE) fglrx(0): Display Infrastructure Failed
[    24.822] (EE) fglrx(0): PreInit failed
[    25.549] (EE) Screen(s) found, but none have a usable configuration.

This happens whenever the "return makes integer from pointer without a cast" warning showed at compilation
I've been downgrading many times, hoping it will fix with new releases, but it's been since 13.2 that I've been holding back, and I'm sick of it
Can anybody help me?

You can access my atisysteminfo-report.txt here: http://pastebin.com/cnuLckXV

btw:
I've tried with catalyst-total
and with the [catalyst] repo
can't start X, same errors

EDIT: fixed the compilation warning, but the Xorg errors still appear

Last edited by NiteiaTt (2013-05-05 14:53:53)

Offline

#5255 2013-05-05 10:14:35

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Can you paste atigetsysteminfo.sh output somewhere?

Offline

#5256 2013-05-05 13:48:55

episyron
Member
Registered: 2010-07-21
Posts: 15

Re: The AMD/ATI Bar & Grill

acgtyrant wrote:

I'm tired, I give up. I will try open sourece driver. Thank you.

I did this now too, and what a breath of fresh air. I have HD 5770 and tried open source drivers some time ago, but back then power management wasn't good enough. Now dynpm is working quite well, and as opposed to catalyst driver, virtual terminals and user switching is working so well. And no more holding back X server and kernel versions. It is not possible to play Team Fortress 2 or use OpenCL yet, so your mileage may vary, but I have been happy with the open source driver.

Offline

#5257 2013-05-05 14:52:04

NiteiaTt
Member
Registered: 2012-04-15
Posts: 29

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Can you paste atigetsysteminfo.sh output somewhere?

Sure thing, sir, thank you for replying

atisysteminfo-report.txt -> http://pastebin.com/cnuLckXV

Offline

#5258 2013-05-07 07:11:06

Janarto
Member
From: Paris
Registered: 2008-09-23
Posts: 80

Re: The AMD/ATI Bar & Grill

I'm using a dell M4700 mobile workstation, and the ati card in it is a firepro M4000.

For the moment I'm running archlinux within virtualbox on top of windows 8, but frankly, I do not like w8 (no offence here, I hope I would have loved it).

I'm planning to reverse the pattern, by getting archlinux natively and windows 8 on top. Then my main concern is the M4000 : would you pick the free driver or the catalyst ?

Offline

#5259 2013-05-08 13:11:59

andy123
Member
Registered: 2011-11-04
Posts: 169
Website

Re: The AMD/ATI Bar & Grill

ccpaging wrote:
Anon11 wrote:
MadNoob wrote:

tray with acpi_backlight=vendor in grub... it should work "randomly" with fn keys

Does not work on my laptop. Function keys for brightness stops working.
The backlight issue should be a catalyst bug as it was working in 12.8

Me too. catalyst-stable-13.1 is OK.

My thinkpad edge e325 is also affected by this problem, but I found a "solution".

I tested manually changing the brightness by writing to "/sys/class/backlight/acpi_video0/brightness", but that didn't work. What does work is writing to it very often for a short time as in

 while :; do echo 10 > /sys/class/backlight/acpi_video0/brightness ; done 

in a root shell and canceling it after a short time.

It would be nice if some notebook users, that can't change their backlight brightness with 13.4 could try to reproduce this.


i'm sorry for my poor english wirting skills…

Offline

#5260 2013-05-09 04:15:58

Anon11
Member
Registered: 2012-05-20
Posts: 33

Re: The AMD/ATI Bar & Grill

andy123 wrote:
ccpaging wrote:
Anon11 wrote:

Does not work on my laptop. Function keys for brightness stops working.
The backlight issue should be a catalyst bug as it was working in 12.8

Me too. catalyst-stable-13.1 is OK.

My thinkpad edge e325 is also affected by this problem, but I found a "solution".

I tested manually changing the brightness by writing to "/sys/class/backlight/acpi_video0/brightness", but that didn't work. What does work is writing to it very often for a short time as in

 while :; do echo 10 > /sys/class/backlight/acpi_video0/brightness ; done 

in a root shell and canceling it after a short time.

It would be nice if some notebook users, that can't change their backlight brightness with 13.4 could try to reproduce this.

yes it works. thanks

Offline

#5261 2013-05-10 08:59:48

mityukov
Member
Registered: 2010-10-10
Posts: 66

Re: The AMD/ATI Bar & Grill

It would be nice if some notebook users, that can't change their backlight brightness with 13.4 could try to reproduce this.

Works this way. Btw, if you get "bash: echo: writing error: Invalid argument" errors, please try smaller values (I have '7' as maximum allowed number for the brightness, for instance).

Offline

#5262 2013-05-10 15:07:18

lano1106
Member
From: Canada, Montreal
Registered: 2012-11-22
Posts: 80
Website

Re: The AMD/ATI Bar & Grill

I have a Sapphire 7970. I have tried to modify GPU voltage with the ADL API and it didn't work.

Would I have more luck tweaking voltage with AMDOverdriveCtrl?

I have catalyst 13.4 from Vi0l0 repository, if this info may influence possible answers.

Offline

#5263 2013-05-11 00:42:33

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

Hello everyone.
I have tried to install using Violos stable unofficial repo, but I have some errors:

# pacman -S catalyst catalyst-utils
resolving dependencies...
warning: cannot resolve "xorg-server<1.14.0", a dependency of "catalyst-utils"
warning: cannot resolve "catalyst-utils", a dependency of "catalyst"
warning: cannot resolve "xorg-server<1.14.0", a dependency of "catalyst-utils"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      catalyst  catalyst-utils

:: Do you want to skip the above packages for this upgrade? [y/N]

Offline

#5264 2013-05-11 01:13:59

jgott
Member
Registered: 2011-04-10
Posts: 21

Re: The AMD/ATI Bar & Grill

Where can I find the PKGBUILD/source tarball for the xorg-server package from the xorg113 repo? I need to build it with a custom patch to the xorg source.

I did find this, but it's not the latest version:
http://catalyst.wirephire.com/tarball/x … ver.tar.gz

Offline

#5265 2013-05-11 02:34:44

tehgeek
Member
Registered: 2013-02-24
Posts: 11

Re: The AMD/ATI Bar & Grill

webmasteryoda wrote:

Hello everyone.
I have tried to install using Violos stable unofficial repo, but I have some errors:

# pacman -S catalyst catalyst-utils
resolving dependencies...
warning: cannot resolve "xorg-server<1.14.0", a dependency of "catalyst-utils"
warning: cannot resolve "catalyst-utils", a dependency of "catalyst"
warning: cannot resolve "xorg-server<1.14.0", a dependency of "catalyst-utils"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      catalyst  catalyst-utils

:: Do you want to skip the above packages for this upgrade? [y/N]

Re-read the part  just above the repo lines in the wiki. smile *hint* - https://wiki.archlinux.org/index.php/AM … positories *hint*

Offline

#5266 2013-05-11 02:57:15

maroid
Member
Registered: 2013-05-11
Posts: 14

Re: The AMD/ATI Bar & Grill

Hello!

On my AMD A10-5800K i get terrible performance with catalyst 13.4 and xorg113.
All games seam to lag periodically all 3-4 seconds. I am the only one with this issue?

//Edit: This seams to be an awesome wm issue using a very complex lua configuration... Nobody? sad

Last edited by maroid (2013-05-11 07:41:38)

Offline

#5267 2013-05-11 10:43:57

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

lano1106 wrote:

Would I have more luck tweaking voltage with AMDOverdriveCtrl?

It works fine on 7850

jgott wrote:

Where can I find the PKGBUILD/source tarball for the xorg-server package from the xorg113 repo? I need to build it with a custom patch to the xorg source.

Here you go: http://catalyst.wirephire.com/tarball/x … src.tar.gz

maroid wrote:

On my AMD A10-5800K i get terrible performance with catalyst 13.4 and xorg113.
All games seam to lag periodically all 3-4 seconds. I am the only one with this issue?

No, it's a known problem of 13.4's broken APU support. Maybe 13.3 beta 3 will work better for you?:
[catalyst-13.3-beta3]
Server = http://catalyst.wirephire.com/repo/catalyst/$arch

Offline

#5268 2013-05-12 19:57:34

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: The AMD/ATI Bar & Grill

Hi,
I am using catalyst-legacy repo. AFAIK legacy drivers requires 3.0 =< linux < 3.9
But it successfully build fglrx module for 3.9.2-1-ARCH kernel on today's update(linux 3.8.11-1 to 3.9.2-1). I haven't restarted my machine yet.

(1/1) reinstalling linux                                        [----------------------------------] 100%
>>> Updating module dependencies. Please wait ...
>>> Generating initial ramdisk, using mkinitcpio.  Please wait...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.9.2-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
  -> Running build hook: [fglrx]
Building fglrx module for 3.9.2-1-ARCH kernel ...
Ok.
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 3.9.2-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: aic94xx
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
  -> Running build hook: [fglrx]
Building fglrx module for 3.9.2-1-ARCH kernel ...
Ok.
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful

Last edited by omeringen (2013-05-12 19:58:40)

Offline

#5269 2013-05-12 20:45:25

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

catalyst doesn't need extra patching to work with 3.9 kernel (if only it was patched for 3.8), it was just my little fault that i didn't update catalyst-total-hd234k dependencies on time. Now it's fixed.
I've also updated catalyst package on main repos.

Offline

#5270 2013-05-13 18:46:33

Anders H
Member
From: Reno, NV
Registered: 2011-07-31
Posts: 43
Website

Re: The AMD/ATI Bar & Grill

Hello all,

I am currently using Catalyst-hook 13.4-2 and last night I upgraded to Linux 3.9.2-1 and Linux-headers 3.9.2-1 after rebooting I was met with a black screen. After going into single user mode I was able to learn that the Xserver was timing out. I have downgraded to Linux 3.8.8-2 and the respective headers, this allowed me to restore full function. So is 13.4-2 not compatible with Linux 3.9.2-1? Or might it be something else?

I've been trolling my log files to see if I can find anything helpful but the only thing I can find is the Xserver time out in the errors.log

May 12 16:54:49 localhost kdm[517]: X server startup timeout, terminating

Any help would be appreciated.

Thank you.

Offline

#5271 2013-05-13 19:32:13

draci2342
Member
Registered: 2013-05-13
Posts: 4

Re: The AMD/ATI Bar & Grill

Anders H wrote:

I am currently using Catalyst-hook 13.4-2 and last night I upgraded to Linux 3.9.2-1 and Linux-headers 3.9.2-1 after rebooting I was met with a black screen.

I ran into the same problem today. It seems that for some reason the nomodeset kernel parameter does not disable KMS in Linux 3.9

I found a really ugly workaround though. If you pass radeon.modeset=0 as kernel parameter, KMS will be disabled and you get to see your desktop environment.
(I know that we are not using the radeon driver here. It throws some ugly warnings, too.)

Does any one know a proper fix for this?

Offline

#5272 2013-05-14 19:21:15

MadNoob
Member
Registered: 2013-03-10
Posts: 18

Re: The AMD/ATI Bar & Grill

draci2342 wrote:
Anders H wrote:

I am currently using Catalyst-hook 13.4-2 and last night I upgraded to Linux 3.9.2-1 and Linux-headers 3.9.2-1 after rebooting I was met with a black screen.

I ran into the same problem today. It seems that for some reason the nomodeset kernel parameter does not disable KMS in Linux 3.9

I found a really ugly workaround though. If you pass radeon.modeset=0 as kernel parameter, KMS will be disabled and you get to see your desktop environment.
(I know that we are not using the radeon driver here. It throws some ugly warnings, too.)

Does any one know a proper fix for this?

Try acpi_backlight=vendor in grub

Offline

#5273 2013-05-14 19:43:59

MadNoob
Member
Registered: 2013-03-10
Posts: 18

Re: The AMD/ATI Bar & Grill

Guys i wrote a script to bypass brightness bug  with 13.4 drivers. Some levels still can't be set on my notebook, but it works for the most.

Newbies guide:

1] Create a file
2] Paste the code at bottom and save it as modify-brightness
3] Go super user
4] Write one of the following commands

Commands:

sh modify-brightness + | Increase brightness level
sh modify-brightness - | Decrease brighness level
sh modify-brightness set 3 | set level (any integer level value supported by your monitor)
sh modify-brightness show | show actual level

Code:

#!/bin/bash
screen="acpi_video0"
tries=20
brightnessMaxLevel=$(cat /sys/class/backlight/$screen/max_brightness);
brightnessActualLevel=$(cat /sys/class/backlight/$screen/actual_brightness);
brightnessFile="/sys/class/backlight/$screen/brightness"
i=0
case "$1" in
	"+")
		if [ "$brightnessActualLevel" -lt "$brightnessMaxLevel" ]; then
			brightnessNewLevel=$(($brightnessActualLevel+1));
			while [ "$i" -ne "$tries" ]; do
				echo $brightnessNewLevel > $brightnessFile;
				i=$(($i+1));
			done
		fi
	;;
	"-")
		if [ "$brightnessActualLevel" -gt "1" ]; then
			brightnessNewLevel=$(($brightnessActualLevel-1));
			while [ "$i" -ne "$tries" ]; do
				echo $brightnessNewLevel > $brightnessFile;
				i=$(($i+1));
			done
		fi
	;;
	"set")
			while [ "$i" -ne "$tries" ]; do
				echo $2 > $brightnessFile;
				i=$(($i+1));
			done
	;;
	"show")
			echo $brightnessActualLevel
	;;
esac

Hope it helps, sorry for my bad english! smile

Last edited by MadNoob (2013-05-14 19:55:04)

Offline

#5274 2013-05-14 20:33:34

draci2342
Member
Registered: 2013-05-13
Posts: 4

Re: The AMD/ATI Bar & Grill

MadNoob wrote:

Try acpi_backlight=vendor in grub

This does not fix the problem. I still get a black screen with a white unblinking cursor and total system freeze (Can't change tty etc.) with this boot option.
Other ideas? It seems to be realated to KMS somehow.

Last edited by draci2342 (2013-05-14 20:34:24)

Offline

#5275 2013-05-15 04:52:45

Anon11
Member
Registered: 2012-05-20
Posts: 33

Re: The AMD/ATI Bar & Grill

Just fyi , i dont have any problem with 3.9.2.1 kernel + catalyst latest + xorg 1.13 from repo
I have nomodeset set.

KDE works fine.

Have 6755g2 (mobile)

Last edited by Anon11 (2013-05-15 04:53:11)

Offline

Board footer

Powered by FluxBB