You are not logged in.

#1 2013-02-20 22:54:09

Registered: 2011-09-29
Posts: 184

Mumble text-to-speech not working

I installed Mumble for voice chat and speech-dispatcher, festival and espeak, but I won't hear any TTS in Mumble.
I tested espeak and it works if I run it in terminal.
I tried setting "DefaultModule espeak" and "DefaultModule festival" in /etc/speech-dispatcher/speechd.conf, but to no avail.


#2 2013-02-25 13:38:23

Registered: 2011-09-29
Posts: 184

Re: Mumble text-to-speech not working

and what's pretty confusing is that there are two config files in different folders, for speech-dispatcher and for espeak too.
One set is in /etc and another one in /usr/share..
I just edited all to the same values, ie

LogLevel  3
LogDir  "default"

DefaultVolume 100
DefaultVoiceType  "MALE1"
DefaultLanguage "en"

AudioOutputMethod "alsa"
AudioALSADevice "default"

AddModule "espeak"       "sd_espeak"   "espeak.conf"
#AddModule "festival"     "sd_festival"  "festival.conf"
#AddModule "flite"        "sd_flite"     "flite.conf"
#AddModule "ivona"<----> "sd_ivona"    "ivona.conf"
#AddModule "espeak-generic" "sd_generic" "espeak-generic.conf"
#AddModule "espeak-mbrola-generic" "sd_generic" "espeak-mbrola-generic.conf"
#AddModule "swift-generic" "sd_generic" "swift-generic.conf"
#AddModule "epos-generic" "sd_generic"   "epos-generic.conf"
#AddModule "dtk-generic"  "sd_generic"   "dtk-generic.conf"
#AddModule "ibmtts"       "sd_ibmtts"    "ibmtts.conf"
#AddModule "cicero"        "sd_cicero"     "cicero.conf"
AddModule "dummy"         "sd_dummy"      ""

DefaultModule espeak
LanguageDefaultModule "en"  "espeak"

Include "clients/*.conf"

and speech-dispatcher/conf/modules/espeak.conf:

 # -- SOUND ICONS --

# Espeak  does not currently support playing sound icons
# (audio files that are played by name when an application requests
# a sound icon).  If you have installed the free(b)soft sound-icons
# package, this is the directory where will they be found.  If not
# blank, the espeak Output Module will play them if it finds a
# file whose name matches the sound icon name.  If blank, or no
# matching file is found, the name of the sound icon will be spoken.

EspeakSoundIconFolder "/usr/share/sounds/sound-icons/"

# Volume at which sound icons are played.

EspeakSoundIconVolume 0

# -- Punctuation --

# Characters to be spoken when punctuation setting is "some"
# Encoding is UTF-8.
EspeakPunctuationList "@+_"
EspeakCapitalPitchRise 0

# -- Internal parameters --

# Number of ms of audio returned by the espeak callback function.
EspeakAudioChunkSize 3000

# Maximum number of samples to buffer in playback queue.
EspeakAudioQueueMaxSize 441000

# Debugging
Debug 0


#3 2013-03-24 01:27:27

Registered: 2013-03-24
Posts: 1

Re: Mumble text-to-speech not working

Month old response, But just adding this for anyone that comes across this through google.

The mumble package in community does not come with support for speech-dispatcher. There is a mumble-speechd package in AUR, but i haven't given it a try.

Using the mumble package in community and starting mumble from the terminal will output:

TextToSpeech: Compiled without support for speech-dispatcher


#4 2013-05-14 13:47:12

Registered: 2011-09-29
Posts: 184

Re: Mumble text-to-speech not working

So that's the reason, I wonder why they did that.

Unfortunately the AUR package is flagged as outdated and also doesn't build for me (errors).


#5 2013-05-14 16:33:54

Registered: 2012-04-05
Posts: 177

Re: Mumble text-to-speech not working

You can compile it from ABS — just removing the `no-speechd` option should do it.


Board footer

Powered by FluxBB