You are not logged in.

#1 2005-11-04 18:01:52

Dieter
Member
From: Germany
Registered: 2005-10-13
Posts: 121

Arch64: Problems with hardware clock, nvidia driver and KDE

Hello,

I tried to install arch64 on my PC here - and encountered the following problems:

1. console boot is ok, except the message "cannot access the hardware clock by any known method". Which package is missing?

2. Installation of the nvidia driver is showing error messages in the the logfile, this is the end of the installer log:

-> The installer has encountered the following error during installation: 'Cann
   ot create symlink /usr/lib/libnvidia-tls.so.1 (File exists)'.  Continue anyw
   ay? ("no" will abort)? (Answer: Yes)
   executing: '/sbin/ldconfig'...
   executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Shared memory test passed.
-> Running runtime sanity check:
ERROR: The runtime configuration check failed for library 'libGL.so.1.0.7676'
       (expected: '/usr/lib/libGL.so.1', found: '(not found)').  The most
       likely reason for this is that conflicting OpenGL libraries are
       installed in a location not inspected by `nvidia-installer`.  Please be
       sure you have uninstalled any third-party OpenGL and third-party
       graphics driver packages.
-> done.
-> Runtime sanity check failed.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

3. When I enter "startx" for loading KDE, the nvidia driver starts with errors. But I get no logon window. From the Xorg.0.log:

(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
dlopen: libGLcore.so.1: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/X11R6/lib/modules/extensions/libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)
...
(II) NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms" "true"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX
(==) RandR enabled
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(II) Initializing built-in extension MIT-SHM

The errors during kde start seem to be related to libglx / libGL.so.x stuff, KDE aborts in kde-init, readconfig etc.

Can you tell me how can get that fixed? Removing and re-installing the nvidia driver does not help.

Regards,
Dieter

Offline

#2 2005-11-05 00:25:53

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

use the installer from nvidia.com for now. I'll fix it soon. I'm  just in one of those slumps where i don't do anything for a week or 2. Pretty soon i'll feel like doing stuff and then i'll make a hundred packages/updates (like i did with gnome 2.12) and then wait another week or 2 before i do stuff again ;-p

Offline

#3 2005-11-06 06:54:55

Dieter
Member
From: Germany
Registered: 2005-10-13
Posts: 121

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

First, using the nvidia installer shows the same error messages.

But installation works if the 32-bit compatibility is switched off in the installer menu.

Dieter

Offline

#4 2005-11-08 22:47:50

Dieter
Member
From: Germany
Registered: 2005-10-13
Posts: 121

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

Item "system clock" (hwclock):

/sbin/hwclock seems to cause problems on 64-bit systems, I found similar posts to forums of Debian and Mandriva.

The following workaround helps:
Load the module "rtc" before you use /sbin/hwclock. Then /dev/rtc is created and /sbin/hwclock works.

As modules from /etc/rc.conf are loaded after the /sbin/hwclock statements in /etc/rc.sysinit, there is a change necessary:
- Either load the modules from /etc/rc.conf before /sbin/hwclock is executed and add "rtc" to the modules list
- or add "/sbin/modprobe rtc" in a new line before the hwclock lines in /etc/rc.sysinit.

I would suggest an update of /etc/rc.sysinit for Arch64 to reflect necessary loading of the rtc module before the hwclock is set.

Dieter

Offline

#5 2005-11-11 16:21:20

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

Just checked 2.6.14 in i686 & rtc is still loaded as module

Could it be loaded via initrd ?

Or will Stock Arch64 Kernel have rtc built in ?

I wanna get me clock working  tongue


Mr Green

Offline

#6 2005-12-07 06:00:52

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,640

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

With my kernel 2.6.14.3 the clock is working fine now.

A new NVidia driver is out. Let´s see if we can use it now straight from a package.

Offline

#7 2006-02-06 21:19:59

Moritz
Member
From: Cologne, NRW, Germany
Registered: 2002-10-12
Posts: 166

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

I still got problem 2 and 3. Should this already be fixed?

Regards,
Moritz

Offline

#8 2006-02-27 19:48:04

skruw
Member
Registered: 2003-12-06
Posts: 23

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

i have the same problem.

the nvidia one..
its annoying

Offline

#9 2006-02-28 16:21:07

Moritz
Member
From: Cologne, NRW, Germany
Registered: 2002-10-12
Posts: 166

Re: Arch64: Problems with hardware clock, nvidia driver and KDE

Don't use the package, use the normal installer and chose "no" on 32bit compatibility...

Offline

Board footer

Powered by FluxBB