You are not logged in.

#1 2013-05-13 10:00:25

AlexC_
Member
Registered: 2008-07-14
Posts: 14
Website

Linux 3.9.2-1 lockups (nVidia + nouveau)

With the recent update from Linux 3.8.11-1 to Linux 3.9.2-1, upon restart my computer would lock up after roughly 5 minutes and the CPU and/or GPU fan (couldn't tell which) started to spin up very fast a few seconds before hand. As soon as I downgraded to Linux 3.8.11-1, everything started to work again.

I am running an nVidia card (7950 I believe) and the nouveau drivers.

Has anyone experience a similar situation, and how can I get some more debug info to help resolve this?

Last edited by AlexC_ (2013-05-13 10:01:41)

Offline

#2 2013-05-14 16:04:19

alexzose
Member
Registered: 2012-05-17
Posts: 10

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

I experience same problems. Sometimes the system crashes, sometimes the temperatures go crazy, an I get a bunch of various errors about nouveau.

Offline

#3 2013-05-15 08:17:36

boomshalek
Member
Registered: 2007-10-12
Posts: 96

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

I had similar behaviour already before upgrading to Linux 3.9.2 (Linux 3.8.11-1 and 3.8.10, maybe 3.8.9 too).
But the system hang was always only around 10-15 seconds. Afterwards it was OK again for one or two hours before hanging again for such a period.

Offline

#4 2013-05-15 09:51:32

z1lt0id
Member
Registered: 2012-09-20
Posts: 167

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

Had this issue as well, downgrading to Linux 3.8 resolved the problem.

Offline

#5 2013-05-15 17:21:32

CyberNhull
Member
Registered: 2013-01-27
Posts: 68

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

Same, altho im using a ati card and my "lockups" are kernel panics (caps lock led blinking). Downgrade to 3.8.something seems to fix the issue...at least for now


If it does not kill you....It will make you smarter

Offline

#6 2013-05-16 11:41:13

AlexC_
Member
Registered: 2008-07-14
Posts: 14
Website

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

Any idea what could be causing this? I couldn't find anything juicy in the logs to help debug. Right now I'm ignoring any package updates for "linux" and "linux-headers".

Offline

#7 2013-05-19 12:23:52

CyberNhull
Member
Registered: 2013-01-27
Posts: 68

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

AlexC_ wrote:

Any idea what could be causing this? I couldn't find anything juicy in the logs to help debug. Right now I'm ignoring any package updates for "linux" and "linux-headers".

Doing the same thing that you are doing buddy..no idea to. Just hoping a new kernel update fix this


If it does not kill you....It will make you smarter

Offline

#8 2013-05-20 17:52:22

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,584

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

I have issues with novueau and 3.9.2 as well. I have two monitors and the VGA attached one does not display anything in console. Starting X effectively locks up the system: it's briefly unresponsive, followed by blacking and heavy HDD access, then drops back to console. Afterwards, keyboard lock-indicators respond, but there is no response to commands (C-A-Bksp, C-A-Del, REISUB).

Starting X with a new user works, presumably due to lacking setup to span across multiple monitors. Though honestly I'm not sure where that setting is. It takes longer than normal (just a few seconds) and I have no mouse pointer despite the mouse being functional. The VGA monitor is seen ([XFCE] Settings -> Display etc.) though it's still black.

The VGA monitor is connected to a KVM while the other (DVI) is not. I haven't gotten around to connecting it directly. And nothing jumps out when comparing kernel log, journal, and Xorg.log from 3.9.2 to the same from 3.8.11.

Card is "NVIDIA Corporation G86 [GeForce 8400 GS] (rev a1)".

Edit: VGA is still blank with 3.9.3, didn't take it any further. And no diff without the KVM.

Last edited by alphaniner (2013-05-20 22:01:00)


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Online

#9 2013-06-03 16:18:10

AlexC_
Member
Registered: 2008-07-14
Posts: 14
Website

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

This is still an issue (for me) with 3.9.4, with zero info in the logs (that I can find) to debug this. Does anyone know where I can look to get some information so that I can start creating a bug report?

Offline

#10 2013-06-04 09:53:22

CyberNhull
Member
Registered: 2013-01-27
Posts: 68

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

The lockups are fix for me above 3.9.2 but my laptop overheats with those kernels -.-" so im still using 3.8.11

Last edited by CyberNhull (2013-06-04 09:53:42)


If it does not kill you....It will make you smarter

Offline

#11 2013-06-04 10:05:34

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

So there is nothing in journalctl when this happens? What about dmesg?


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#12 2013-06-04 10:23:43

AlexC_
Member
Registered: 2008-07-14
Posts: 14
Website

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

I've just tried again with 3.9.4-1, and so far I've been using KDE for ~10 minutes and it has yet to lock up. However, my GPU fan is still running like crazy at times, which could be related to the following messages from "journalctl -b":

nouveau  [  PTHERM][0000:01:00.0] temperature (92 C) went below the 'downclock' threshold
nouveau  [  PTHERM][0000:01:00.0] temperature (87 C) went below the 'fanboost' threshold

Edit: and just as I posted this I got the following (still no lock up though).

nouveau  [  PTHERM][0000:01:00.0] temperature (90 C) hit the 'fanboost' threshold
nouveau  [  PTHERM][0000:01:00.0] temperature (87 C) went below the 'fanboost' threshold

Last edited by AlexC_ (2013-06-04 10:24:57)

Offline

#13 2013-06-04 10:35:18

AlexC_
Member
Registered: 2008-07-14
Posts: 14
Website

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

And there we go, it locked up again with zero information from "journalctl" or "dmesg" =\

Offline

#14 2013-06-04 11:04:10

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

AlexC_ wrote:

I've just tried again with 3.9.4-1, and so far I've been using KDE for ~10 minutes and it has yet to lock up. However, my GPU fan is still running like crazy at times, which could be related to the following messages from "journalctl -b":

nouveau  [  PTHERM][0000:01:00.0] temperature (92 C) went below the 'downclock' threshold
nouveau  [  PTHERM][0000:01:00.0] temperature (87 C) went below the 'fanboost' threshold

Edit: and just as I posted this I got the following (still no lock up though).

nouveau  [  PTHERM][0000:01:00.0] temperature (90 C) hit the 'fanboost' threshold
nouveau  [  PTHERM][0000:01:00.0] temperature (87 C) went below the 'fanboost' threshold

I think it might be your bios locking you up, because of a problem with driver/kernel making your specific card run too hot.

Check your bios for some sort of temperature safety threshold and see what its at.

It could possibly be a hardware problem, maybe your card is damaged, I read somewhere though that newer cards dont have as good support in the open drivers, but it seems wierd that you have this problem with both open and propriety drivers


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#15 2013-06-13 13:40:15

CyberNhull
Member
Registered: 2013-01-27
Posts: 68

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

Anyone had problems with 3.9.5? Like lockups or overheating?


If it does not kill you....It will make you smarter

Offline

#16 2013-06-15 08:55:05

RazZziel
Member
From: Spain
Registered: 2007-07-13
Posts: 35

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

I do, with the official nVidia driver, however it seems to be fixed disabling the nVidia card with bbswitch (I'm on an Optimus Laptop, Dell L502X)

However, for some reason mplayer won't work. When I try to play a video, it crashes right away, and I see a kernel error in dmesg

MPlayer SVN-r36285-4.8.0 (C) 2000-2013 MPlayer Team
Cannot test OS support for SSE, disabling to be safe.
205 audio & 424 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing pajama jam.flv.
libavformat version 55.7.100 (internal)
libavformat file format detected.
[lavf] stream 0: video (vp6f), -vid 0
[lavf] stream 1: audio (mp3), -aid 0
VIDEO:  [VP6F]  504x380  0bpp  30.000 fps  475.9 kbps (58.1 kbyte/s)
Clip info:
 lasttimestamp: 1001
 datasize: 73537080
 metadatacreator: FlixEngineLinux_8.0.12.0 (www.on2.com)
 canSeekToEnd: 1
 videosize: 59526566
 audiosize: 14010514
Load subtitles in ./
Killed
[  311.687485] BUG: unable to handle kernel paging request at f80ed9ac
[  311.687562] IP: [<c1196b07>] proc_reg_open+0x57/0x120
[  311.687621] *pdpt = 000000000164c001 *pde = 000000002dd02067 *pte = 0000000000000000 
[  311.687704] Oops: 0000 [#1] PREEMPT SMP 
[  311.687752] Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) bbswitch(O) cdc_ether usbnet cdc_wdm cdc_acm joydev intel_powerclamp coretemp iTCO_wdt kvm_intel iTCO_vendor_support kvm dell_wmi sparse_keymap acpi_call(O) crc32_pclmul crc32c_intel aesni_intel snd_hda_codec_hdmi psmouse aes_i586 xts lrw gf128mul dell_laptop dcdbas arc4 ablk_helper serio_raw r8169 mii iwldvm cryptd mei lpc_ich i2c_i801 snd_hda_codec_realtek thermal microcode battery iwlwifi snd_hda_intel evdev wmi ac snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer snd soundcore tun vboxnetflt(O) vboxdrv(O) fuse uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media iwl3945 iwlegacy mac80211 cfg80211 rfkill cpufreq_userspace cpufreq_conservative cpufreq_powersave cpufreq_stats mperf processor ext4 crc16 mbcache
[  311.688622]  jbd2 xhci_hcd ehci_pci i915 video button i2c_algo_bit drm_kms_helper drm i2c_core intel_agp intel_gtt agpgart uhci_hcd ehci_hcd usbcore usb_common tg3 ptp pps_core libphy ata_piix sr_mod cdrom sd_mod ahci libahci ata_generic libata scsi_mod [last unloaded: nvidia]
[  311.688928] Pid: 4018, comm: mplayer Tainted: P           O 3.9.5-1-pae #1 Dell Inc.          Dell System XPS L502X/0NJT03
[  311.689030] EIP: 0060:[<c1196b07>] EFLAGS: 00210202 CPU: 0
[  311.689085] EIP is at proc_reg_open+0x57/0x120
[  311.689128] EAX: f80ed980 EBX: ef136840 ECX: 00000000 EDX: 00000000
[  311.689186] ESI: e72f16e0 EDI: e12e4f20 EBP: ebae5e08 ESP: ebae5de8
[  311.689245]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[  311.689296] CR0: 80050033 CR2: f80ed9ac CR3: 20a15000 CR4: 000407f0
[  311.689355] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
[  311.689413] DR6: ffff0ff0 DR7: 00000400
[  311.689451] Process mplayer (pid: 4018, ti=ebae4000 task=dfc1b660 task.ti=ebae4000)
[  311.689521] Stack:
[  311.689541]  e12e4f20 ebae5e08 e6ee5600 e12e4f20 ef136890 e6ee5600 c1196ab0 e12e4f20
[  311.689637]  ebae5e30 c11436ba 00008000 e12e4f20 c1196ab0 e6ee5608 ea3cf300 ebae5ed0
[  311.689731]  00000000 e6ee5600 ebae5e40 c1143acb ebae5f00 00000000 ebae5e98 c115114a
[  311.689825] Call Trace:
[  311.689855]  [<c1196ab0>] ? __pde_users_dec+0x30/0x30
[  311.689907]  [<c11436ba>] do_dentry_open+0x14a/0x250
[  311.689958]  [<c1196ab0>] ? __pde_users_dec+0x30/0x30
[  311.690008]  [<c1143acb>] finish_open+0x2b/0x40
[  311.690054]  [<c115114a>] do_last+0x30a/0xd10
[  311.690099]  [<c114f21c>] ? link_path_walk+0x1dc/0x750
[  311.690151]  [<c1132235>] ? kmem_cache_alloc+0x195/0x1b0
[  311.690204]  [<c1151bf4>] path_openat+0xa4/0x420
[  311.690251]  [<c1152b09>] ? user_path_at_empty+0x49/0x70
[  311.690303]  [<c1152b8b>] do_filp_open+0x2b/0x70
[  311.690350]  [<c1144b02>] do_sys_open+0xe2/0x1b0
[  311.690396]  [<c1144bf8>] sys_open+0x28/0x30
[  311.690442]  [<c14001b6>] ? native_cpu_up+0x4cc/0x894
[  311.690494]  [<c14120cd>] sysenter_do_call+0x12/0x28
[  311.690543]  [<c1400000>] ? native_cpu_up+0x316/0x894
[  311.690590] Code: 00 00 e8 6d b7 f9 ff 85 c0 89 c6 0f 84 c3 00 00 00 8d 43 50 89 45 f0 e8 d8 4a 27 00 8b 43 20 85 c0 0f 84 b4 00 00 00 83 43 40 01 <8b> 78 2c 8b 40 34 89 45 e0 8b 45 f0 e8 b8 4c 27 00 85 ff 0f 84
[  311.690935] EIP: [<c1196b07>] proc_reg_open+0x57/0x120 SS:ESP 0068:ebae5de8
[  311.691009] CR2: 00000000f80ed9ac
[  311.714441] ---[ end trace c56cbbfb9cfc1d92 ]---
[  311.714445] note: mplayer[4018] exited with preempt_count 1

When I run it a second time, instead of crashing it hangs forever, I can't even killall -9 it. A new kernel error shows up in dmesg, and the kernel starts eating 100% CPU.

MPlayer SVN-r36285-4.8.0 (C) 2000-2013 MPlayer Team
Cannot test OS support for SSE, disabling to be safe.
205 audio & 424 video codecs
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing pajama jam.flv.
libavformat version 55.7.100 (internal)
libavformat file format detected.
[lavf] stream 0: video (vp6f), -vid 0
[lavf] stream 1: audio (mp3), -aid 0
VIDEO:  [VP6F]  504x380  0bpp  30.000 fps  475.9 kbps (58.1 kbyte/s)
Clip info:
 lasttimestamp: 1001
 datasize: 73537080
 metadatacreator: FlixEngineLinux_8.0.12.0 (www.on2.com)
 canSeekToEnd: 1
 videosize: 59526566
 audiosize: 14010514
Load subtitles in ./
<----HANGS------>
[  372.403330] BUG: soft lockup - CPU#1 stuck for 22s! [mplayer:4023]
[  372.403334] Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) bbswitch(O) cdc_ether usbnet cdc_wdm cdc_acm joydev intel_powerclamp coretemp iTCO_wdt kvm_intel iTCO_vendor_support kvm dell_wmi sparse_keymap acpi_call(O) crc32_pclmul crc32c_intel aesni_intel snd_hda_codec_hdmi psmouse aes_i586 xts lrw gf128mul dell_laptop dcdbas arc4 ablk_helper serio_raw r8169 mii iwldvm cryptd mei lpc_ich i2c_i801 snd_hda_codec_realtek thermal microcode battery iwlwifi snd_hda_intel evdev wmi ac snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer snd soundcore tun vboxnetflt(O) vboxdrv(O) fuse uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media iwl3945 iwlegacy mac80211 cfg80211 rfkill cpufreq_userspace cpufreq_conservative cpufreq_powersave cpufreq_stats mperf processor ext4 crc16 mbcache
[  372.403373]  jbd2 xhci_hcd ehci_pci i915 video button i2c_algo_bit drm_kms_helper drm i2c_core intel_agp intel_gtt agpgart uhci_hcd ehci_hcd usbcore usb_common tg3 ptp pps_core libphy ata_piix sr_mod cdrom sd_mod ahci libahci ata_generic libata scsi_mod [last unloaded: nvidia]
[  372.403390] Pid: 4023, comm: mplayer Tainted: P      D    O 3.9.5-1-pae #1 Dell Inc.          Dell System XPS L502X/0NJT03
[  372.403391] EIP: 0060:[<c140b5fd>] EFLAGS: 00200297 CPU: 1
[  372.403396] EIP is at _raw_spin_lock+0x2d/0x40
[  372.403397] EAX: ef136890 EBX: ef136840 ECX: 00000001 EDX: 00000000
[  372.403398] ESI: e71304a0 EDI: e12e4f20 EBP: ec74fde0 ESP: ec74fde0
[  372.403399]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[  372.403400] CR0: 80050033 CR2: b5804010 CR3: 26e4f000 CR4: 000407f0
[  372.403401] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
[  372.403402] DR6: ffff0ff0 DR7: 00000400
[  372.403403] Process mplayer (pid: 4023, ti=ec74e000 task=dfc18ae0 task.ti=ec74e000)
[  372.403404] Stack:
[  372.403405]  ec74fe08 c1196af8 e12e4f20 ec74fe08 ef155240 e12e4f20 ef136890 ef155240
[  372.403408]  c1196ab0 e12e4f20 ec74fe30 c11436ba 00008000 e12e4f20 c1196ab0 ef155248
[  372.403412]  ea3cf200 ec74fed0 00000000 ef155240 ec74fe40 c1143acb ec74ff00 00000000
[  372.403415] Call Trace:
[  372.403420]  [<c1196af8>] proc_reg_open+0x48/0x120
[  372.403422]  [<c1196ab0>] ? __pde_users_dec+0x30/0x30
[  372.403425]  [<c11436ba>] do_dentry_open+0x14a/0x250
[  372.403428]  [<c1196ab0>] ? __pde_users_dec+0x30/0x30
[  372.403430]  [<c1143acb>] finish_open+0x2b/0x40
[  372.403432]  [<c115114a>] do_last+0x30a/0xd10
[  372.403434]  [<c114f09e>] ? link_path_walk+0x5e/0x750
[  372.403437]  [<c1132235>] ? kmem_cache_alloc+0x195/0x1b0
[  372.403439]  [<c1151bf4>] path_openat+0xa4/0x420
[  372.403441]  [<c1152b09>] ? user_path_at_empty+0x49/0x70
[  372.403444]  [<c1152b8b>] do_filp_open+0x2b/0x70
[  372.403446]  [<c1144b02>] do_sys_open+0xe2/0x1b0
[  372.403449]  [<c1144bf8>] sys_open+0x28/0x30
[  372.403452]  [<c14001b6>] ? native_cpu_up+0x4cc/0x894
[  372.403454]  [<c14120cd>] sysenter_do_call+0x12/0x28
[  372.403455] Code: e5 66 66 66 66 90 89 e2 81 e2 00 e0 ff ff 83 42 14 01 ba 00 01 00 00 f0 66 0f c1 10 0f b6 ce 38 d1 74 0c 8d 76 00 f3 90 0f b6 10 <38> ca 75 f7 5d c3 8d b6 00 00 00 00 8d bc 27 00 00 00 00 55 89

Offline

#17 2013-06-16 18:53:51

RazZziel
Member
From: Spain
Registered: 2007-07-13
Posts: 35

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

The mplayer problem is still happening with 3.9.6-1-pae. Some times mplayer works fine, but other times the kernel will crash with the same call trace.

Offline

#18 2013-06-29 09:48:15

RazZziel
Member
From: Spain
Registered: 2007-07-13
Posts: 35

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

linux-pae 3.9.7-1 is still really unstable, it will crash when trying to view videos with mplayer or chromium (both flash and html5). There are also overheating problems, as bbswitch doesn't seem to be able to turn off the Nvidia chip until I reboot bumblebeed.

Downgraded to 3.8.11, and everything works perfect again.

Offline

#19 2013-06-30 12:45:15

RazZziel
Member
From: Spain
Registered: 2007-07-13
Posts: 35

Re: Linux 3.9.2-1 lockups (nVidia + nouveau)

Looks like it was actually a problem with the nvidia driver or even hardware. strace showed that mplayer crashed when executing

open("/proc/driver/nvidia/params", O_RDONLY)

After removing nvidia driver, my system seems to be stable again with linux 3.9.8-1-pae

Offline

Board footer

Powered by FluxBB