You are not logged in.

#1 2013-05-12 20:41:10

Koopa
Member
Registered: 2012-07-20
Posts: 19

Audio Issues After Upgrade to linux 3.9.2-1

I did an upgrade today and now I'm having an issue with my audio. What happens is it'll sound like it is skipping every few seconds. What I notice is the headphone symbol flickers on in the GNOME top bar, as if my computer thinks the headphones got plugged in and then removed vary rapidly. My first thought was poor connection to the wire going to my speakers, but it is fine, the speakers work with my laptop no problem, and the same problem comes with my headphones. Also I didn't have this problem before the update.

I was having trouble finding any info elsewhere about it, was wondering if anyone had a similar issue. The update I suspect is the linux kernel 3.8.11-1 -> 3.9.2-1, though I suppose I have no basis for suspecting it. Below is the pacman.log for today when I upgraded.

[2013-05-12 15:52] [PACMAN] Running 'pacman -Syy'
[2013-05-12 15:52] [PACMAN] synchronizing package lists
[2013-05-12 15:52] [PACMAN] Running 'pacman -Syu'
[2013-05-12 15:52] [PACMAN] synchronizing package lists
[2013-05-12 15:52] [PACMAN] starting full system upgrade
[2013-05-12 15:56] [PACMAN] upgraded ca-certificates-java (20121112+nmu2-1 -> 20121112+nmu2-2)
[2013-05-12 15:56] [PACMAN] upgraded nss (3.14.3-2 -> 3.14.3-3)
[2013-05-12 15:56] [PACMAN] upgraded evolution-data-server (3.8.1-1 -> 3.8.2-1)
[2013-05-12 15:56] [PACMAN] upgraded libvpx (1.1.0-1 -> 1.2.0-1)
[2013-05-12 15:56] [PACMAN] upgraded ffmpeg (1:1.2-2 -> 1:1.2.1-1)
[2013-05-12 15:56] [PACMAN] upgraded giflib (4.1.6-5 -> 4.2.1-1)
[2013-05-12 15:56] [PACMAN] upgraded perl-error (0.17019-1 -> 0.17020-1)
[2013-05-12 15:56] [PACMAN] upgraded git (1.8.2.2-1 -> 1.8.2.3-1)
[2013-05-12 15:56] [PACMAN] upgraded gnutls (3.1.10-1 -> 3.1.11-1)
[2013-05-12 15:56] [PACMAN] upgraded gvfs (1.16.1-1 -> 1.16.1-2)
[2013-05-12 15:56] [PACMAN] upgraded libimobiledevice (1.1.4-2 -> 1.1.5-1)
[2013-05-12 15:56] [PACMAN] upgraded gvfs-afc (1.16.1-1 -> 1.16.1-2)
[2013-05-12 15:56] [PACMAN] upgraded gvfs-obexftp (1.16.1-1 -> 1.16.1-2)
[2013-05-12 15:56] [PACMAN] upgraded hdf5 (1.8.10-1 -> 1.8.10_patch1-1)
[2013-05-12 15:56] [PACMAN] upgraded imagemagick (6.8.5.3-1 -> 6.8.5.6-1)
[2013-05-12 15:56] [PACMAN] upgraded nvidia-utils (313.30-2 -> 319.17-1)
[2013-05-12 15:56] [PACMAN] upgraded nvidia-libgl (313.30-2 -> 319.17-1)
[2013-05-12 15:56] [PACMAN] upgraded qt4 (4.8.4-17 -> 4.8.4-18)
[2013-05-12 15:56] [PACMAN] upgraded soprano (2.9.1-1 -> 2.9.2-1)
[2013-05-12 15:56] [PACMAN] upgraded upower (0.9.20-1 -> 0.9.20-2)
[2013-05-12 15:56] [PACMAN] upgraded kdelibs (4.10.2-4 -> 4.10.3-3)
[2013-05-12 15:56] [PACMAN] upgraded lib32-nvidia-utils (313.30-2 -> 319.17-1)
[2013-05-12 15:56] [PACMAN] upgraded lib32-nvidia-libgl (313.30-2 -> 319.17-1)
[2013-05-12 15:56] [PACMAN] upgraded lib32-systemd (202-1 -> 203-1)
[2013-05-12 15:56] [PACMAN] upgraded libgpod (0.8.2-6 -> 0.8.2-7)
[2013-05-12 15:56] [PACMAN] upgraded libpcap (1.3.0-3 -> 1.4.0-1)
[2013-05-12 15:56] [PACMAN] upgraded libpipeline (1.2.2-1 -> 1.2.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-en-US (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-common (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-base (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-calc (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-draw (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-gnome (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-impress (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-kde4 (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-math (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-postgresql-connector (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-sdk (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-sdk-doc (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libxml2 (2.8.0-1 -> 2.9.1-1)
[2013-05-12 15:56] [PACMAN] upgraded libreoffice-writer (4.0.2-4 -> 4.0.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libtirpc (0.2.2-4 -> 0.2.3-1)
[2013-05-12 15:56] [PACMAN] upgraded libxfce4util (4.10.1-1 -> 4.10.1-2)
[2013-05-12 15:57] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2013-05-12 15:57] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Starting build: 3.9.2-1-ARCH
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux.img
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Starting build: 3.9.2-1-ARCH
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-05-12 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
[2013-05-12 15:57] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-05-12 15:57] [PACMAN] upgraded linux (3.8.11-1 -> 3.9.2-1)
[2013-05-12 15:57] [PACMAN] upgraded lirc-utils (1:0.9.0-43 -> 1:0.9.0-45)
[2013-05-12 15:57] [PACMAN] upgraded lm_sensors (3.3.3-2 -> 3.3.3-3)
[2013-05-12 15:57] [PACMAN] upgraded sbcl (1.1.4-1 -> 1.1.7-1)
[2013-05-12 15:57] [PACMAN] upgraded maxima (5.29.1-1 -> 5.30.0-1)
[2013-05-12 15:57] [PACMAN] upgraded nvidia (313.30-5 -> 319.17-2)
[2013-05-12 15:57] [PACMAN] upgraded pam (1.1.6-1 -> 1.1.6-3)
[2013-05-12 15:57] [PACMAN] upgraded pixman (0.28.2-1 -> 0.30.0-1)
[2013-05-12 15:57] [PACMAN] upgraded rhythmbox (2.99.1-1 -> 2.99.1-2)
[2013-05-12 15:57] [PACMAN] upgraded rpcbind (0.2.0-9 -> 0.2.0-11)
[2013-05-12 15:57] [PACMAN] upgraded rsync (3.0.9-5 -> 3.0.9-6)
[2013-05-12 15:57] [PACMAN] upgraded sbc (1.0-1 -> 1.1-1)
[2013-05-12 15:57] [ALPM-SCRIPTLET] if you are running x86_64, you need the lib32 opt depends for your driver
[2013-05-12 15:57] [ALPM-SCRIPTLET] 
[2013-05-12 15:57] [ALPM-SCRIPTLET]  if you are having problems with the steam license, remove .steam and .local/share/Steam
[2013-05-12 15:57] [PACMAN] upgraded steam (1.0.0.38-1 -> 1.0.0.39-1)
[2013-05-12 15:57] [PACMAN] upgraded suitesparse (4.0.2-1 -> 4.2.1-1)
[2013-05-12 15:57] [PACMAN] upgraded thunar-archive-plugin (0.3.0-2 -> 0.3.1-1)
[2013-05-12 15:57] [PACMAN] upgraded thunar-media-tags-plugin (0.2.0-2 -> 0.2.1-1)
[2013-05-12 15:57] [PACMAN] upgraded virtualbox-guest-modules (4.2.12-3 -> 4.2.12-5)
[2013-05-12 15:57] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2013-05-12 15:57] [PACMAN] upgraded virtualbox-host-modules (4.2.12-3 -> 4.2.12-5)
[2013-05-12 15:57] [PACMAN] upgraded xfce4-mixer (4.10.0-1 -> 4.10.0-2)
[2013-05-12 15:57] [PACMAN] upgraded xfce4-power-manager (1.2.0-3 -> 1.2.0-4)

Thanks,
-Koopa

EDIT: Been searching for a while and found some others with the same problems, but no solutions still. My hardware posted below.

$ cat /proc/asound/cards 
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe500000 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe080000 irq 25
$ lspci | grep Audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)

EDIT: So, after some not so successful searching I decided to test my suspicion. I downgraded from linux 3.9.2-1 back to 3.8.11-1. There were a few dependancies, the virtualbox guest and host modules as well as an update to nvidia. To be safe I downgraded all the nvidia updates that had happened. pacman log below.

[2013-05-12 22:35] [PACMAN] Running 'pacman -U linux-3.8.11-1-x86_64.pkg.tar.xz nvidia-313.30-5-x86_64.pkg.tar.xz virtualbox-guest-modules-4.2.12-3-x86_64.pkg.tar.xz virtualbox-host-modules-4.2.12-3-x86_64.pkg.tar.xz nvidia-utils-313.30-2-x86_64.pkg.tar.xz nvidia-libgl-313.30-2-x86_64.pkg.tar.xz lib32-nvidia-utils-313.30-2-x86_64.pkg.tar.xz lib32-nvidia-libgl-313.30-2-x86_64.pkg.tar.xz'
[2013-05-12 22:35] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2013-05-12 22:35] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Starting build: 3.8.11-1-ARCH
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux.img
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Starting build: 3.8.11-1-ARCH
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2013-05-12 22:35] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
[2013-05-12 22:35] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-05-12 22:35] [PACMAN] downgraded linux (3.9.2-1 -> 3.8.11-1)
[2013-05-12 22:35] [PACMAN] downgraded nvidia-utils (319.17-1 -> 313.30-2)
[2013-05-12 22:35] [PACMAN] downgraded nvidia-libgl (319.17-1 -> 313.30-2)
[2013-05-12 22:35] [PACMAN] downgraded nvidia (319.17-2 -> 313.30-5)
[2013-05-12 22:36] [PACMAN] downgraded virtualbox-guest-modules (4.2.12-5 -> 4.2.12-3)
[2013-05-12 22:36] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2013-05-12 22:36] [PACMAN] downgraded virtualbox-host-modules (4.2.12-5 -> 4.2.12-3)
[2013-05-12 22:36] [PACMAN] downgraded lib32-nvidia-utils (319.17-1 -> 313.30-2)
[2013-05-12 22:36] [PACMAN] downgraded lib32-nvidia-libgl (319.17-1 -> 313.30-2)

So, now how would I go about determining which package broke the audio? I had suspected the linux kernel update, but I suppose the nvidia update could have done it to. If necessary I'd love to file a bug, but I want to make sure I can describe it efficiently. (I've never filed a bug before.)

EDIT (5/31/2013): Currently some work arounds that may alleviate your issue, the one that worked for me is to disable auto-mute in alsamixer. The problem however does still exist in the latest kernel upgrade, 3.9.4-1. Bug report is still open, and can be found here: https://bugs.archlinux.org/task/35262

Thanks,
-Koopa

Last edited by Koopa (2013-05-31 04:47:20)

Offline

#2 2013-05-13 06:19:42

Innominate
Member
Registered: 2012-12-29
Posts: 13

Re: Audio Issues After Upgrade to linux 3.9.2-1

I can confirm the issue. I'm using KDE and when I start my laptop, I get this message:

KDE detected that one or more internal devices were removed.

Do you want KDE to permanently forget about these devices?

This is the list of devices KDE thinks can be removed:

Capture: HDA Intel PCH, STAC92xx Analog (Default Audio Device)
Output: HDA Intel PCH, STAC92xx Analog (Default Audio Device)

It doesn't matter if I have the headphones connected or not, I still get sound only from the speakers. Used Google yesterday and found a topic where an openSUSE user who upgraded to 3.9 series had the same issue. On Phoronix, there's an article about sound to be improved in 3.9 kernel.

Offline

#3 2013-05-13 11:47:41

Koopa
Member
Registered: 2012-07-20
Posts: 19

Re: Audio Issues After Upgrade to linux 3.9.2-1

Did having KDE permanently forget about the device (the non-existent headphones) solve the problem?

Offline

#4 2013-05-13 13:13:54

Innominate
Member
Registered: 2012-12-29
Posts: 13

Re: Audio Issues After Upgrade to linux 3.9.2-1

Sorry, I didn't dare to allow KDE to forget the devices and I'm using the system as it is at the moment.

Offline

#5 2013-05-13 13:30:27

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 679

Re: Audio Issues After Upgrade to linux 3.9.2-1

After upgrade to 3.9 i have problems with headphones. When i plug them in there is no sound but if i plug them only half of the size i can hear some audio.

cat /proc/asound/cards

 0 [Intel]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe9f4000 irq 45

lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#6 2013-05-13 14:20:30

anthon
Member
Registered: 2013-05-13
Posts: 30

Re: Audio Issues After Upgrade to linux 3.9.2-1

If you have no sound in KDE it's because the sound sensibility changed with the new kernel, so you have to change that using alsamixer. Moreover, it's safe to tell KDE to forget about the devices, most likely it's due to a change in the naming of the devices in the kernel or something like that, anyway KDE will find the audio recognised by the kernel.

I'm not sure this is the same problem Koopa encountered though.

Offline

#7 2013-05-13 14:34:05

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 679

Re: Audio Issues After Upgrade to linux 3.9.2-1

In alsamixer i have headphones entry to the full. As i said, i can hear sound on headphones but i must not plug them in computer completely.


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#8 2013-05-13 16:17:34

Innominate
Member
Registered: 2012-12-29
Posts: 13

Re: Audio Issues After Upgrade to linux 3.9.2-1

anthon wrote:

If you have no sound in KDE it's because the sound sensibility changed with the new kernel, so you have to change that using alsamixer. Moreover, it's safe to tell KDE to forget about the devices, most likely it's due to a change in the naming of the devices in the kernel or something like that, anyway KDE will find the audio recognised by the kernel.

I'm not sure this is the same problem Koopa encountered though.

Thank you. All the problems are fixed and everything works as expected. Was safe to let KDE forget the devices and toggling auto-mute from Alsamixer fixed the issue as well.

Offline

#9 2013-05-13 17:38:53

pablo.cardozo
Member
From: Montevideo, Uruguay
Registered: 2013-05-13
Posts: 1
Website

Re: Audio Issues After Upgrade to linux 3.9.2-1

I'm still with the same problem, I have no audio from the upgrade. I accepted that I forget KDE audio device mentioned. No I have alsamixer, kmix only.

cat / proc / asound / cards
  0 [PCH]: HDA-Intel - HDA Intel PCH
                       HDA Intel PCH at 0xf7b00000 irq 59
  1 [NVidia]: HDA-Intel - HDA NVidia
                       HDA NVidia at 0xf6080000 irq 17

Thanks for all the help.

Offline

#10 2013-05-13 21:44:13

Chehri
Member
Registered: 2013-05-13
Posts: 6

Re: Audio Issues After Upgrade to linux 3.9.2-1

Just wanted to say I had the same problem. I fixed it by downgrading the kernel as well.

For those who are new to Arch, this is what I ran (note, you'll probably have to remove/change whatever package(s) is/are holding you back from downgrading the kernel):

pacman -U /var/cache/pacman/pkg/linux-3.8.11-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/virtualbox-host-modules-4.2.12-2-x86_64.pkg.tar.xz /var/cache/pacman/pkg/bbswitch-0.6-5-x86_64.pkg.tar.xz

Offline

#11 2013-05-14 03:39:42

Koopa
Member
Registered: 2012-07-20
Posts: 19

Re: Audio Issues After Upgrade to linux 3.9.2-1

Since others have reportedly seen the same issue, and I finally got to my computer after this initial post, I've filed a bug. You can find it here:

https://bugs.archlinux.org/task/35262

Thanks,
-Koopa

Offline

#12 2013-05-14 04:30:32

bchr
Member
Registered: 2013-05-14
Posts: 5

Re: Audio Issues After Upgrade to linux 3.9.2-1

Same problem here, and downgrading the kernel worked. I also had some sound problems with the previous 3.8 kernels (sometimes there would be no sound, either on speakers or headphones), so I had high hopes with these new kernel changes ^_^"

$ cat /proc/asound/cards
0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xd2710000 irq 49
1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xd1000000 irq 17

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)

Offline

#13 2013-05-14 04:32:08

Chehri
Member
Registered: 2013-05-13
Posts: 6

Re: Audio Issues After Upgrade to linux 3.9.2-1

Koopa wrote:

Since others have reportedly seen the same issue, and I finally got to my computer after this initial post, I've filed a bug. You can find it here:

https://bugs.archlinux.org/task/35262

Thanks,
-Koopa

Thanks for reporting it. Slight note though, I had no noise at all (no flickering).

If someone could update this thread when a new kernel works, that'd be great! I put it in my IgnorePkg for the moment.

Offline

#14 2013-05-14 04:37:45

Koopa
Member
Registered: 2012-07-20
Posts: 19

Re: Audio Issues After Upgrade to linux 3.9.2-1

Chehri wrote:
Koopa wrote:

Since others have reportedly seen the same issue, and I finally got to my computer after this initial post, I've filed a bug. You can find it here:

https://bugs.archlinux.org/task/35262

Thanks,
-Koopa

Thanks for reporting it. Slight note though, I had no noise at all (no flickering).

If someone could update this thread when a new kernel works, that'd be great! I put it in my IgnorePkg for the moment.

Is there anyway to edit a bug report? I don't see anything obvious, but I'm exhausted, so maybe my brain isn't working properly. Anyway, if there isn't, I'd just leave a comment on the report with the fact that you hear nothing, not even the flicker.

And thanks for reminding me to add it to IgnorePkg, forgot to/never have had to do that before. But I'll be sure to post here when I know it's fixed.

Offline

#15 2013-05-14 20:06:05

ludenticus
Member
Registered: 2013-05-14
Posts: 14

Re: Audio Issues After Upgrade to linux 3.9.2-1

I experienced the same issue, but found the solution, as suggested by anthon (post #6) and Innominate (post #8):

run alsamixer and turn off auto-mute after selecting Sound card (F6).

I didn't let Phonon/Kmix forget the devices.

Offline

#16 2013-05-14 20:57:10

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,041

Re: Audio Issues After Upgrade to linux 3.9.2-1

ludenticus wrote:

I experienced the same issue, but found the solution, as suggested by anthon (post #6) and Innominate (post #8):

run alsamixer and turn off auto-mute after selecting Sound card (F6).

I didn't let Phonon/Kmix forget the devices.

I can confirm that this worked for me too.

Offline

#17 2013-05-14 22:06:11

Koopa
Member
Registered: 2012-07-20
Posts: 19

Re: Audio Issues After Upgrade to linux 3.9.2-1

ludenticus wrote:

I experienced the same issue, but found the solution, as suggested by anthon (post #6) and Innominate (post #8):

run alsamixer and turn off auto-mute after selecting Sound card (F6).

I didn't let Phonon/Kmix forget the devices.

This is for the issue where you have absolutely no sound, correct? You didn't have a sound flicker?

Offline

#18 2013-05-14 22:07:19

Chehri
Member
Registered: 2013-05-13
Posts: 6

Re: Audio Issues After Upgrade to linux 3.9.2-1

jakobcreutzfeldt wrote:
ludenticus wrote:

I experienced the same issue, but found the solution, as suggested by anthon (post #6) and Innominate (post #8):

run alsamixer and turn off auto-mute after selecting Sound card (F6).

I didn't let Phonon/Kmix forget the devices.

I can confirm that this worked for me too.

I always had auto-mute off, though I didn't try switching it on and off.

Offline

#19 2013-05-15 07:58:14

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 679

Re: Audio Issues After Upgrade to linux 3.9.2-1

jakobcreutzfeldt wrote:
ludenticus wrote:

I experienced the same issue, but found the solution, as suggested by anthon (post #6) and Innominate (post #8):

run alsamixer and turn off auto-mute after selecting Sound card (F6).

I didn't let Phonon/Kmix forget the devices.

I can confirm that this worked for me too.

That SOLVED my problem.

Thanks!


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#20 2013-05-15 15:39:24

ybsar
Member
Registered: 2013-05-15
Posts: 10

Re: Audio Issues After Upgrade to linux 3.9.2-1

Shark wrote:

After upgrade to 3.9 i have problems with headphones. When i plug them in there is no sound but if i plug them only half of the size i can hear some audio.

I have the same problem than Shark had, but the proposed workaround did not solved my problem.

cat /proc/asound/cards

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7a10000 irq 47

lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

Temporarily solved by downgrading to linux 3.8.11.

Last edited by ybsar (2013-05-15 16:06:43)

Offline

#21 2013-05-15 23:42:56

fawkes5
Member
From: Canada
Registered: 2012-12-23
Posts: 84

Re: Audio Issues After Upgrade to linux 3.9.2-1

ludenticus wrote:

I experienced the same issue, but found the solution, as suggested by anthon (post #6) and Innominate (post #8):

run alsamixer and turn off auto-mute after selecting Sound card (F6).

I didn't let Phonon/Kmix forget the devices.

This did not work for me.

Downgrading to kernel 3.8.11 does work, however it breaks League of Legends which i run with wine.
Gotta get my LoL fix.

Last edited by fawkes5 (2013-05-15 23:44:26)

Offline

#22 2013-05-16 05:12:31

fawkes5
Member
From: Canada
Registered: 2012-12-23
Posts: 84

Re: Audio Issues After Upgrade to linux 3.9.2-1

I just ran a system upgrade and now everything is working properly. I assume it was the util-linux package upgrade.

EDIT: nvm, its still not working properly.

Last edited by fawkes5 (2013-05-16 15:14:46)

Offline

#23 2013-05-16 08:16:41

Azd325
Member
From: Berlin
Registered: 2012-12-21
Posts: 31
Website

Re: Audio Issues After Upgrade to linux 3.9.2-1

I had also problem with my sound after upgrading.  I fixed it with right model option in mod probe.  Did you try this

Offline

#24 2013-05-16 08:17:22

Chehri
Member
Registered: 2013-05-13
Posts: 6

Re: Audio Issues After Upgrade to linux 3.9.2-1

Azd325 wrote:

I had also problem with my sound after upgrading.  I fixed it with right model option in mod probe.  Did you try this

What module did you load? snd was loaded for me and still didn't work.

Offline

#25 2013-05-16 09:13:04

Azd325
Member
From: Berlin
Registered: 2012-12-21
Posts: 31
Website

Re: Audio Issues After Upgrade to linux 3.9.2-1

head -1 /proc/asound/card0/codec#0

Make this to check which codec you need for your card and try to find it on
https://www.kernel.org/doc/Documentatio … Models.txt

You have to try around to find the right model

I've this Codec: Conexant CX20588 and this will interpret as Conexant 5066 and I choose then the Thinkpad model     for though I've acer smile

More info at https://wiki.archlinux.org/index.php/Ad … chitecture (Topic Model settings)

Offline

Board footer

Powered by FluxBB