You are not logged in.

#26 2013-05-08 19:41:40

plp
Member
Registered: 2013-01-24
Posts: 15

Re: [SOLVED] fusion-icon (compiz) crashes

What about your SaveOnExit property? Is it set to "false" as it should (again according to the Wiki)?

  <property name="general" type="empty">
    <property name="FailsafeSessionName" type="empty"/>
    <property name="SessionName" type="string" value="Default"/>
    <property name="SaveOnExit" type="bool" value="false"/>
  </property>

Offline

#27 2013-05-08 19:49:09

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [SOLVED] fusion-icon (compiz) crashes

everything is configured according the wiki:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-session" version="1.0">
  <property name="general" type="empty">
    <property name="FailsafeSessionName" type="empty"/>
    <property name="SessionName" type="string" value="Default"/>
    <property name="SaveOnExit" type="bool" value="false"/>
  </property>
  <property name="sessions" type="empty">
    <property name="Failsafe" type="empty">
      <property name="IsFailsafe" type="empty"/>
      <property name="Count" type="empty"/>
      <property name="Client0_Command" type="array">
        <value type="string" value="fusion-icon"/>
        <value type="string" value="--force-compiz"/>
      </property>
      <property name="Client0_PerScreen" type="empty"/>
      <property name="Client1_Command" type="empty"/>
      <property name="Client1_PerScreen" type="empty"/>
      <property name="Client2_Command" type="empty"/>
      <property name="Client2_PerScreen" type="empty"/>
      <property name="Client3_Command" type="empty"/>
      <property name="Client3_PerScreen" type="empty"/>
      <property name="Client4_Command" type="empty"/>
      <property name="Client4_PerScreen" type="empty"/>
    </property>
  </property>
  <property name="splash" type="empty">
    <property name="Engine" type="string" value=""/>
    <property name="engines" type="empty">
      <property name="balou" type="empty">
        <property name="Theme" type="string" value="kindersurprise"/>
      </property>
    </property>
  </property>
  <property name="compat" type="empty">
    <property name="LaunchGNOME" type="bool" value="true"/>
  </property>
</channel>

Offline

#28 2013-05-08 20:37:46

plp
Member
Registered: 2013-01-24
Posts: 15

Re: [SOLVED] fusion-icon (compiz) crashes

OK, I give up. :-(

Offline

#29 2013-05-08 23:19:29

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [SOLVED] fusion-icon (compiz) crashes

Are there any logs in which I could trace back what actually happens?

Offline

#30 2013-05-10 16:50:19

plp
Member
Registered: 2013-01-24
Posts: 15

Re: [SOLVED] fusion-icon (compiz) crashes

I think I once managed to do that by stopping the login manager and starting XFCE from the console, by executing 'startxfce4'.

Offline

#31 2013-05-10 20:32:24

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [SOLVED] fusion-icon (compiz) crashes

nuc wrote:

everything is configured according the wiki:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-session" version="1.0">
  <property name="general" type="empty">
    <property name="FailsafeSessionName" type="empty"/>
    <property name="SessionName" type="string" value="Default"/>
    <property name="SaveOnExit" type="bool" value="false"/>
  </property>
  <property name="sessions" type="empty">
    <property name="Failsafe" type="empty">
      <property name="IsFailsafe" type="empty"/>
      <property name="Count" type="empty"/>
      <property name="Client0_Command" type="array">
        <value type="string" value="fusion-icon"/>
        <value type="string" value="--force-compiz"/>
      </property>
      <property name="Client0_PerScreen" type="empty"/>
      <property name="Client1_Command" type="empty"/>
      <property name="Client1_PerScreen" type="empty"/>
      <property name="Client2_Command" type="empty"/>
      <property name="Client2_PerScreen" type="empty"/>
      <property name="Client3_Command" type="empty"/>
      <property name="Client3_PerScreen" type="empty"/>
      <property name="Client4_Command" type="empty"/>
      <property name="Client4_PerScreen" type="empty"/>
    </property>
  </property>
  <property name="splash" type="empty">
    <property name="Engine" type="string" value=""/>
    <property name="engines" type="empty">
      <property name="balou" type="empty">
        <property name="Theme" type="string" value="kindersurprise"/>
      </property>
    </property>
  </property>
  <property name="compat" type="empty">
    <property name="LaunchGNOME" type="bool" value="true"/>
  </property>
</channel>

I got it to work, but I notice some differences between mine and yours.

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-session" version="1.0">
  <property name="general" type="empty">
    <property name="FailsafeSessionName" type="string" value="Failsafe"/>
    <property name="SessionName" type="string" value="Default"/>
    <property name="SaveOnExit" type="bool" value="false"/>
  </property>
  <property name="sessions" type="empty">
    <property name="Failsafe" type="empty">
      <property name="IsFailsafe" type="empty"/>
      <property name="Count" type="empty"/>
      <property name="Client0_Command" type="array">
        <value type="string" value="fusion-icon"/>
        <value type="string" value="--force-compiz"/>
      </property>
      <property name="Client0_PerScreen" type="empty"/>
      <property name="Client1_Command" type="empty"/>
      <property name="Client1_PerScreen" type="empty"/>
      <property name="Client2_Command" type="empty"/>
      <property name="Client2_PerScreen" type="empty"/>
      <property name="Client3_Command" type="empty"/>
      <property name="Client3_PerScreen" type="empty"/>
      <property name="Client4_Command" type="empty"/>
      <property name="Client4_PerScreen" type="empty"/>
    </property>
  </property>
  <property name="splash" type="empty">
    <property name="Engine" type="string" value=""/>
    </property>
</channel>

Namely the following is different...

<property name="FailsafeSessionName" type="string" value="Failsafe"/>

Don't have the following section...

    <property name="engines" type="empty">
      <property name="balou" type="empty">
        <property name="Theme" type="string" value="kindersurprise"/>
      </property>
    </property>
  </property>
  <property name="compat" type="empty">
    <property name="LaunchGNOME" type="bool" value="true"/>

Offline

#32 2013-05-16 15:14:44

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [SOLVED] fusion-icon (compiz) crashes

Ok, I've finally made some progress. I have found out that xfce4 DOES save my sessions (opens the same windows) and tries to load them.
I have changed the line

<property name="FailsafeSessionName" type="empty"/>

to

<property name="FailsafeSessionName" type="string" value="Failsafe"/>

because this is working for David and is also stated in the wiki.
Then I did "rm -r ~/.cache/sessions", and since now I xfce4 crashes everytime I try to login. I get an error message that the session "Failsafe" cannot be loaded... WTF??
I don't get this, SavOnExit is set to false! Now I use the exact same xml file as David, but it fails.

Any ideas why xfce4 tries to load a previous session??

Last edited by nuc (2013-05-16 15:15:49)

Offline

#33 2013-05-26 15:43:35

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [SOLVED] fusion-icon (compiz) crashes

Please guys help me, I can't fire up xfce4 stil :'(

Offline

#34 2013-05-27 23:09:40

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [SOLVED] fusion-icon (compiz) crashes

related to xfce4 storing sessions -> https://bbs.archlinux.org/viewtopic.php?id=163830

Offline

#35 2013-05-28 13:18:49

arch2013
Member
From: Berlin
Registered: 2013-05-22
Posts: 11

Re: [SOLVED] fusion-icon (compiz) crashes

Hello!

If it also happens on logout, have you checked the settings at session&startup? Maybe there are for instance "automatically started applications"

The next guess (only if you use lxdm):
(as described in my post)
lxdm does not correctly kills user processes at logout, one may want to edit /etc/lxdm/PostLogout:
--------------------------------
# Close processes on logout Bug 8209
#Find current session number
session=$(loginctl -p Sessions show-user $USER | cut -f2 -d"=" | cut -f1 -d" ")

#Terminate session
loginctl terminate-session $session

----
This should at least inhibit xfce4 to save on proper logout

Offline

#36 2014-03-23 22:37:30

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: [SOLVED] fusion-icon (compiz) crashes

Offline

Board footer

Powered by FluxBB