You are not logged in.

#1 2013-05-17 11:11:50

poseidon
Member
Registered: 2012-06-07
Posts: 60

[SOLVED] GUI kinda blocked for minutes after resume

When I'm on battery power and close the laptop's lid, Arch goes to sleep. Opening the lid has the effect, hat Arch resumes, but the taskbar is frozen: I may click on the task bar but nothing happens. However, those clicks are remembered and after a period of time the system reacts and executes all those clicks. This period of time grows with the number of sleep / resume cycles. The GUI is not completely frozen: I am able to Alt-TAB to the konsole, which is always open, and start the progs I need on the konsole.
I do not observe this behavior, if I uncheck "Lock screen on resume" in the "Advanced Settings" of the "Enhanced Battery Mnitor".

Any ideas? My DE is KDE, the laptop is a lenovo X220.

Last edited by poseidon (2013-05-18 12:57:07)

Offline

#2 2013-05-17 11:19:33

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,482

Re: [SOLVED] GUI kinda blocked for minutes after resume

I've some troubles on suspend to disk on intel graphics with some part s of the desktop not refreshing.
It is fixed by alt+shift+f12 ; alt+shift+f12  (suspend desktop effects ; re-enable them).

Offline

#3 2013-05-18 12:56:33

poseidon
Member
Registered: 2012-06-07
Posts: 60

Re: [SOLVED] GUI kinda blocked for minutes after resume

Pressed that key-combination yesterday to see what would happen. Nothing happended, actually, because all special graphic effects are switched off. However, that did something good to my laptop. Opened lid today (laptop slept since yesterday evening) and everything worked.

Thanks for the hint!

Offline

Board footer

Powered by FluxBB