You are not logged in.

#1 2013-05-19 21:11:22

Damián94
Member
From: Poland
Registered: 2013-05-02
Posts: 10

Flash crashed during watching movies in YT, sound doesn't always work.

I have many the few problems with flash and sound in my Arch Linux.

Firstly, when I want to play a movie in YouTube, flash often gets crashed. Movies stop loading, and they stop playing at the most often in 7th second or 12th second. Additionally, the sound falters itself. When I want to do something in web browser, it stops working. I must restart it, but flash still doesn't work. I noticed, after flash's crash, I cannot work for example in kdenlive. It gets crashed too. That problem often exists during watching movies in YT.
Secondly, I don't always have sound in games. For example, I cannot hear anything in Wolfenstein Enemy Territory, but e.g. in SuperTuxKart I hear everything. I don't have any idea, why sound works in some apps and doesn't work in the other apps.

I downgraded flash, because I thought, it could help, but unfortnately, it still has the problems. I use Firefox, but earlier I used Chromium and that problem was too.

Edit: I have just noticed, when after flash's crashing I want to listen to music and then I want to stop it, it falters like sound in YT movies.

Last edited by Damián94 (2013-05-19 21:15:53)

Offline

#2 2013-05-19 21:19:48

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Flash crashed during watching movies in YT, sound doesn't always work.

This is the third thread about sound issues I have read in the past couple of days that doesn't even include information about what sound system is in use...

Offline

#3 2013-05-19 21:42:26

Damián94
Member
From: Poland
Registered: 2013-05-02
Posts: 10

Re: Flash crashed during watching movies in YT, sound doesn't always work.

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI IXP SB4x0 High Definition Audio Controller (rev 01)

I have installed ALSA.

Offline

#4 2013-05-20 04:55:38

dodo3773
Member
Registered: 2011-03-17
Posts: 801

Re: Flash crashed during watching movies in YT, sound doesn't always work.

If you use pulseaudio on your system try installing pulseaudio-alsa. This works for me in chromium + pepperflash. I was having sound issues / freezing issues until I installed that package. Also, check out the pulseaudio wiki on arch wiki and / or check your system to see if you have pulseaudio installed. Does sound work in your game correctly / consistently if your web browser / flash is not open / running?

Offline

#5 2013-05-20 12:27:30

Damián94
Member
From: Poland
Registered: 2013-05-02
Posts: 10

Re: Flash crashed during watching movies in YT, sound doesn't always work.

I had pulseaudio installed, by i didn't have pulseaudio-alsa. Now, it seems, it works correctly. For now flash works correctly and not crash. I hope, your tip has helped me and I won't have any problem with sound! Thank You. smile But I still don't have sound in Wolfenstein ET. It's not muted in settings in game.

So... sound was working correctly in games (exclude ET) after flash's crashing. Only when I was listening to music and then I was pausing the music, sound was faltering.

Offline

#6 2013-05-20 16:09:49

dodo3773
Member
Registered: 2011-03-17
Posts: 801

Re: Flash crashed during watching movies in YT, sound doesn't always work.

Is wolfenstein a wine game? If so There are a bunch of optional dependencies for wine. You can see them if you do "pacman -Qi wine" (same for any installed program in Arch unless installed without pacman/PKGBUILD).  Some that I have installed are:

lib32-alsa-lib
lib32-libpulse

If the game is a 32 bit windows game running through wine you may need some of these. If that doesn't work you can run it through the pulseaudio wrapper like this: "padsp wine /path/to/game.exe" Where /path/to/game.exe is the path to your wolfenstein executable. You can also check your sound settings with a program called "winecfg" (the defaults work fine for me though). To verify that your game is using pulseaudio there is a program called "pavucontrol" that will tell you all of the programs currently using sound through pulseaudio. Hope that helps.

Edit: Also found this which may be of interest I don't know: https://aur.archlinux.org/packages/et-sdl-sound/

Last edited by dodo3773 (2013-05-20 16:10:53)

Offline

#7 2013-05-20 17:33:58

Damián94
Member
From: Poland
Registered: 2013-05-02
Posts: 10

Re: Flash crashed during watching movies in YT, sound doesn't always work.

Edit: Also found this which may be of interest I don't know: https://aur.archlinux.org/packages/et-sdl-sound/

Unfortunately, it didn't help. Wolfenstein ET is still muted.


No, this game is also for Linux and I have that version. It's patched to the newest version (for Linux only the newest version is available).
I installed this game as root - is it not bad? Is it not a reason, I cannot hear anything in this game?

Last edited by Damián94 (2013-05-20 17:34:06)

Offline

#8 2013-05-20 17:38:33

dodo3773
Member
Registered: 2011-03-17
Posts: 801

Re: Flash crashed during watching movies in YT, sound doesn't always work.

Damián94 wrote:

Edit: Also found this which may be of interest I don't know: https://aur.archlinux.org/packages/et-sdl-sound/

Unfortunately, it didn't help. Wolfenstein ET is still muted.


No, this game is also for Linux and I have that version. It's patched to the newest version (for Linux only the newest version is available).
I installed this game as root - is it not bad? Is it not a reason, I cannot hear anything in this game?

I don't know much more about this as I do not run that game.

Offline

#9 2013-05-22 21:06:32

Damián94
Member
From: Poland
Registered: 2013-05-02
Posts: 10

Re: Flash crashed during watching movies in YT, sound doesn't always work.

Hmm, I totally forgot, in ET there is a console. lol

It tells me:

------sound initialization-------
could not open /dev/dsp

But still I don't know, what I can manage myself with that problem...

Offline

#10 2013-05-23 01:45:26

dodo3773
Member
Registered: 2011-03-17
Posts: 801

Re: Flash crashed during watching movies in YT, sound doesn't always work.

May be an oss problem. Try and see if this package helps at all:

https://aur.archlinux.org/packages/et-sdl-sound/

Offline

#11 2013-05-23 19:08:16

Damián94
Member
From: Poland
Registered: 2013-05-02
Posts: 10

Re: Flash crashed during watching movies in YT, sound doesn't always work.

it did not help me. Still ET is muted. neutral

Offline

#12 2013-05-23 19:24:25

dodo3773
Member
Registered: 2011-03-17
Posts: 801

Re: Flash crashed during watching movies in YT, sound doesn't always work.

Damián94 wrote:

it did not help me. Still ET is muted. neutral

Try alsamixer in a terminal to see if anything is muted, try installing pavucontrol and look at that and see if anything is muted. Other than that I'm out of ideas.

Offline

Board footer

Powered by FluxBB