You are not logged in.

#1 2013-05-18 11:38:01

and-bnk
Member
Registered: 2013-04-10
Posts: 49

neither systemctl suspend nor pm-suspend work

Hi everyone!
I am experiencing an odd situation here: my laptop does not wake up when suspended, nieither systemctl suspend nor pm-suspend work. The following happens: it goes to sleep, but when resuming, it simply reboots.
But the funny thing is that pm-hibernate works perfectly.
I have tried everything:
systemctl + laptop-mode-tools
acpid + systemctl
acpid + pm-utils
acpid + pm-utils + laptop-mode-tools
pm-utils
pm-utils + laptop-mode-tools

everytime is a failure: my laptop does not wake up. And journalctl does not say anything illuminating.
Of course, gnome-power-manager is installed.

Is there any configuration or something that I am supposed to be aware of?

Any suggestion?

Thanks in advance!

best regards,
and-bnk

Offline

#2 2013-05-19 09:12:12

and-bnk
Member
Registered: 2013-04-10
Posts: 49

Re: neither systemctl suspend nor pm-suspend work

it seems like the problem was the fact that the user belonged to some groups such as power and network.
Now it works...
Is it possibile that the problem was just this one?!

Last edited by and-bnk (2013-05-19 09:14:14)

Offline

#3 2013-05-19 16:10:29

and-bnk
Member
Registered: 2013-04-10
Posts: 49

Re: neither systemctl suspend nor pm-suspend work

false alarm: now it does not work anymore...

what is going on here?!
Please, any suggestion?

Offline

#4 2013-05-22 05:04:36

scott_fakename
Member
Registered: 2012-08-15
Posts: 58

Re: neither systemctl suspend nor pm-suspend work

I have experienced a similar issue in the past. Tell me if this sounds familiar:

You suspend. It goes into suspend mode just fine (gives you the pulsating power light or whatever your machine does when its suspended to ram). Then you wake up. It wakes up for a split second and the shuts right down immediately. Maybe the console you were looking at or the login screen flash up for a split second and then the computer just shuts down as if you had asked it to shut down?

If that is the case then you have two things that both think they are in charge of controlling the computer's power management. Likely culprits are the desktop manager, acpid, and systemd. So choose one that you WANT to control power (in my case I chose acpid) and disable the others through their respective methods.

I am going to leave those to another post in case I'm way off base.

--Scott

Offline

#5 2013-05-22 09:22:11

and-bnk
Member
Registered: 2013-04-10
Posts: 49

Re: neither systemctl suspend nor pm-suspend work

scott_fakename wrote:

I have experienced a similar issue in the past. Tell me if this sounds familiar

yew, it does.

scott_fakename wrote:

Likely culprits are the desktop manager, acpid, and systemd. So choose one that you WANT to control power (in my case I chose acpid) and disable the others through their respective methods.

and how can disable pm-utils? and how systemctl suspend?

thanks

Offline

#6 2013-05-23 00:28:51

scott_fakename
Member
Registered: 2012-08-15
Posts: 58

Re: neither systemctl suspend nor pm-suspend work

I don't know about pm-utils... I don't think it would actually be in charge of shutting down your computer on its own. I have pm-utils installed but it never caused me any grief like that.

systemd can handle shutting down, suspending, hibernating, maybe some other things. It decides what to do and what not to do in response to various button presses by looking at the file /etc/systemd/logind.conf. If you want systemd to stop handling power, then here is what I did on my system:

1. Back up /etc/systemd/logind.conf.
2. Uncomment the lines in that file that say "HandlePowerKey=", "HandleBlahBlah=", and so on, changing their values to "ignore" (for example, "HandlePowerKey=ignore". This prevents systemd from taking action when these buttons are pressed.
3. Uncomment the lines that say "BlahBlahIgnoreInhibited=", and set them to yes. This prevents programs from telling your computer not to suspend and so on.

You might have to reboot. I don't know when logind sources that file.

Here is mine:

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# See logind.conf(5) for details

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
PowerKeyIgnoreInhibited=yes
SuspendKeyIgnoreInhibited=yes
HibernateKeyIgnoreInhibited=yes
LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min

Modify according to your needs. And then set up your acpid. Make sure that's running, and write your /etc/acpi/handler.sh . Here is a link that can tell you how to do it: https://wiki.archlinux.org/index.php/Acpid

Hope that helps.

Offline

Board footer

Powered by FluxBB