You are not logged in.

#1 2005-12-11 09:03:57

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

I cant boot with 2.6.14 from testing

/etc/lilo.conf

boot=/dev/hda
image=/boot/vmlinuz26
label=archlinux
root=dev/hda2
appednd="pci=noacpi"
read-only
mkinitrd=/boot/initrd26.img

/etc/mkinitrd.conf
# Disable whole subsystems by setting to "1"
REMOVE_IDE=
REMOVE_SCSI=
REMOVE_SATA=
REMOVE_CDROM=
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=1
REMOVE_DM=1
REMOVE_FS=

# Enable auto-detection of HOSTCONTROLlER and FILESYSTEMS (set to "1")
#   (NOTE: This is still experimental, so it is disabled by default)
AUTODETECT=0

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above
HOSTCONTROLLER_IDE="ide-core ide-generic ide-disk ata-piix piix"
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS=

# Number of seconds to wait for USB devices to settle
USB_TIMEOUT=5

# If you have an encrypted root filesystem, set it here (eg, /dev/hda4)
CRYPT_DEVICE=

# If you use software RAID for your root device then list all the devices
# that belong to your root array here.  If your root RAID device is
# something other than md0, then change the RAID_ROOT_ARRAY setting.
#    eg, RAID_ROOT_DEVICES="/dev/hda3 /dev/hdc3"
RAID_ROOT_ARRAY="md0"
RAID_ROOT_DEVICES=

# Define additional modules here
ADD_MODULE=
REMOVE_MODULE=

When I booting the kernel

Busy Box v 1.01
Enter help for commands
/bin/sh: cant access tty; job control turned off

Offline

#2 2005-12-11 09:12:12

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: I cant boot with 2.6.14 from testing

sorry,

HOSTCONTROLLER_IDE=

#mkinitrd auto

Offline

#3 2005-12-11 09:21:23

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: I cant boot with 2.6.14 from testing

Samuel Cengel wrote:

/etc/lilo.conf

boot=/dev/hda
image=/boot/vmlinuz26
label=archlinux
root=dev/hda2
appednd="pci=noacpi"
read-only
mkinitrd=/boot/initrd26.img

Use:

initrd=/boot/initrd26.img

Offline

#4 2005-12-11 09:30:48

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: I cant boot with 2.6.14 from testing

sorry, in /etc/lilo.conf I have

initrd=/boot/initrd26.img

Offline

#5 2005-12-12 09:11:16

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: I cant boot with 2.6.14 from testing

I have the same problem after upgrading to 2.6.14.3-2

/bin/sh: cant access tty; job control turned off

I have two options in lilo boot menu: one for auto initrd and one for full initrd.
I cannot boot with any initrd.

My Arch is on VMware so I tried to upgrade few times, each time trying to do something to fix this, but nothing helps.

Is this kernel build broken?


to live is to die

Offline

#6 2005-12-12 16:14:52

Theoden
Member
Registered: 2005-03-03
Posts: 240

Re: I cant boot with 2.6.14 from testing

Looks like the problem I reported quite a while back now is still a problem.  Kinda makes you wonder why no one is finding a fix for it, doesn't it?

--Theoden   :?


"If builders built buildings the way programmers write programs,
the first woodpecker that came along would destroy civilization."

Offline

#7 2005-12-12 17:01:57

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: I cant boot with 2.6.14 from testing

If you get this error message, I'd suggest not using testing for right now unless you are willing to try and diagnose this bug.  It is currently an issue being looked at/worked on.

EDIT: and if you are willing to test this, send me a PM here or on IRC and I can see what's going on (or feel free to email me your initrd images - aaronmgriffin-at-gmail-dot-com)

Offline

#8 2005-12-12 17:16:12

Theoden
Member
Registered: 2005-03-03
Posts: 240

Re: I cant boot with 2.6.14 from testing

Cool!  Nice to hear.  You are the first one I know of to acknowledge this problem and make such a statement.  Thanks.

--Theoden   :?


"If builders built buildings the way programmers write programs,
the first woodpecker that came along would destroy civilization."

Offline

#9 2005-12-12 18:04:19

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: I cant boot with 2.6.14 from testing

Ok, any of you with this problem - please provide your main disk chipsets the output of "lspci" and "hwdetect --ide"

Thanks

Offline

#10 2005-12-12 21:56:35

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: I cant boot with 2.6.14 from testing

I compiled my own kerenl 2.6.14. It is the best way.

Offline

#11 2005-12-12 22:58:55

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: I cant boot with 2.6.14 from testing

NOTE: if you're compiling your own kernel with initrd, please be careful to stick to the default arch config as close as possible - there are some settings which are required to properly work with the initrd stuff.

Offline

#12 2005-12-13 03:42:23

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: I cant boot with 2.6.14 from testing

Samuel, Romashka:

What are the errors/messages above the Busybox stuff when the initrd fails?  Usually there is some error message there to give us a hint at what's failing.

Samuel:  Since you're building a custom kernel, there's no real need to actually build an initrd as well.  The initrd is useful for mass-distributed kernels, as they are easier to adapt to varying configurations.  Since you're customizing a kernel for yourself, you could just build all needed drivers into the kernel and forget this whole initrd business.

Offline

#13 2005-12-13 06:55:00

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: I cant boot with 2.6.14 from testing

Guys, please try regenerating your init ramdisks with the latest version, 1.01-23.  The problem is fixed.

Offline

#14 2005-12-13 18:09:35

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: I cant boot with 2.6.14 from testing

/bin/sh: Can't open auto
Kernal panic - not cyncing: Attempted to kill init!


to live is to die

Offline

#15 2005-12-13 19:04:05

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: I cant boot with 2.6.14 from testing

Hi Romashka,

I'm a little stumped with your problem.  We can look at it further if you take apart that broken initrd and look at the /linuxrc script inside.  You can do it two ways.

1. cat the script from the busybox shell after the initrd bails.

# cat /linuxrc

2. mount the initrd loopback from your working system.

# cp /boot/initrd26.img ./initrd.gz
# gunzip initrd.gz
# mount -o loop initrd /mnt
# cat /mnt/linuxrc

We're interesting in the lines near the end of that script, where it mounts your root device and pivots to it.  Can you share those lines with us?

Offline

#16 2005-12-13 19:17:23

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: I cant boot with 2.6.14 from testing

dumb question are you guys running lilo again after changes to initrd?


Mr Green

Offline

#17 2005-12-13 21:43:37

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: I cant boot with 2.6.14 from testing

Hi apeiro, the initrd support is good for variability, yes.
I decided to compile my own kernel, because I want to learn something about compiling and functions the linux kernel.

I compiled my own kernel 2.6.14 without initrd support.

and Arch linux is great distro (for me).

Sorry, for my english. :-)

Offline

#18 2005-12-13 22:38:09

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: I cant boot with 2.6.14 from testing

Samuel Cengel wrote:

Sorry, for my english. :-)

Your english is as good as mine!

Good to know your problems are fixed, Samuel.

Offline

#19 2005-12-13 23:33:05

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: I cant boot with 2.6.14 from testing

Two months ago I decided to write 3 articles about Archlinux in Slovak language for Slovak/Czech users.

First article is the installation guide in Slovak language.

Articles are published on www.linuxos.sk.

I am very grateful to all peoples from Archlinux team, because this distro is super stuff.

Some peoples send me a email and they are very enthusiastic from Archlinux.

Offline

#20 2005-12-14 08:45:14

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: I cant boot with 2.6.14 from testing

To apeiro:

We can look at it further if you take apart that broken initrd and look at the /linuxrc script inside.

I am wokring in two companies at the same time. smile
Right now I have no access to my VMware machine.
I'll get to my VMware machine today and try the newest mkinitrd. Then if kernel upgrade fails again I'll send you my /linuxrc.

To Mr. Green:

dumb question are you guys running lilo again after changes to initrd?

yes

I do the following steps:
pacman -Syuf
(mkinitrd runs automatically during kernel install)
lilo

In lilo menu I have two options: one boots initrd26.img, and another boots initrd26-full.img
None is working.


to live is to die

Offline

#21 2005-12-14 13:14:17

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: I cant boot with 2.6.14 from testing

It seems I found the reason:
when booting kernel says:

mount: Mounting 303 on /new_root failed: No such device

Shouldn't it be /dev/hda3?
But when I checked /proc/cmdline on working VMware machine with older kernel and initrd it says:

auto BOOT_IMAGE=arch ro root=303

How to explain this???


to live is to die

Offline

#22 2005-12-14 15:09:53

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: I cant boot with 2.6.14 from testing

I wonder what has changed in new kernel that caused such problem.
The newest mkinitrd didn't help.
Any ideas?


to live is to die

Offline

#23 2005-12-14 15:53:52

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: I cant boot with 2.6.14 from testing

I have tried mkinitrd-1.01-23 with older kernel 2.6.14.3-1
and found that the problem is in mkinitrd not in the kernel!
Judd, please fix it!


to live is to die

Offline

#24 2005-12-14 16:23:26

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: I cant boot with 2.6.14 from testing

Samuel Cengel wrote:

Two months ago I decided to write 3 articles about Archlinux in Slovak language for Slovak/Czech users.

First article is the installation guide in Slovak language.

Articles are published on www.linuxos.sk.

I'd say it was a good article, but I have no idea what it says  lol

Romashka wrote:

I have tried mkinitrd-1.01-23 with older kernel 2.6.14.3-1
and found that the problem is in mkinitrd not in the kernel!
Judd, please fix it!

Ok, can you please enlighten us further - please provide your disc specs (IDE, SATA, SCSI, etc) along with your grub/lilo configs.  Also, did you try the full image, auto image, or both?  Can you provide us with your mkinitrd.conf file as well?

Offline

#25 2005-12-14 16:45:14

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: I cant boot with 2.6.14 from testing

To phrakture: Yeah, you will try to learn Slovak language  roll and I will try to learn English, more.

To judd: http://www.zeroflux.org/pics/jam1/IMG_0357.jpg  it is a very very very pretty girl, so beautiful smile.  big_smile

sorry for this link, forum is about linux, but smile is nice.

Offline

Board footer

Powered by FluxBB