You are not logged in.

#1 2013-03-13 10:38:29

zoran119
Member
Registered: 2009-03-10
Posts: 23

Synaptics touchpad is too sensitive

When I move the mouse pointer to the position I want (on a link for example) and then move my finger of the touchpad (so that I can click the link by tapping the touchpad) the cursor moves quite a bit... off the link I was trying to click. This is quite annoying (clicking wrong links, having to move the pointer back onto the link...) and happens quite often. Anything I can do to fix this?

Offline

#2 2013-03-13 10:45:00

brebs
Member
Registered: 2007-04-03
Posts: 3,401

Re: Synaptics touchpad is too sensitive

Yes, see wiki.

Offline

#3 2013-03-13 10:59:15

zoran119
Member
Registered: 2009-03-10
Posts: 23

Re: Synaptics touchpad is too sensitive

I had a look there and could not find anything to help me... I installed gsynaptics and tried different settings but nothing helped.

Offline

#4 2013-03-13 18:19:21

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: Synaptics touchpad is too sensitive

Option "CoastingSpeed" "0"

did the trick for me.

See notes at https://wiki.archlinux.org/index.php/Sy … ed_options

Offline

#5 2013-03-14 11:21:17

zoran119
Member
Registered: 2009-03-10
Posts: 23

Re: Synaptics touchpad is too sensitive

CoastingSpeed didn't help... I don't think that is the issue I am experiencing anyway. I cannot touch the touchpad with my finger (and move it off the touch pad) without the mouse pointer moving quite a few pixels. So annoying!

Offline

#6 2013-03-14 12:02:11

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,835

Re: Synaptics touchpad is too sensitive

Try playing with HorizHysteresis and VertHysteresis. synclient will give you the current values, go up in small amounts.

man synaptics for details.

Offline

#7 2013-03-15 22:02:21

zoran119
Member
Registered: 2009-03-10
Posts: 23

Re: Synaptics touchpad is too sensitive

tomk wrote:

Try playing with HorizHysteresis and VertHysteresis. synclient will give you the current values, go up in small amounts.

man synaptics for details.

Awesome! That solved my problem!

Offline

#8 2013-04-21 15:41:43

tictoerest
Member
Registered: 2013-03-14
Posts: 3

Re: Synaptics touchpad is too sensitive

I'm having the same issue.  I thought maybe this hysteresis settings would help but they really don't.  My touchpad is very jerky, not smooth at all.  If I just move my finger in a straight line I get these small deviations in movement.  When I messed with the hysteresis settings all it did was restrict my movement, but I still get this jerkyness.

Last edited by tictoerest (2013-04-21 15:42:14)

Offline

#9 2013-04-30 18:54:20

suridaj
Member
Registered: 2013-04-30
Posts: 4

Re: Synaptics touchpad is too sensitive

tictoerest wrote:

I'm having the same issue.  I thought maybe this hysteresis settings would help but they really don't.  My touchpad is very jerky, not smooth at all.  If I just move my finger in a straight line I get these small deviations in movement.  When I messed with the hysteresis settings all it did was restrict my movement, but I still get this jerkyness.

Same here. The xy hysteresis is really not good for precision...

I have solved the jittery touchpad by putting the following in /etc/X11/xorg.conf.d/51-mysynaptics.conf :

Section "InputClass"
        Identifier "Prevent jumpy touchpad pointer"
        MatchIsTouchpad "on"
        Option "MinSpeed" "0"
        Option "ConstantDeceleration" "5"
EndSection

MinSpeed equal to zero allows for fine, precise motion. ConstantDeceleration makes the slow motions even slower which suppresses the pointer twitches when you're tapping or just trying to hold it still. In my case I have it set to 5. You should probably play with the value to get it just right, for instance by using xinput:

$ xinput --set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 5

EDIT: spelling + xinput.

Last edited by suridaj (2013-04-30 19:02:55)

Offline

#10 2013-06-05 23:05:41

dillius
Member
Registered: 2013-06-05
Posts: 1

Re: Synaptics touchpad is too sensitive

I'm having a similar problem with a Thinkpad.

I have tried using synclient to manipulate...

MinSpeed
VertScrollDelta
HorizScrollDelta
CoastingSpeed
CoastingFriction
HorizHysteresis
VertHysteresis
FingerLow
FingerHigh

...and regardless of what I do my pointer still flies across the screen at absolutely insane speeds.

Offline

#11 2013-06-05 23:11:12

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,270

Re: Synaptics touchpad is too sensitive

I have better luck just building a config file.

ewaller$@$odin ~ [1]1007 %cat /etc/X11/xorg.conf.d/50-synaptics.conf
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "CircularScrolling" "true"
        Option "CircScrollTrigger" "3"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
        MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on
# non-synaptics clickpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection

What environment are you using?  Gnome and KDE have their own control panels.  Other full featured DEs may as well. 
Are you sure it is being seen as a touchpad?  Could it be in mouse emulation mode?  Take a look in your /var/log/Xorg.0.log file and make sure it is being treated as a tablet and that evdev knows about it.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#12 2013-06-05 23:14:42

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Synaptics touchpad is too sensitive

@ewaller... that looks an awful lot like the default file shipped with xf86-input-synaptics.  Are you posting it to show changes? If so, could you point them out?

Offline

#13 2013-06-05 23:24:59

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,270

Re: Synaptics touchpad is too sensitive

WonderWoofy wrote:

@ewaller... that looks an awful lot like the default file shipped with xf86-input-synaptics.  Are you posting it to show changes?

No wink 
I was trying to point out that one can put the file that comes in /usr/share/X11/xorg.conf.d/50-synaptics.conf into /etc/X11/xorg.conf.d and play to ones hearts content without having to rely on the sometimes broken shared configuration memory interface. 

If so, could you point them out?

ewaller$@$odin /etc/X11/xorg.conf.d 1011 %diff $(locate 50-synaptics)
14,18d13
<         Option "TapButton1" "1"
<         Option "TapButton2" "2"
<         Option "TapButton3" "3"
<       Option "CircularScrolling" "true"
<       Option "CircScrollTrigger" "3"
22c17
<         MatchDevicePath "/dev/input/event*"
---
> #       MatchDevicePath "/dev/input/event*"
31,48d25
< EndSection
<
< # This option enables the bottom right corner to be a right button on
< # non-synaptics clickpads.
< # This option is only interpreted by clickpads.
< Section "InputClass"
<         Identifier "Default clickpad buttons"
<         MatchDriver "synaptics"
<         Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
< EndSection
<
< # This option disables software buttons on Apple touchpads.
< # This option is only interpreted by clickpads.
< Section "InputClass"
<         Identifier "Disable clickpad buttons on Apple touchpads"
<         MatchProduct "Apple|bcm5974"
<         MatchDriver "synaptics"
<         Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
ewaller$@$odin /etc/X11/xorg.conf.d [1]1012 %

It looks like I've some older cruft in mine that I should clean out (ewaller hangs his head in shame).  I seem to like the default speeds, I like tap click, and I love circular scrolling.

Edit:  I should point out, I did have some problems with the evdev matching, so I enabled the device path matching in addition to the class matching.  When that failed, my touchpad was not being seen by evdev, and the result was a mouse driver stepped up and took over.  That may be the root of the current problem.

Last edited by ewaller (2013-06-05 23:28:27)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#14 2015-11-08 03:54:30

hankyplanky
Member
Registered: 2015-11-08
Posts: 1

Re: Synaptics touchpad is too sensitive

Setting HorizHysteresis and VertHysteresis higher make the touchpad less responsive and only partially help with the oversensitivity. Those properties just make scrolling opposite of the direction your mouse was headed take more effort which gives the appearance of reducing jitter, but when moving the same direction the sensitivity is still present.

I solved the problem by running:

synclient FingerHigh=110 FingerLow=100

This increases the pressure necessary to register touch.

Offline

Board footer

Powered by FluxBB