You are not logged in.

#1 2013-04-08 15:24:17

jones
Member
Registered: 2013-03-14
Posts: 86

[SOLVED] Fresh install - German umlaute do not work

Hello,

I have just successfully booted into my brand new arch install. So, upon first boot, everything was displayed in Lat2-Terminus16 since I set that up in vconsole.conf, like it said in the beginners' guide. For everything related to generating the locale-files, I simply followed the relevant BG part as well!

First things I did was:
-add my own user and set his password
-then (still as root):

pacman -S sudo
nano /etc/pacman.conf
[uncomment multilib line, see https://wiki.archlinux.org/index.php/Multilib]
pacman -Syy
mv /etc/pacman.conf /etc/pacman.conf.backup
mv /etc/pacman.conf.pacnew /etc/pacman.conf
nano /etc/pacman.conf
[uncomment multilib line, see https://wiki.archlinux.org/index.php/Multilib]
pacman -Syy
pacman -Syu

So, basically whenever a German umlaut was displayed, it showed me the following:

Same goes for enterin, when I hit the key it shows me the characters listed above.

No clue what is wrong. Did I make an error along the way?

Last edited by jones (2013-07-14 11:06:13)

Offline

#2 2013-04-08 15:46:57

mzneverdies
Member
Registered: 2012-02-04
Posts: 147

Re: [SOLVED] Fresh install - German umlaute do not work

echoing LANG could be useful, to check the locale
example:

[mz@gantz ~]$ echo $LANG
es_ES.UTF-8

if the locale are what they are supposed to be (de_DE.UTF-8 UTF-8 ?), then no clue smile

Offline

#3 2013-04-08 15:50:01

jones
Member
Registered: 2013-03-14
Posts: 86

Re: [SOLVED] Fresh install - German umlaute do not work

mzneverdies wrote:

echoing LANG could be useful, to check the locale
example:

[mz@gantz ~]$ echo $LANG
es_ES.UTF-8

if the locale are what they are supposed to be (de_DE.UTF-8 UTF-8 ?), then no clue smile

Oh, yes, I set that variable to de_DE.UTF-8 UTF-8. Damn forgot to mention that, will edit the op. Thanks.

Offline

#4 2013-04-08 16:44:32

jacobopantoja
Member
From: Madrid
Registered: 2011-03-16
Posts: 44

Re: [SOLVED] Fresh install - German umlaute do not work

Post the output of

localectl

If you haven't I recommend you to give a quick read to how systemd handles locales
https://wiki.archlinux.org/index.php/Systemd#Locale
I find that following systemd wiki for fresh installs is better, because the BG is a bit out-dated. Feel free to improve it.

Offline

#5 2013-04-11 12:29:02

rix
Member
Registered: 2012-07-25
Posts: 221

Re: [SOLVED] Fresh install - German umlaute do not work

Also post the entire vconsole.conf and let us know how did you set your keyboard layout.

Offline

#6 2013-06-08 13:46:16

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,058
Website

Re: [SOLVED] Fresh install - German umlaute do not work

I made a bugreport about this after having the same issue.
https://bugs.archlinux.org/task/35721

Offline

#7 2013-07-12 12:42:37

jones
Member
Registered: 2013-03-14
Posts: 86

Re: [SOLVED] Fresh install - German umlaute do not work

The problem still exists with 2013.07.

# echo $LANG
de.DE-UTF8
# localectl
System Locale: LANG=de_DE.UTF-8
VC Keymap: de-latin1
X11 Layout: n/a
# nano /etc/vconsole.con
[KEYMAP=de-latin1
[FONT=Lat2-Terminus16

What does

Loading a framebuffer driver will cause a reset, so you'll lose all settings. The better solution here is to load the framebuffer console driver (i915 in your case) from initramfs. Maybe our autodetect hook should just include such drivers by default.

exactly mean? This suggestion was provided in teateawhy's bug report by Jan de Groot and I think it related to mkinitcpio.
=> So I should add i915 as a hook to mkinitcpio.conf?

Last edited by jones (2013-07-12 12:53:00)

Offline

#8 2013-07-12 17:32:51

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED] Fresh install - German umlaute do not work

No, there is no i915 hook. The discussion in the bug report relates to finding a universal solution, i.e. a new hook.
You can add "i915" as a module to be included explicitly in mkinitcpio: https://wiki.archlinux.org/index.php/KM … _KMS_start
Yet, I'm not sure you really need to (I don't at least).

edit: Thought I add this (yes, I mix English desktop with German keyboard):

$ cat locale.conf
LOCALE=en_US.UTF-8
LANG=de_DE.UTF.8
LC_MESSAGES=C
LC_COLLATE=C 
LC_ALL=
cat vconsole.conf 
KEYMAP=de-latin1-nodeadkeys
#FONT=cp850-8x16
#FONT_MAP=8859_1_to_uni

Last edited by Strike0 (2013-07-12 17:39:59)

Offline

#9 2013-07-14 10:58:52

jones
Member
Registered: 2013-03-14
Posts: 86

Re: [SOLVED] Fresh install - German umlaute do not work

The keyboard layout still doesn't work. hmm
I am using a radeon card so added 'radeon' as a module instead but it didn't help.
The rest of the keyboard layout is off as well but it does not fully match the typical QWERTY layout. Don't really know what to do here. sad

Last edited by jones (2013-07-14 10:59:51)

Offline

#10 2013-07-14 11:05:50

jones
Member
Registered: 2013-03-14
Posts: 86

Re: [SOLVED] Fresh install - German umlaute do not work

SOLUTION

sudo leafpad /etc/X11/xorg.conf.d/20-keyboard.conf

(or nano instead of leafpad)
and enter this:

Section "InputClass"
        Identifier "keyboard"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection

Offline

#11 2013-07-14 12:43:13

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED] Fresh install - German umlaute do not work

Hm, ok. I never got your thread is about configuring the keyboard for X. 
Good you solved it anyhow.

Offline

#12 2013-07-14 17:33:02

jones
Member
Registered: 2013-03-14
Posts: 86

Re: [SOLVED] Fresh install - German umlaute do not work

Oh ok, well. With writing "The keyboard layout still doesn't work. " I meant that I tried what you suggested 1:1 except for the i915 module (as my mainboard does not use any Intel graphics module, the graphics mode is set to PCI Express = radon card) and logged out and back in... but forgot that the display of characters is only half of the equation. As I wrote in the op, I wanted to solve the problem of enterting the characters as well. smile Thank you though for the other part. smile

Last edited by jones (2013-07-14 17:33:40)

Offline

Board footer

Powered by FluxBB