You are not logged in.

#1 2013-06-08 09:16:06

momo.reina
Member
Registered: 2012-02-23
Posts: 66

[SOLVED]Arch not booting properly

I just did the /bin /sbin integration into /usr/bin required for the latest pacman update.

Now Arch is suddenly booting into a minimal GNU GRUB shell...

I've tried chroot-ing into the HD and rerunning the update plus the mkinitcpio command, no luck. Anyone else have this issue? Any solutions? It just seems like the bootloader is not working for some reason...

Last edited by momo.reina (2013-06-08 15:10:14)

Offline

#2 2013-06-08 09:17:47

jelly
Trusted User (TU)
From: /dev/null
Registered: 2008-06-10
Posts: 711

Re: [SOLVED]Arch not booting properly

Does the symlink for /bin and /sbin exists?

Offline

#3 2013-06-08 12:58:02

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,354

Re: [SOLVED]Arch not booting properly

Specific errors, please

Offline

#4 2013-06-08 14:33:29

momo.reina
Member
Registered: 2012-02-23
Posts: 66

Re: [SOLVED]Arch not booting properly

Scimmia wrote:

Specific errors, please

There are no specific errors, it just drops me in a GNU GRUB shell.

jelly wrote:

Does the symlink for /bin and /sbin exists?

/bin and /sbin both point to /usr/bin, /lib and /lib64 point to /usr/lib

It doesn't even give me the choice between normal Arch and Recovery/Fallback mode... just straight into this strange shell.

Offline

#5 2013-06-08 15:09:50

momo.reina
Member
Registered: 2012-02-23
Posts: 66

Re: [SOLVED]Arch not booting properly

So I re-installed the bootloader (syslinux), and systemd-sysvcompat. Also added init=/bin/init to the kernel line. Everything is working now.

Has anyone had a similar experience when doing the /bin -> /usr/bin integration or is my system just a screw up?

Offline

#6 2013-06-08 15:26:53

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,354

Re: [SOLVED]Arch not booting properly

Wait a minute, re-installed syslinux, but you were dropped to a grub prompt? I'm guessing you were using grub 0.97 before the update and tried to upgrade to syslinux? If so, it sounds like the upgrade was incomplete and with no grub.cfg, grub didn't know what t to do.

Offline

#7 2013-06-08 16:25:53

momo.reina
Member
Registered: 2012-02-23
Posts: 66

Re: [SOLVED]Arch not booting properly

Scimmia wrote:

Wait a minute, re-installed syslinux, but you were dropped to a grub prompt? I'm guessing you were using grub 0.97 before the update and tried to upgrade to syslinux? If so, it sounds like the upgrade was incomplete and with no grub.cfg, grub didn't know what t to do.

I was using grub before the update, after the update I was getting dropped into the grub shell. I installed syslinux instead of re-installing grub on a whim, this was after the bootloader stopped working so it had nothing to do with the failed boot attempts.

Offline

#8 2013-06-08 18:50:37

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,354

Re: [SOLVED]Arch not booting properly

The update wouldn't install with grub 0.97 installed. How did you get past that error? Or are we taking about grub2 here?

Last edited by Scimmia (2013-06-08 19:03:58)

Offline

Board footer

Powered by FluxBB