You are not logged in.

#1 2013-06-10 08:08:57

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

[SOLVED] urxvt and xterm segfault after system upgrade

Hi,

I survived system upgrade with moving the bin directories, as well as upgrading to syslinux from grub-legacy.

The only problem is urxvt and even xterm segfaults when launched? I tried renaming .XDefaults but that didn't help.

Thanks in advance.

EDIT:

Just installed rxvt, which works?

Last edited by dumas (2013-06-13 12:24:49)


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#2 2013-06-13 10:51:26

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] urxvt and xterm segfault after system upgrade

It's so sad to not have a proper terminal sad


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#3 2013-06-13 11:39:45

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,787
Website

Re: [SOLVED] urxvt and xterm segfault after system upgrade

strace could be handy.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2013-06-13 12:07:42

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] urxvt and xterm segfault after system upgrade

Thanks, didn't know strace before.

strace showed some libs weren't compatible, which I related to this thread

https://bbs.archlinux.org/viewtopic.php … 0#p1285990

Sure enough, while the newest rxvt-unicode package is 9.18-5, I was synced to 9.18-3.

Manually downloading the newest package and installing worked.

But back to the question: what is wrong with my package management?


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#5 2013-06-13 12:16:21

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,787
Website

Re: [SOLVED] urxvt and xterm segfault after system upgrade

9.18-5 is the current version in the repos.  Either you are using pacman incorrectly, or you have an out of date mirror.  Try `pacman -Syyu` to see if you get updates, if not, edit your mirror list and chose better mirrors, reflector is a good tool to help with this.

EDIT: 9.18-5 has been in the repos since well before the bin move.  So it would seem you did not successfully manage that update.

Last edited by Trilby (2013-06-13 12:17:44)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#6 2013-06-13 12:24:33

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] urxvt and xterm segfault after system upgrade

Thanks for the quick response, but as I said in the other post, something is not right with my syncing.

I'll mark this thread as solved, the other thread still has problem.


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

Board footer

Powered by FluxBB