You are not logged in.

#1 2013-06-10 09:41:41

Registered: 2013-05-30
Posts: 18

Mounting UEFI partition failing at boot


My PC worked well until today, after an update (pacman -Syu). Now I cannot boot any more. The error message is:

systemd-fsck[214]: dosfsck 3.0.17, 29 May 2013, FAT32, LFN
[  OK  ] Started File System Check on /dev/disk/by-uuid/FED1-CCC8.
systemd-fsck[212]: /dev/sda1: 59 files, 5563/130812 clusters
         Mounting /boot/efi...
[FAILED] Failed to mount /boot/efi.

Then after the system is completely blocked, I cannot enter the root password nor press Ctrl+D.

Booting from DVD, everything is correct: I can mount sda2 on /mnt, sda1 on /mnt/boot, sda4 on /mnt/home then swapon sda3, and finally arch-chroot /mnt /usr/bin/bash.

Any idea to unblock me?


#2 2013-06-10 14:38:21

Registered: 2013-05-30
Posts: 18

Re: Mounting UEFI partition failing at boot

This is not obvious. I finally switched to BIOS instead of UEFI and it works now. I know I forgot to update EFI through systemd when the kernel is updated, this is maybe the reason. But I've been unable to solve the UEFI problem.

Problem solved (don't know how to set in title).


Last edited by zorggy (2013-06-10 14:40:31)


#3 2013-06-10 17:39:52

From: .nz
Registered: 2009-05-09
Posts: 25,035

Re: Mounting UEFI partition failing at boot

To mark a thread as [Solved], just edit your first post and prepend it to the title.

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438


#4 2013-06-15 16:16:53

Registered: 2012-05-16
Posts: 1

Re: Mounting UEFI partition failing at boot


I had the same error as zorggy after the last update and since the thread is not officially marked as [SOLVED] I decided to post my experience as I have found a different solution.

I'm booting using efistub and a efibootmgr entry and I use systemd to sync the EFISTUB kernel and initramfs files at boot.

As I said, I had the same error as zorggy when rebooting after my last update. I booted from DVD and looking at the /boot and /boot/efi/EFI/arch I realised that the kernel and initramfs files were not updated like they were supposed to (the files in  /boot/efi/EFI/arch were older than the ones in /boot) so I just manually copied the new files in the right place and everything works without the need to switch to BIOS.

OK I just figured out what happened, the /usr/lib/systemd/system/efistub-update.service script described in the wiki needs to be updated because of the move to /usr/bin. Basically it points to /bin/cp but this command has moved to /usr/bin/cp so I think the file should be modified to look like this :

Description=Copy EFISTUB Kernel to UEFISYS Partition

ExecStart=/usr/bin/cp -f /boot/vmlinuz-linux /boot/efi/EFI/arch/vmlinuz-arch.efi
ExecStart=/usr/bin/cp -f /boot/initramfs-linux.img /boot/efi/EFI/arch/initramfs-arch.img
ExecStart=/usr/bin/cp -f /boot/initramfs-linux-fallback.img /boot/efi/EFI/arch/initramfs-arch-fallback.img

So I don't know if my problem was the same as zorggy's, but if it's the case I think this thread should be moved to Pacman & Package Upgrade Issues since it is directly linked to the move to /usr/bin. Or maybe I should just open another thread in that section.

I would also like to update the wiki but I'm not sure if a warning should added in the wiki telling people to update their file or if I should just change the code section.


P.S.  I've used Arch for around 3 years but this is the first time I feel I had enything usefull enough to post to the forums, let me know if I'm out of line. I'm "just shy not antisocial" as XKCD would put it.

Last edited by femtomatic (2013-06-15 19:15:42)


Board footer

Powered by FluxBB