You are not logged in.

#1 2013-06-13 15:29:13

Depado
Member
Registered: 2013-02-28
Posts: 48

[SOLVED] GDM Doesn't want to start [Fresh Install]

Hi,
I'm installing Arch on my gf laptop and I got a little issue that I don't know how to solve.
I installed xorg (xorg-server, xorg-xinit, xorg-settings (or something like that) and then installed the whole gnome and gnome-extra package group.
Then I installed the driver xf86-video-intel.
I then typed

systemctl enable gdm.service

The problem is that the boot screen stops after the [OK] Starting GDM.

I can start the session using startx. But I don't seem to be able to launch gdm.
I tried to set the driver option to "sna" but it doesn't work either.

Does anyone have the same issue ?
Thanks :x

UP
After a few researches, here is some new information :

systemctl status gdm.service

Starting Gnome Display Manager
Started Gnome Display Manager
Failed to give slave programs access to the display. Trying to proceed.
GdmLauncherEnvironment: Unknown user gnome-initial-setup
GdmDisplay: display lasted 0.4 seconds

Edit : FYI It's not a problem of symlink during the "enable" phase.

SOLVED by adding a user. Stupid me.

Last edited by Depado (2013-06-14 09:42:31)

Offline

#2 2013-06-13 17:20:29

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 331

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

After the 'systemctl enable gdm.service' did you had a output where gdm.service was linked to displaymanager.service?

Did you check /etc/systemd/system/display-manager.service for its contents and if it is linked?

If not linked, you can try

systemctl -f enable gdm.service

as mentioned here.

Last edited by henk (2013-06-13 17:21:55)

Offline

#3 2013-06-13 17:29:13

Depado
Member
Registered: 2013-02-28
Posts: 48

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

I didn't have an output the first time I tried to enable gdm. It didn't change anything to -f the enable...
In my display-manager.service I got a unit describing Gnome Display Manager so I guess the link was successful.

Any other idea ?

Offline

#4 2013-06-13 17:47:45

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 331

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

No output about linking to displaymanager meens no actual linking at that time.
In the link I provided:

"systemctl enable" will try to symlink gdm.service to /etc/systemd/system/display-manager.service. My guess is this symlink already 
exists and systemd fails to overwrite this for some reason 

Further down it is solved with the command I gave you, because it forces ( -f) a overwrite of the displaymanager.service.

Offline

#5 2013-06-13 17:49:48

Depado
Member
Registered: 2013-02-28
Posts: 48

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

I removed display-manager.service and retried. There was an output but the problem is still there, I can't start gdm...
The output is :

ln -s '/usr/lib/systemd/system/gdm.service' '/etc/systemd/system/display-manager.service'

Last edited by Depado (2013-06-13 17:51:27)

Offline

#6 2013-06-13 18:00:50

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,966

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

Did you test X? https://wiki.archlinux.org/index.php/Be … ide#Test_X

Nevermind, missed that part of the OP.

Last edited by Scimmia (2013-06-13 18:02:35)

Offline

#7 2013-06-13 18:01:07

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 331

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

Try it with a reboot. I remember my net-auto-wired.service wouldn't start until I did a reboot.
If it is still not working, login, and do

 systemctl status displaymanager.service

Offline

#8 2013-06-13 18:03:29

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 331

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

he can start the session with startx he mentioned.

Offline

#9 2013-06-13 18:29:53

Depado
Member
Registered: 2013-02-28
Posts: 48

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

A reboot doesn't affect the problem.

Here is the output of

systemctl status display-manager
GdmLaunchEnvironment: Unknown user gnome-initial-setup
GdmDisplay: display lasted 0.68 seconds
Child Process 369 was already dead
# And then the errors I gave below for Gdm service.
GdmLocalDisplayFactory: maximum number of X display failures reached : check X server log for errors

Offline

#10 2013-06-13 19:14:30

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 331

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

I'am a bit at the end of what might be your problem. I'am not using gnome or gdm myself.

I've searched a bit on the "Unknown user gnome-initial-setup", and that got me to the question:
Have you added a user already?
https://wiki.archlinux.org/index.php/GDM#GDM_root_login

It's a wild guess, after this I'm done. If it will not work, the last thing I can do is to propose lxdm.

Offline

#11 2013-06-13 19:27:39

Depado
Member
Registered: 2013-02-28
Posts: 48

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

Yep I added a user. Just after the reboot from the livecd to the stable system.
Thanks a lot anyway you helped me a lot, I learned some things I didn't know ^^

Offline

#12 2013-06-13 19:35:24

Depado
Member
Registered: 2013-02-28
Posts: 48

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

Hey there, I'm stupid.
My user was not created I don't know what happened. Adding a user solved the problem... Well you're my hero of the day. Thanks a lot.

Offline

#13 2013-06-14 04:49:41

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 331

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

Good morning,
very happy to see you got it working.
You could still mark this thread as [SOLVED].

Offline

#14 2013-06-14 09:42:59

Depado
Member
Registered: 2013-02-28
Posts: 48

Re: [SOLVED] GDM Doesn't want to start [Fresh Install]

I edited my post but forgot to mark it as solved. Thanks again smile

Offline

Board footer

Powered by FluxBB