You are not logged in.

#1 2013-06-13 15:04:03

JohnnySSH
Member
Registered: 2013-05-04
Posts: 75

Unable to boot from Grub 2.00 file not found errors on 32bit

Hi,

I've recently installed Archlinux on to an old laptop which is round 10 years old or so.....

Having done many 64bit installs and all of them going through smoothly this is kind of puzzling.

The installation went through as normal with using: https://wiki.archlinux.org/index.php/Installation_Guide as reference which is generally perfect.


Unfortunately Grub 2,00 is comming up with errors claiming:

error file all_video.mod not found
error file minix3_be.mod not found
error file relocator.mod not found
error no such device <UUID>
Press Any Key to Continue

However it is loading the kernel and initial ramdisk!!

The machine has an old 80GB IDE hard drive inside so perhaps something extra needs to be done with that?

Strange though that all "missing" files above are actually in the /boot/grub/i386-pc directory.

At first I thought something got borked during the download/install of grub2 so I reinstalled it and again same errors; then I rebuilt the whole system and again same errors; I also tried copying the i386-pc directory over from another machine and again same errors..... :-(


What is going on and is there a fix for this?


It seems like something restricted to the 32bit build as I've never had an issue with 3 64bit machines that I've built recently, though I'm using the latest install/boot media and the rest is fetched via HTTP anyway.


Could anyone give me a hand?


Many thanks.

[EDIT]

I did drop down to the Grub command prompt and try to manually load the system and again it can't find the modules using "insmod" even though they are listed when tryping:

set pager=1
ls (hd0,1)/boot/grub/i386-pc

Last edited by JohnnySSH (2013-06-13 15:06:17)

Offline

#2 2013-06-17 18:37:27

sup
Member
From: Earth
Registered: 2010-09-11
Posts: 21

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

I can second this error on a new installation. I too have installed arch dozens of times and have never run into this (in fact I have arch running from another drive in the same computer and it's still booting just fine). But, unlike above, the installation giving me this error is on a drive that is only a year old and I have installed arch on it before with no problems. I can confirm that the files it says it can't find are in fact on the drive.

It's a JFS root on a grub-bios (64-bit) GPT install. The only thing I did differently from the last time I used this drive was not have /boot on it's own partition. Could that be a problem? I have the correct BIOS boot partition for grub as the first partition. Not sure what's wrong.

Last edited by sup (2013-06-17 19:03:56)

Offline

#3 2013-06-17 22:54:54

JohnnySSH
Member
Registered: 2013-05-04
Posts: 75

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

I figured out a workaround for this issue, though not a solution.

Basically I installed Lilo from the AUR.... the only issue with that is that the lilo.conf file kept auto changing the HD from /dev/sda1 to /dev/hda1 (IDE drive).

I then basically had to force it by editing the config file then running:

lilo -b /dev/sda

From then on it worked and the system boots but I presume this is a bug??

Out of 4 laptops built recently (3x 64bit), all the 64bit systems are fine... they all run JFS too with no separate "/boot" partition.

Offline

#4 2013-06-17 23:03:47

sup
Member
From: Earth
Registered: 2010-09-11
Posts: 21

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

I suppose I'll try a different file system. If I remember correctly from my Slackware days, Lilo isn't robust enough for my setup. I may try syslinux as well.

It definitely seems to be a new thing as I don't see this error reported anywhere else.

Last edited by sup (2013-06-17 23:06:36)

Offline

#5 2013-06-17 23:10:16

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

@sup, your problem is totally different from what JohnnySSH describes above.  But since he has found a solution to his problem, I guess you can't really hijack the thread.  So are you certain that grub supports jfs?  I know it supports quite a bit, but I am not certain about jfs.  Also, I am not sure why Lilo wouldn't be "robust enough for (your) setup".  That makes little to no sense to me.  I have no idea what you mean by "robust" unless you are talking about some of the more ridiculous things that grub can do, like have /boot on an lvm or an mdadm.  But if Lilo did not meet your needs, I can gaurantee that syslinux will certainly not.

Offline

#6 2013-06-17 23:14:41

Nielskep
Member
Registered: 2011-01-04
Posts: 9

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

I wanted to make new post, but I am actually also suffering from this issue ..
Fresh install according to the guide :
started with gdisk the hard disk, putting too large boot partition (I know) and not giving it a FS.
mounted everything (but cannot mount the boot then)
pacstrap & fstab generated & chrooted
some smaller steps till mkinitcpio
installing grub-bios
executed grub-install --target=i386-pc --recheck --debug /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
rebooted and got into the grub menu.

But .. afterwards ?boot?grub?i386-pc/relocator.mod? not found and it jumps back to the menu?

Any help appreciated, do I need to copy paste some files here?

Offline

#7 2013-06-17 23:20:53

sup
Member
From: Earth
Registered: 2010-09-11
Posts: 21

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

WonderWoofy, as I am currently writing this on an arch install that is all JFS and boots with GRUB, yes, GRUB supports JFS. I was done with this thread. Not sure why you decided to show up just to be rude.

Offline

#8 2013-06-17 23:24:21

JohnnySSH
Member
Registered: 2013-05-04
Posts: 75

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

@WonderWoofy

So are you certain that grub supports jfs?

I am definitely confident as the machine I'm typing from now is Archlinux + JFS + Grub2 -- though 64 bit

insmod jfs

...oops @sup got there before me :-)

@Nielskep that is the issue that I had!! Install Lilo as described from AUR

https://wiki.archlinux.org/index.php/LILO

Offline

#9 2013-06-17 23:28:23

Nielskep
Member
Registered: 2011-01-04
Posts: 9

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

okay, but before going to LILO I would like to understand what's happening here and what I am doing wrong with Grub..

Offline

#10 2013-06-17 23:33:59

JohnnySSH
Member
Registered: 2013-05-04
Posts: 75

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

I understand completely! Unfortunately I don't have an answer as I'm quite new to Archlinux myself however, from the Wiki guide it should just be a case of:

install-grub /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg 

Any boot adjustments should be done in /etc/grub.d/ which I'm sure you're aware of.


Ok.... that was weird; I think some updates just cleared Grub off the system I'm typing from??

Had to re-install through Pacman though I hope I don't end up with the same errors as on my 32-bit otherwise I will scream... since I'm triple booting this machine with Sabayon Linux and FreeBSD 9 :-S

Offline

#11 2013-06-19 17:40:25

mcmilton
Member
Registered: 2011-11-14
Posts: 12

Re: Unable to boot from Grub 2.00 file not found errors on 32bit

I've got the same issue when I moved from the legacy grub to grub 2. I have 64bit system, JFS for the root partition.

The booting stops with the message "error file relocator.mod not found". Two other error messages (about all_video.mod and minix3_be.mod do not appear, since, I guess, I use the text mode for grub. The workaround which works for me is using Live USB with Ubuntu 12.04. I boot my laptop from this USB stick, then mount root partition: "mount /dev/sda6 /mnt" (my root partition with Arch Linux is in sda6). Then I install grub: "grub-install --root-directory=/mnt/ /dev/sda" And that is it. The system boots.

But, the grub which boots the system is not from Arch. This grub comes from Ubuntu USB stick and its version is 1.99 (it is shown at boot screen), while the version of the current Arch Grub is 2.00-2. So it looks like a regression of a newer version of grub.

Offline

Board footer

Powered by FluxBB