You are not logged in.

#1 2013-06-19 17:24:40

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

lightdm didnt start gnome

I just booted my laptop and left it for a while and tried to login to gnome from lightdm a bit later and nothing happened.

Usually when logging into gnome from lightdm the cursor will switch from the lightdm mouse cursor to the gnome mouse cursor, this didn't happen when it failed and I was left with a blank black screen and the lightdm mouse cursor.

Here is journal output:
You can see from when I booted (Jun 19 18:34:51 to Jun 19 18:48:52) and when I came back to login (un 19 19:16:32 onwards)

Jun 19 18:34:51 jason-laptop dhcpcd[306]: wlan0: no IPv6 Routers available
Jun 19 18:34:59 jason-laptop NetworkManager[133]: <info> (wlan0): IP6 addrconf timed out or failed.
Jun 19 18:34:59 jason-laptop NetworkManager[133]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Jun 19 18:34:59 jason-laptop NetworkManager[133]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Jun 19 18:34:59 jason-laptop NetworkManager[133]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Jun 19 18:38:05 jason-laptop systemd[1]: Time has been changed
Jun 19 18:48:51 jason-laptop systemd[1]: Starting Cleanup of Temporary Directories...
Jun 19 18:48:52 jason-laptop systemd[1]: Started Cleanup of Temporary Directories.
Jun 19 19:16:32 jason-laptop lightdm[223]: pam_unix(lightdm-greeter:session): session closed for user lightdm
Jun 19 19:16:32 jason-laptop lightdm[284]: pam_unix(lightdm:session): session opened for user jason by (uid=0)
Jun 19 19:16:33 jason-laptop systemd-logind[136]: New session 1 of user jason.
Jun 19 19:16:33 jason-laptop systemd-logind[136]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
Jun 19 19:16:33 jason-laptop lightdm[141]: ** (process:284): WARNING **: Failed to open CK session: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The
Jun 19 19:16:34 jason-laptop gnome-session[365]: WARNING: Could not parse desktop file xscreensaver.desktop or it references a not found TryExec binary
Jun 19 19:16:34 jason-laptop gnome-session[365]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Jun 19 19:16:35 jason-laptop kernel: dconf worker[385]: segfault at 110 ip 00007f5a5ff7d32d sp 00007f5a57eab790 error 4 in libc-2.17.so[7f5a5ff46000+1a3000]
Jun 19 19:16:34 jason-laptop systemd-coredump[386]: Invalid number of arguments passed from kernel.
Jun 19 19:16:35 jason-laptop dbus-daemon[138]: dbus[138]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.serv
Jun 19 19:16:35 jason-laptop dbus[138]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service'
Jun 19 19:16:35 jason-laptop systemd[1]: Starting RealtimeKit Scheduling Policy Service...
Jun 19 19:16:35 jason-laptop dbus-daemon[138]: dbus[138]: [system] Successfully activated service 'org.freedesktop.RealtimeKit1'
Jun 19 19:16:35 jason-laptop dbus[138]: [system] Successfully activated service 'org.freedesktop.RealtimeKit1'
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Successfully called chroot.
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Successfully dropped privileges.
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Successfully limited resources.
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Running.
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Watchdog thread running.
Jun 19 19:16:35 jason-laptop systemd[1]: Started RealtimeKit Scheduling Policy Service.
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Canary thread running.
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Successfully made thread 397 of process 397 (/usr/bin/pulseaudio) owned by '1000' high priority at nice level 
Jun 19 19:16:35 jason-laptop rtkit-daemon[398]: Supervising 1 threads of 1 processes of 1 users.
Jun 19 19:16:36 jason-laptop dbus-daemon[138]: dbus[138]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
Jun 19 19:16:36 jason-laptop dbus[138]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
Jun 19 19:16:36 jason-laptop dbus-daemon[138]: dbus[138]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.servic
Jun 19 19:16:36 jason-laptop dbus[138]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service failed to load: 
Jun 19 19:16:36 jason-laptop pulseaudio[397]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.GetProperties() failed: org.freedesktop.systemd1.LoadFailed: Un
Jun 19 19:16:57 jason-laptop systemd[1]: Starting Getty on tty2...
Jun 19 19:16:57 jason-laptop systemd[1]: Started Getty on tty2.
Jun 19 19:16:59 jason-laptop login[411]: pam_unix(login:session): session opened for user jason by LOGIN(uid=0)
Jun 19 19:16:59 jason-laptop systemd-logind[136]: New session 2 of user jason.
Jun 19 19:16:59 jason-laptop login[411]: LOGIN ON tty2 BY jason
Jun 19 19:17:33 jason-laptop sudo[564]: jason : TTY=tty2 ; PWD=/home/jason ; USER=root ; COMMAND=/usr/bin/systemctl restart lightdm.service
Jun 19 19:17:33 jason-laptop sudo[564]: pam_unix(sudo:session): session opened for user root by jason(uid=0)
Jun 19 19:17:33 jason-laptop systemd[1]: Stopping Light Display Manager...
Jun 19 19:17:33 jason-laptop gnome-session[365]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Jun 19 19:17:33 jason-laptop lightdm[284]: pam_unix(lightdm:session): session closed for user jason
Jun 19 19:17:33 jason-laptop systemd-logind[136]: Removed session 1.
Jun 19 19:17:33 jason-laptop systemd[1]: Starting Light Display Manager...
Jun 19 19:17:33 jason-laptop systemd[1]: Started Light Display Manager.
Jun 19 19:17:33 jason-laptop sudo[564]: pam_unix(sudo:session): session closed for user root

Any ideas?

Its not a big issue, I just restarted lightdm and all is well, but I don't like it when these things happen randomly.

Last edited by jrussell (2013-06-19 17:25:34)


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#2 2013-06-19 19:34:40

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 330

Re: lightdm didnt start gnome

It seems you have some problems with activating 'dbus-org.bluez.service'.
A solution is described here and here (last comment).

Offline

#3 2013-06-29 18:18:35

Bqck
Member
Registered: 2013-06-29
Posts: 1

Re: lightdm didnt start gnome

henk wrote:

It seems you have some problems with activating 'dbus-org.bluez.service'.
A solution is described here and here (last comment).

I met the same problem and I removed "dbus-org.bluez.service" and "bluetooth.service". Then lightdm works like usual.
Thanks Henk.

Offline

#4 2013-06-29 19:04:19

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: lightdm didnt start gnome

I don't think that the bluez and Bluetooth errors are related to the login problem. The login problem seems completely random, and hardly ever happens, but it irritates me that it does happen.


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

Board footer

Powered by FluxBB