You are not logged in.

#1 2013-06-21 20:45:52

kjozsa
Member
Registered: 2008-06-05
Posts: 110

NVIDIA backlight on HP 8560w

I'd like to ask for some help. I have a HP 8560w notebook with an up to date Arch installation (as of today, 21/06/13). This notebook has an nvidia quadro 1000m and backlight control have been working correctly for years, right until a few weeks ago. Now it's all the way bumped to the max and I find no way to change it anymore. To my best knowledge, no configuration has been changed by me, so I suspect it's some newer package version.

What I tried to come around this problem (in no particular order):
- read the forums and wiki :)
- install and enable acpid as I discovered a related error in my Xorg log - no effect
- set the brightness manually via /sys/class/backlight/acpi_video0/brightness from root - echo works, nothing changes
- set the brightness via xbacklight - no effect
- alter the acpi boot parameter to vendor or legacy - either brightness control is gone from gnome3 menu or has no effect
- add Option        "RegistryDwords" "EnableBrightnessControl=1" to the nvidia device section of my Xorg config - no effect with or without it
- install and use nvidiabl + nvidiablctl - this one actually can turn down the brightness, but even it's max 127 value is way way too dim (almost unreadable), so it's no use for me

I'm slowly running out of ideas. Any more hints to try? Thanks in advance!

Offline

#2 2013-07-10 22:13:40

kjozsa
Member
Registered: 2008-06-05
Posts: 110

Re: NVIDIA backlight on HP 8560w

May I ping this one? Noone is running Arch on a HP/Nvidia notebook or noone cares about brightness?

Offline

#3 2013-07-19 06:13:17

majiq
Member
Registered: 2009-03-06
Posts: 259

Re: NVIDIA backlight on HP 8560w

I imagine the configuration is rarer than the backlight possibility. Have you tried downgrading to a point where it works again and then seeing what brings back the error. Alternatively, if you can run a quick live cd of another distro and backlight works there, you can maybe narrow it down from there and rule out hardware.

Offline

#4 2014-03-20 13:33:52

cafe
Member
Registered: 2014-03-20
Posts: 103

Re: NVIDIA backlight on HP 8560w

Hello,

I have the same computer as you and I've faced the same issue.
To solve it, I had to read the driver's source code a bit to understand the options passed when modprobing.
My video card is a Nvidia Quadro 1000M and it is supported by the driver as you can see here.

After you install the package nvidiabl from the aur you'll notice that /sys/class/backlight now lists two devices for adjusting backlight. acpi_video[0-9]/ and nvidia_backlight. To remove the first, you'll have to add the kernel parameter acpi_backlight=vendor to your bootloader. This will tell the kernel that you are using a custom backlight driver and that you don't want the default one to be loaded. In grub, this can be easily achieved by changing the fifth line of /etc/default/grub

GRUB_CMDLINE_LINUX="(..) acpi_backlight=vendor (...)"

And by running

# grub-mkconfig -o /boot/grub/grub.cfg

The user guillaumezin explained in his github that you can pass several options to the driver when modprobing. The ones that worked best for me were these : max=17000, min=50, off=0 (this will turn off screen when backlight is set to 0), screen_type=1 and model=nv5x.

You can try yours by running :

# modprobe -r nvidiabl
# modprobe nvidiabl max=17000 min=50 off=0 screen_type=1 model=nv5x

And changing these parameters. Note that the max registry value of 127 will always be the same. That's because the driver's interface should be the same if you want your software to work on different hardwares. 

Finally, when you have your perfect configuration, create the file /etc/modules-load.d/backlight.conf with the driver that you want to load on boot time : nvidiabl and set up the options in another file /etc/modprobe.d/backlight.conf with the contents :

 options nvidiabl max=(your_max) min=(your_min) off=(your_choice) screen_type=(your_config) model=(your_config)

Reboot and test the keyboard shortcuts. If you are using GNOME 3, it should work out of the box. For other desktops environments, you should probably map the keys to nvidiablctl commands.

Hope it helps,
Cheers,

Last edited by cafe (2014-03-20 13:36:04)

Offline

#5 2016-01-17 10:07:06

kikislater
Member
From: Mauritius
Registered: 2016-01-16
Posts: 1

Re: NVIDIA backlight on HP 8560w

cafe wrote:

Hello,

I have the same computer as you and I've faced the same issue.
To solve it, I had to read the driver's source code a bit to understand the options passed when modprobing.
My video card is a Nvidia Quadro 1000M and it is supported by the driver as you can see here.

After you install the package nvidiabl from the aur you'll notice that /sys/class/backlight now lists two devices for adjusting backlight. acpi_video[0-9]/ and nvidia_backlight. To remove the first, you'll have to add the kernel parameter acpi_backlight=vendor to your bootloader. This will tell the kernel that you are using a custom backlight driver and that you don't want the default one to be loaded. In grub, this can be easily achieved by changing the fifth line of /etc/default/grub

GRUB_CMDLINE_LINUX="(..) acpi_backlight=vendor (...)"

And by running

# grub-mkconfig -o /boot/grub/grub.cfg

The user guillaumezin explained in his github that you can pass several options to the driver when modprobing. The ones that worked best for me were these : max=17000, min=50, off=0 (this will turn off screen when backlight is set to 0), screen_type=1 and model=nv5x.

You can try yours by running :

# modprobe -r nvidiabl
# modprobe nvidiabl max=17000 min=50 off=0 screen_type=1 model=nv5x

And changing these parameters. Note that the max registry value of 127 will always be the same. That's because the driver's interface should be the same if you want your software to work on different hardwares. 

Finally, when you have your perfect configuration, create the file /etc/modules-load.d/backlight.conf with the driver that you want to load on boot time : nvidiabl and set up the options in another file /etc/modprobe.d/backlight.conf with the contents :

 options nvidiabl max=(your_max) min=(your_min) off=(your_choice) screen_type=(your_config) model=(your_config)

Reboot and test the keyboard shortcuts. If you are using GNOME 3, it should work out of the box. For other desktops environments, you should probably map the keys to nvidiablctl commands.

Hope it helps,
Cheers,

Good settings for this laptop model. I have got the same and It works very well with 17000 max.
I wonder if it works after suspend then wake up ....
Edit : Don't work after waking up until I have to type on the keyboard luminosity keys

I don't understand very well the 127 value. What is it, a percentage ?

$ cat /sys/class/backlight/nvidia_backlight/max_brightness
127

Last edited by kikislater (2016-01-17 10:31:16)

Offline

Board footer

Powered by FluxBB