You are not logged in.

#1 2013-06-22 10:37:38

JohnColeman
Member
From: Glasgow, Scotland
Registered: 2013-01-21
Posts: 12

downgrading package postgis (2.0.3-1 => 2.0.2-1)

I ran into trouble with a python 3 postgis program which used to work fine:

  File "/home/john/workspace/Tkstars/src/dalriada/tk/StarDAO.py", line 31, in __init__
    cur.execute("SELECT ra,ST_AsText(ST_TRANSFORM(hyg_line,40001))as line FROM meridians")
psycopg2.OperationalError: could not load library "/usr/lib/postgresql/postgis-2.0.so": /usr/lib/postgresql/postgis-2.0.so: undefined symbol: json_tokener_errors

some struggling later I did:

pacman -U postgis-2.0.2-1-x86_64.pkg.tar.xz in /var/cache/pacman/pkg.

Then AOK again:

[john@cart tk]$ python3 StarViewer.py
StarViewer - INFO - StarViewer starting
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.

Starviewer image via Wordpress

Last edited by JohnColeman (2013-08-21 11:10:03)

Offline

#2 2013-06-22 13:50:57

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,936

Re: downgrading package postgis (2.0.3-1 => 2.0.2-1)

JohnColman:  That picture is a bit bigger than permitted by  our policy, but as the size in bytes is not too bad, I am going to leave it be (I am in a good mode; just back from vacation smile ) Just be aware of the policy and consider using click through tumbnails.  Thanks


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB