You are not logged in.

#1 2013-06-23 15:55:19

josealb77
Member
Registered: 2013-06-23
Posts: 74

Error compiling mintmenu [SOLVED]

Hello,
I'm new and I don't know if it is here where I should post it or there is a more direct way to talk with the package maintainer like comments of the AUR package web, but here I go:
When I compile mintmenu-5.4.9-1-x86_64 I get this error when the "makepkg -s" command gets to mintMenu.py

patching file usr/lib/linuxmint/mintMenu/plugins/execute.py
Hunk #1 succeeded at 19 (offset -1 lines).
Listing '.'...
Compiling './capi.py'...
Compiling './compile.py'...
Compiling './keybinding.py'...
Compiling './mintMenu.py'...
***   File "./mintMenu.py", line 24
    except Exception, e:
                    ^
SyntaxError: invalid syntax

Compiling './mintMenuConfig.py'...
***   File "./mintMenuConfig.py", line 16
    except Exception, e:
                    ^
SyntaxError: invalid syntax

Compiling './mintRemove.py'...
***   File "./mintRemove.py", line 17
    except Exception, detail:
                    ^
SyntaxError: invalid syntax

Listing './plugins'...
Compiling './plugins/__init__.py'...
Compiling './plugins/applications.py'...
***   File "./plugins/applications.py", line 50
    print '%s took %0.3f ms' % (func.func_name, (t2-t1)*1000.0)
                           ^
SyntaxError: invalid syntax

Compiling './plugins/easybuttons.py'...
***   File "./plugins/easybuttons.py", line 106
    except Exception, e:
                    ^
SyntaxError: invalid syntax

Compiling './plugins/easyfiles.py'...
Compiling './plugins/easygconf.py'...
Compiling './plugins/easygsettings.py'...
Compiling './plugins/execute.py'...
***   File "./plugins/execute.py", line 11
    print elem
             ^
SyntaxError: invalid syntax

Compiling './plugins/filemonitor.py'...
***   File "./plugins/filemonitor.py", line 31
    except Exception, detail:
                    ^
SyntaxError: invalid syntax

Compiling './plugins/get_apt_cache.py'...
***   File "./plugins/get_apt_cache.py", line 12
    print "CACHE" + "###" + str(name) + "###" + str(summary) + "###" + str(description)
                ^
SyntaxError: invalid syntax

Compiling './plugins/places.py'...
***   File "./plugins/places.py", line 188
    except Exception, detail:
                    ^
SyntaxError: invalid syntax

Compiling './plugins/recent.py'...
Compiling './plugins/system_management.py'...
Listing './search_engines'...
==> Limpiando la instalación...
  -> Limpiando archivos innecesarios...
  -> Comprimiendo las páginas man e info...
  -> Quitando los símbolos no requeridos de los binarios y bibliotecas...
==> Creando paquete "mintmenu"...
  -> Generando el archivo .PKGINFO...
  -> Añadiendo install archivo...
  -> Generando archivo .MTREE...
  -> Comprimiendo el paquete...
==> Abandonando el entorno fakeroot.
==> Terminado haciendo: mintmenu 5.4.9-1 (dom jun 23 15:44:58 CEST 2013)

After that I can install mintmenu but it doesn't look like the Mint Menu, it has the structure but not the "favorites" section, not the grey background, not the icon menu, and some other things.
Is it any kind of coding error, or any version incompatibility between compiling versions?

Last edited by josealb77 (2013-06-24 10:41:24)

Offline

#2 2013-06-23 16:12:00

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,793
Website

Re: Error compiling mintmenu [SOLVED]

As I don't use any of the dependencies that this is to work with, I can only comment generally.

Posting here with this sort of question is good - you can then get help figuring out if something is misconfigured on your end, or if there is something wrong with the PKGBUILD.

You should also post on the packages comment page in the aur too - especially if/when you think there might be an issue with the PKGBUILD.

In this case, that is a highly "voted" package, and the maintainer seems quite active in keeping it up to date.  This means they'll probably have a good response for you quickly if you post on the aur page, but it also suggests the issue may be at your end.

EDIT: I'm horrible with python distribution steps, but I can't help but wonder if the 'cd $pkgdir/usr/...' is in the wrong place.  There is a loop that modifies all the python hashbangs appropriately to work in arch, but then it cd's to where the "pre-sed" copied versions are and compiles those.  I think the cd should be before the for loop.  But this would really be something to ask the maintainer.

Last edited by Trilby (2013-06-23 16:16:43)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-06-23 16:26:51

josealb77
Member
Registered: 2013-06-23
Posts: 74

Re: Error compiling mintmenu [SOLVED]

Thank you very much Trilby. I'm going to contact with the maintainer trough the AUR page too.

Offline

#4 2013-06-24 10:40:59

josealb77
Member
Registered: 2013-06-23
Posts: 74

Re: Error compiling mintmenu [SOLVED]

SOLVED: In the comments between 2013-05-21 12:20 and 2013-06-24 09:42 in the mintmenu AUR page you can find the solution https://aur.archlinux.org/packages/mintmenu/

Offline

Board footer

Powered by FluxBB