You are not logged in.

#1 2013-06-24 08:49:21

na5m
Member
From: Rancho Cordova, CA
Registered: 2008-11-19
Posts: 27

[SOLVED] f2fs partition will not mount during boot

sda1 = /boot (formatted as ext4)
sda2 = / (formatted as f2fs)

I need to somehow pass the -t f2fs to the
mount command as the initramfs is loading. Any ideas?

http://i1122.photobucket.com/albums/l53 … 3d9ff3.jpg



-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by na5m (2013-06-25 07:34:36)


Let's go check out Hades!

Offline

#2 2013-06-24 12:41:15

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: [SOLVED] f2fs partition will not mount during boot

You need to fix the problem mentioned by mount, not hack around it.

Offline

#3 2013-06-24 21:24:56

na5m
Member
From: Rancho Cordova, CA
Registered: 2008-11-19
Posts: 27

Re: [SOLVED] f2fs partition will not mount during boot

Oops! Thanks for fixing my faux pas, mod.

falconindy: the initramfs fully loads successfully. From the emergency shell,
I'm able to use the mount command and successfully mount sda2 onto /
Question is, how can I address the problem mentioned by mount
when the loading of initramfs is non-interactive?


Let's go check out Hades!

Offline

#4 2013-06-24 21:59:14

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] f2fs partition will not mount during boot

Not sure if this is what falconindy is referring to, but on the kernel command line it might help to specify the filesystem type.

Offline

#5 2013-06-24 22:04:33

cedeel
Member
From: ~
Registered: 2009-08-25
Posts: 171
Website

Re: [SOLVED] f2fs partition will not mount during boot

Perhaps give wipefs(8) a try?

Offline

#6 2013-06-24 22:11:13

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] f2fs partition will not mount during boot

cedeel wrote:

Perhaps give wipefs(8) a try?

Do you know what wipefs does?  That is definitely not what the OP wants to do here.

Offline

#7 2013-06-24 22:17:30

cedeel
Member
From: ~
Registered: 2009-08-25
Posts: 171
Website

Re: [SOLVED] f2fs partition will not mount during boot

Yes, I do know what wipefs does; I gave the man page a read since I didn't know beforehand.

If his partition indeed contains several signatures, then it would be advisable to remove the false one(s).

Offline

#8 2013-06-24 22:20:59

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] f2fs partition will not mount during boot

So I fail to understand how making the filesystem invisible is going to help mount it.

Offline

#9 2013-06-24 22:25:09

cedeel
Member
From: ~
Registered: 2009-08-25
Posts: 171
Website

Re: [SOLVED] f2fs partition will not mount during boot

If the case is that, in addition to a valid f2fs signature, there's also some other filesystem signature left over from previous use, that can confuse mount.
So, if there are ext4, xfs, btrfs, ntfs etc. signatures on the partition, it would be advisable to remove them.

Offline

#10 2013-06-24 23:42:50

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,365

Re: [SOLVED] f2fs partition will not mount during boot

Agreed with falconindy and cedeel. It's worth mentioning that, despite it's scary name, wipefs doesn't do anything the the filesystem by default.

# wipefs /dev/sda2

will simply show you what filesystems the partition identifies as, including the offset of their signatures. It's a simple matter of then using wipefs with the -o flag and the offset to remove the offending signature.

Of course, it's always a good idea to back up any important/irreplaceable data before messing with partitions.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#11 2013-06-24 23:50:16

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 921

Re: [SOLVED] f2fs partition will not mount during boot

you have f2fs-tools and f2fs in the MODULES in the /etc/mkinitcpio.conf and rebuilding the initramfs and rotfs=f2fs in the bootloader options??


Well, I suppose that this is somekind of signature, no?

Offline

#12 2013-06-25 07:33:52

na5m
Member
From: Rancho Cordova, CA
Registered: 2008-11-19
Posts: 27

Re: [SOLVED] f2fs partition will not mount during boot

Thanks everyone. wipefs was the fix.
Linux was telling me what the solution
was, but was too blind to see (and more than a little scared
of a command named wipefs) smile
Arch boots like a charm now.

http://i1122.photobucket.com/albums/l53 … 9bfd65.jpg

wipefs -f -o 0x10040 /dev/sda2 did the trick.
I had to use -f because the sda2 was mounted.

Funny thing is now that I'm in Arch proper, when I run
wipefs, the btrfs entry still shows up, but with a different
offset. No big deal, I guess. I'm just happy that I can
boot into Arch.

http://i1122.photobucket.com/albums/l53 … 1599ae.jpg

We can mark this thread as solved. Thanks again, everyone.


Let's go check out Hades!

Offline

Board footer

Powered by FluxBB