You are not logged in.

#1 2013-07-02 14:49:08

Tanizaki
Member
Registered: 2013-05-01
Posts: 4

Bug? flashplugin crashes, downgrading libvdpau solves it

Since this morning Flash has been crashing both in Firefox and Chromium in my 64bits installation.
Making the suggested changes to /etc/adobe/mms.cfg makes no difference.
After downgrading libvdpau (0.6-2 => 0.6-1) flashplugin works normally again.

Did I find a bug or am I doing something wrong?

EDIT: Oh! https://bbs.archlinux.org/viewtopic.php?id=145408

Last edited by Tanizaki (2013-07-02 14:52:18)

Offline

#2 2013-07-02 21:55:36

BrainWorker
Member
Registered: 2011-02-23
Posts: 26

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

I have the same problem.

Offline

#3 2013-07-03 07:49:18

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

So from the thread you linked, solutions are
https://bbs.archlinux.org/viewtopic.php … 7#p1154347 and
https://bbs.archlinux.org/viewtopic.php … 7#p1163327

Although I'd be very careful of the -c option when removing things with pacman. (I doubt -c is actually necessary)


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#4 2013-07-03 07:56:18

BrainWorker
Member
Registered: 2011-02-23
Posts: 26

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

pacman -Rs flashplugin
rm -rf ~/.adobe/
pacman -S flashplugin

This did not help me.

Every video on youtube is like this anyway:

http://www.imageup.ru/img280/1392524/flash.png


-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Offline

#5 2013-07-03 08:52:30

gsg
Member
Registered: 2008-02-08
Posts: 14

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Same problem here.

pacman -Rs flashplugin
rm -rf ~/.adobe/
pacman -S flashplugin

This did not help me too.

But downgrading libvdpau (0.6-2 => 0.6-1)  solves the problem.

Offline

#6 2013-07-03 13:10:19

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,742

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Disable acceleration in /etc/adobe/mms.cfg

Also if you are using chromium you should use chromium-pepper-flash from aur.

Last edited by Mr.Elendig (2013-07-03 13:10:48)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#7 2013-07-05 16:18:35

Tanizaki
Member
Registered: 2013-05-01
Posts: 4

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Mr.Elendig wrote:

Disable acceleration in /etc/adobe/mms.cfg

Do you mean setting EnableLinuxHWVideoDecode to 0?
It doesn't make any difference in Firefox, Flash still crashes with libdvpau 0.6-2

Mr.Elendig wrote:

Also if you are using chromium you should use chromium-pepper-flash from aur.

This works for Chromium.

Offline

#8 2013-07-05 22:57:23

semeion
Member
From: Brazil
Registered: 2008-10-20
Posts: 56

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Offline

#9 2013-07-06 23:20:38

Etharius
Member
Registered: 2013-07-06
Posts: 1

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

gsg wrote:

But downgrading libvdpau (0.6-2 => 0.6-1)  solves the problem.

Confirmed. Downgrading to libvdpau-0.6-1 solved the problem for me too.

Offline

#10 2013-07-08 03:22:04

Kebertx
Member
Registered: 2012-01-02
Posts: 69

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Doesn't the "2" in "0.6-2" represent just the pkgrel? I'm looking at the PKGBUILD for libvdpau, and it seems that 0.6-2 is really using the same source as 0.6-1. I just downgraded that way since I didn't have the old package anymore, and it hasn't helped at all. Can someone point me to a source for the working libvdpau downgrade package?

Offline

#11 2013-07-10 11:03:01

BrainWorker
Member
Registered: 2011-02-23
Posts: 26

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

After upgrading of mesa and nouveau-dri youtube videos seem to work but not always. Sometimes they start normally, sometimes they crash, greatly slowing down my system. So downgrading libvdpau to 0.6-1 is still best option.

Last edited by BrainWorker (2013-07-10 11:39:01)

Offline

#12 2013-07-10 11:24:07

progandy
Member
Registered: 2012-05-17
Posts: 2,152

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Kebertx wrote:

Doesn't the "2" in "0.6-2" represent just the pkgrel? I'm looking at the PKGBUILD for libvdpau, and it seems that 0.6-2 is really using the same source as 0.6-1. I just downgraded that way since I didn't have the old package anymore, and it hasn't helped at all. Can someone point me to a source for the working libvdpau downgrade package?

Find 0.6-1 in the ARM http://arm.konnichi.com/

The difference is 0.6-2 is compiled with DRI2-support while 0.6-1 is not. This apparently exposed a bug in the nouveau driver.

Last edited by progandy (2013-07-10 11:25:58)

Offline

#13 2013-07-19 17:56:26

ElegantMonkey
Member
From: São Paulo, Brazil
Registered: 2013-07-19
Posts: 2

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

progandy wrote:

Find 0.6-1 in the ARM http://arm.konnichi.com/

The difference is 0.6-2 is compiled with DRI2-support while 0.6-1 is not. This apparently exposed a bug in the nouveau driver.

I don't think it is a bug with nouveau... I'm using the proprietary NVidia drivers and the same thing happens to me.


Bite my shiny metal ass!

Offline

#14 2013-08-06 21:20:35

BrainWorker
Member
Registered: 2011-02-23
Posts: 26

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

New version of libvdpau 0.7-1 does not change anything :-(

Youtube videos take long time to load with impossibility to use browser and with "crash" window after all.

Last edited by BrainWorker (2013-08-06 21:21:05)

Offline

#15 2014-04-27 20:16:33

BrainWorker
Member
Registered: 2011-02-23
Posts: 26

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Still the same problem sad

Offline

#16 2014-07-01 19:44:21

BrainWorker
Member
Registered: 2011-02-23
Posts: 26

Re: Bug? flashplugin crashes, downgrading libvdpau solves it

Version 0.8-1 of libvdpau just came out, but it does not change anything either :-(

Every attempt to watch online video ends with crash message.

Am I doing anything wrong?

Offline

Board footer

Powered by FluxBB