You are not logged in.

#1 2013-07-03 01:31:06

thrashrokz33
Member
Registered: 2013-02-08
Posts: 29

[SOLVED] NetworkManager stuck on "Configuring Interface"

I'm running NetworkManager in KDE. It recognizes my wireless network, but when I attempt to connect to it, it sits on "Configuring Interfaces" for a few seconds, and then prompts me for my network password. After entering the correct password, the process repeats. I've verified that the password is correct.

I'm not sure if NetworkManager is conflicting with something else or not. I do have netctl installed, and the wireless was connecting fine before installing NetworkManager. If removing NetworkManager is the solution, then is there any other way I can get a network icon in KDE, similar to nm-applet?

Last edited by thrashrokz33 (2013-07-04 20:19:11)

Offline

#2 2013-07-03 02:43:30

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] NetworkManager stuck on "Configuring Interface"

You should actually check to see if there is anything conflicting there.  You can use systemctl to dump all the active units into the pager.  Then you can peruse that list to see if you can find other things that might be trying to handle the network.  Did you actually disable netctl before trying to get network manager going?

A good place to start with wireless/network debugging (or debugging in general) is to try setting things up with the most basic of tools.  In this case it would be wpa_supplicant and dhcpcd.  If that works then you at least know it is an issue with networkmanager and not with the HW itself.

Offline

#3 2013-07-03 21:21:51

thrashrokz33
Member
Registered: 2013-02-08
Posts: 29

Re: [SOLVED] NetworkManager stuck on "Configuring Interface"

So I disabled my netctl service, which actually got the wifi to connect through NetworkManager. Overjoyed, I rebooted just to make sure that it would still function, and now the hardware wifi switch will not turn the wifi LED on, and only the wired connection is recognized now.

Offline

#4 2013-07-03 23:27:53

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] NetworkManager stuck on "Configuring Interface"

Install rfkill.  It is a utility to control the rfkill subsystem.  The interface might be initialized in a "soft blocked" state.  It *shouldn't* be, but that doesn't mean that it absolutely won't. 

After you install the rfkill package, do "rfkill list" and see if the interface in question is being blocked.  If you see anything that is being blocked that shound't be (or if you just see anything blocked at all), try doing "rfkill unblock all" as root.  Then test again.

You might also want to make sure that the udev is recognizing and loading a module for your device.  Use "lspci -k", and it will show you all the attached pci devices and the modules loaded for each (as well as what modules are available for each device if there is more than one).

If it is just an rfkill problem, there may be a way to get the device to load in an "unblocked" fashion.  But if you can't figure that out, there are a couple systemd service files that are included with the rfkill package that can automate this process on boot.

Offline

#5 2013-07-04 20:18:56

thrashrokz33
Member
Registered: 2013-02-08
Posts: 29

Re: [SOLVED] NetworkManager stuck on "Configuring Interface"

Thanks Woofy. I did a full system update, and for whatever reason, everything is working. The wireless connects fine. Marking as solved for now.

Offline

#6 2013-07-04 21:04:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] NetworkManager stuck on "Configuring Interface"

You should still look into rfkill if you don't know how to use it already.  There is a pretty good chance that at some point you will find your interface soft blocked.  Knowing what to do about it is really quite ideal.

Offline

Board footer

Powered by FluxBB