You are not logged in.

#1 2013-05-21 06:06:29

somodi
Member
Registered: 2013-05-21
Posts: 7

carl9170 problems

Hi everyone!
I have problems with my wireless connection. It's very poor, it's delaying to load every webpage, also router's config panel.
Googlying I arrived to this: https://patchwork.kernel.org/patch/2174121/
It's the same message that I've read in my dmesg.
¿Is there any way to know if this patch is in in my kernel? ¿Or any easy way to patch my module?
¿Is there any workarround changing router's protocol / security?

Thank you very much for the information or similar experience that anyone can share.

Pablo.

3.9.2-1-ARCH #1 SMP PREEMPT Sat May 11 20:31:08 CEST 2013 x86_64 GNU/Linux

Offline

#2 2013-05-21 06:33:59

pam
Member
Registered: 2012-12-21
Posts: 27

Re: carl9170 problems

Through Arch linux there is no easy way to troubleshoot.

Either RMA your router or change it for another or try other linux....other than that its pretty much a dead end.


Main workstation: HP-Pavilion G6-2005ax, AMD quad core trinity APU(devastator) with 7640 HD 512 MB radeon + 7670m 1GB Gddr3 dedicated, 240 gb zalman ssd, 8GB ddr 3 1600mhz, OS: Arch 2013, Ultimate 3.4 lite, Windows 8.
Moderator at www.ultimateeditionoz.com Admin at:http://forumubuntusoftware.info

Offline

#3 2013-05-22 02:26:33

somodi
Member
Registered: 2013-05-21
Posts: 7

Re: carl9170 problems

Thanks for the recomendation.
I think my router it's not the problem. With the same hardware in Win7 the wireless adapter works great. Also with other computers.
Indeed this is not a problem to "troubleshoot"... it's (as I understand) something like broken driver in kernel that needs a patch.

Thanks in advance for any collaboration.

[  812.907791] WARNING: at drivers/net/wireless/ath/carl9170/tx.c:992 carl9170_op_tx+0x87d/0x8c0 [carl9170]()
[  812.907795] Modules linked in: arc4 carl9170 ath mac80211 cfg80211 rfkill saa7115 snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_device stk1160 snd_ac97_codec videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common ac97_bus videodev media coretemp kvm_intel kvm fuse snd_hda_codec_via nvidia(PO) snd_hda_intel snd_hda_codec snd_hwdep snd_pcm crc32c_intel drm mxm_wmi iTCO_wdt snd_page_alloc snd_timer iTCO_vendor_support gpio_ich r8169 snd lpc_ich i2c_i801 i2c_core i7core_edac edac_core microcode evdev soundcore mii asus_atk0110 wmi button acpi_cpufreq mperf processor vboxnetflt(O) vboxdrv(O) ext4 crc16 mbcache jbd2 sd_mod hid_generic sr_mod cdrom usbhid hid firewire_ohci ahci firewire_core crc_itu_t libahci libata ehci_pci xhci_hcd ehci_hcd scsi_mod usbcore usb_common
[  812.907885]  [<ffffffffa00ed1bd>] carl9170_op_tx+0x87d/0x8c0 [carl9170]
[  812.908050]  [<ffffffffa00e5432>] ? carl9170_usb_submit_rx_urb+0x92/0xd0 [carl9170]
[  812.908055]  [<ffffffffa00e5965>] ? carl9170_usb_rx_complete+0x75/0x100 [carl9170]
[  812.908090]  [<ffffffffa00ee0f4>] __carl9170_rx+0x2d4/0xae0 [carl9170]
[  812.908095]  [<ffffffffa00ee988>] carl9170_rx_stream+0x88/0x400 [carl9170]
[  812.908099]  [<ffffffffa00eed25>] carl9170_rx+0x25/0x32 [carl9170]
[  812.908104]  [<ffffffffa00e5c10>] carl9170_usb_tasklet+0xb0/0xe0 [carl9170]

Last edited by somodi (2013-05-22 02:31:08)

Offline

#4 2013-06-24 00:03:59

somodi
Member
Registered: 2013-05-21
Posts: 7

Re: carl9170 problems

I've also have seen that with lts kernel it works perfect.
I will stay with this option instead of using ndiswrapper with the Windows XP 64bits driver (an acceptable workarround).
What happens when mantainers upgrade the kernel in the repositories lts to this buggy version?

Offline

#5 2013-06-24 00:49:01

Gulver
Member
Registered: 2013-05-24
Posts: 208

Re: carl9170 problems

What is your specific hardware? did you try to recompile your driver?

Offline

#6 2013-06-24 01:22:02

somodi
Member
Registered: 2013-05-21
Posts: 7

Re: carl9170 problems

Hi! Thks for your answer. The dongle is:  TP-Link TL-WN822N Ver. 1.1
I didn't try it. I think that I should try to recompile an old version of this module without this new bug. But I have not idea where to start smile
Thanks in advance.

Offline

#7 2013-06-24 02:37:09

Gulver
Member
Registered: 2013-05-24
Posts: 208

Re: carl9170 problems

Try both and see if any works.

I also am having a similar problem, bugs are everywhere, drivers are old...

Offline

#8 2013-06-25 02:18:48

somodi
Member
Registered: 2013-05-21
Posts: 7

Re: carl9170 problems

Do you know where I can look info for compiling old version just a single module without going to an old kernel?

Offline

#9 2013-06-25 05:10:38

gilmoreja
Member
From: Florida
Registered: 2012-05-28
Posts: 71

Re: carl9170 problems

I use carl9170, and I have to use the noht=1 option for that driver, or my adapter will stop responding during periods of high throughput. Unfortunately, it seems like it's just a very poor driver. For a long time I had to also use the nohwcrypt option for my adapter to work at all (though, after some update to the driver I no longer have to use that option).

I don't use the same adapter that you do, but try using one or both of those options and see if your situation improves. The hwcrypt in particular is a known problem with the driver, as stated in the info page on wireless.kernel.org.

If you're unsure what that means, then here's an example.

Create /etc/modprobe.d/modprobe.conf and add these two lines

options carl9170 nohwcrypt=1
options carl9170 noht=1

Then you can try commenting out one or the other to see what you can get away with. Make sure you reboot to get the effect.

Last edited by gilmoreja (2013-06-25 05:11:36)


Time you enjoy wasting isn't wasted time.

Offline

#10 2013-07-04 04:32:15

somodi
Member
Registered: 2013-05-21
Posts: 7

Re: carl9170 problems

Thanks for the tip. It's working very fine with noht=1 only. The same as you.
Wich brand and model is your adapter?  If there is someone with the same problem it will helps.
Really thanks!

Offline

Board footer

Powered by FluxBB